master volume does not work with snd-hda-intel on HP Elite 8200

Bug #881340 reported by Beastyvoid
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

When changing the volume Up and Down in Ubuntu 11.10 oneiric, the audio volume does not change at all.
If you, for example use KWin (or alsamixer) to lower the "Master volume" from 100% to 0%, the volume does not decrease at all, until it reaches 0%. There it is muted. Alsamixer, Kwin, volume button, they all make the same behaviour. It is probably a gstreamer problem, or parameter for the kernel module snd-hda-intel.

If you change the volume of the PCM output sound in alsamixer, it works, reflecting the actual value. But master volume doesn't.

Hardware sound card :
cat /proc/asound/cards
 0 [PCH ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xfa020000 irq 48

lspci -k -v -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
        Subsystem: Hewlett-Packard Company Device 1494
        Flags: bus master, fast devsel, latency 0, IRQ 48
        Memory at fa020000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Root Complex Link
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

dmidecode :

System Information
        Manufacturer: Hewlett-Packard
        Product Name: HP Compaq 8200 Elite CMT PC

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
Revision history for this message
jlindbergh (jlindbergh) wrote :

I have the exact same model machine, and is of course also affected by this. I also noticed that if I go to Sound settings and turn Output volume (master volume) up above 100% it actually increases the volume. Other than that I only have two volume ranges: off/muted - if I turn it all the way down, and "on" - if I have the slider somewhere between 1%-100%.

Revision history for this message
Morten Breum (mortenbreum) wrote :

I also noticed the described behavior since upgrading to 11.10.
I have searched high and low and found this bug - and also https://help.ubuntu.com/community/HdaIntelSoundHowto in which I found that adding a line to /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=eeepc-p701
made the volume controls work well on my eee-machine.
Perhaps you can also work around the issue by setting the model parameter manually...

Revision history for this message
Lars Risan (lars-risan) wrote :

Just wto add that I also have this bug on my Dell Inspirion Zino, with this sound card:

lars@eple:~$ cat /proc/asound/cards
 0 [SB ]: HDA-Intel - HDA ATI SB
                      HDA ATI SB at 0xfe5f8000 irq 16
 1 [HDMI ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfe7e8000 irq 19

Revision history for this message
Lars Risan (lars-risan) wrote :

And then, I tried the trick that worked for Morten, and I did not get it to work.

Find it very difficult to figure out what MODEL to write in thins line:
options snd-hda-intel model=MODEL

I tried:
options snd-hda-intel model=dell-eq

Found that on one link form the page that Morten linked to, but I was not able to retrieve the right MODEL from my own machine. Seems like it should be some generic vendor-term, not the specific sound-card model name.

Anyone got any clue? How exactly did you find your "eeepc-p701", Morten?

Revision history for this message
Beastyvoid (yvan-skywalker) wrote :

I tried Morten tricks but it did not work for me. With that I had sound output only on the rear connector and not anymore on the front connector, and the volume still did not work.

To see the particular version you're using you need this :

head /proc/asound/card0/codec#0 : the "codec" info gives you the particular driver

then have a look for this driver in this file :
/usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz : search for your model (ALC662 for me).
There you can see the proper variant of the driver (for me the eeepc-p701, but still not working)

Revision history for this message
Lars Risan (lars-risan) wrote :

Ha! Thanks Beastyvoid and Morten!

It worked for me, on my Kubuntu 11.10, on a Dell Inspirion Zino HD.

Added
options snd-hda-intel model=dell

to

/etc/modprobe.d/alsa-base.conf

The bug was only related to the "master volume", that had no other levels but 0% and 100% -- all other sound stuff worked fine, including adjusting volume on individual channels, like Youtube or Amarok.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers