totem-plugin-viewer crashed with SIGSEGV in g_type_check_instance_is_a()

Bug #859060 reported by tr33m4n on 2011-09-25
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Medium
Unassigned
totem (Ubuntu)
Undecided
Unassigned

Bug Description

Totem crashed when clicking the small play button to preview a sound file in the itunes store preview thingy... more specifically this address http://itunes.apple.com/us/album/nine-oclock-single/id465976129?ls=1

Description: Ubuntu oneiric (development branch)
Release: 11.10
libgstreamer0.10-0:
  Installed: 0.10.35-1
  Candidate: 0.10.35-1
  Version table:
 *** 0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-plugins-base:
  Installed: 0.10.35-1
  Candidate: 0.10.35-1
  Version table:
 *** 0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-plugins-good:
  Installed: 0.10.30-1ubuntu7
  Candidate: 0.10.30-1ubuntu7
  Version table:
 *** 0.10.30-1ubuntu7 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-alsa:
  Installed: 0.10.35-1
  Candidate: 0.10.35-1
  Version table:
 *** 0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-audiosink:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-plugins-bad:
  Installed: 0.10.22-2ubuntu4
  Candidate: 0.10.22-2ubuntu4
  Version table:
 *** 0.10.22-2ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-plugins-ugly:
  Installed: 0.10.18-3ubuntu1
  Candidate: 0.10.18-3ubuntu1
  Version table:
 *** 0.10.18-3ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-ffmpeg:
  Installed: 0.10.12-1ubuntu1
  Candidate: 0.10.12-1ubuntu1
  Version table:
 *** 0.10.12-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-pulse:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-gconf:
  Installed: 0.10.30-1ubuntu7
  Candidate: 0.10.30-1ubuntu7
  Version table:
 *** 0.10.30-1ubuntu7 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-tools:
  Installed: 0.10.35-1
  Candidate: 0.10.35-1
  Version table:
 *** 0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-audiosource:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-doc:
  Installed: (none)
  Candidate: 0.10.35-1
  Version table:
     0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
libgstreamer0.10-dev:
  Installed: (none)
  Candidate: 0.10.35-1
  Version table:
     0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-videosink:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-videosource:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-gnonlin:
  Installed: (none)
  Candidate: 0.10.17-2
  Version table:
     0.10.17-2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-gnonlin-dbg:
  Installed: (none)
  Candidate: 0.10.17-2
  Version table:
     0.10.17-2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-gnonlin-doc:
  Installed: (none)
  Candidate: 0.10.17-2
  Version table:
     0.10.17-2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-nice:
  Installed: 0.1.0-2ubuntu1
  Candidate: 0.1.0-2ubuntu1
  Version table:
 *** 0.1.0-2ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-plugins-base-apps:
  Installed: 0.10.35-1
  Candidate: 0.10.35-1
  Version table:
 *** 0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-plugins-base-dbg:
  Installed: (none)
  Candidate: 0.10.35-1
  Version table:
     0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-x:
  Installed: 0.10.35-1
  Candidate: 0.10.35-1
  Version table:
 *** 0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-gnomevfs:
  Installed: (none)
  Candidate: 0.10.35-1
  Version table:
     0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-plugins-bad-dbg:
  Installed: (none)
  Candidate: 0.10.22-2ubuntu4
  Version table:
     0.10.22-2ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-plugins-base-doc:
  Installed: (none)
  Candidate: 0.10.35-1
  Version table:
     0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-camerabin:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-plugins-really-bad:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-plugins-good-doc:
  Installed: (none)
  Candidate: 0.10.30-1ubuntu7
  Version table:
     0.10.30-1ubuntu7 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-visualization:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-plugins-good-dbg:
  Installed: (none)
  Candidate: 0.10.30-1ubuntu7
  Version table:
     0.10.30-1ubuntu7 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-pulseaudio:
  Installed: 0.10.30-1ubuntu7
  Candidate: 0.10.30-1ubuntu7
  Version table:
 *** 0.10.30-1ubuntu7 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-qapt:
  Installed: (none)
  Candidate: 1.2.1-0ubuntu2
  Version table:
     1.2.1-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-fluendo-mp3:
  Installed: 0.10.15.debian-1
  Candidate: 0.10.15.debian-1
  Version table:
 *** 0.10.15.debian-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
        100 /var/lib/dpkg/status
libgstreamer0.10-0-dbg:
  Installed: (none)
  Candidate: 0.10.35-1
  Version table:
     0.10.35-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
gstreamer0.10-plugins-ugly-dbg:
  Installed: (none)
  Candidate: 0.10.18-3ubuntu1
  Version table:
     0.10.18-3ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-plugins-bad-multiverse:
  Installed: 0.10.21-1
  Candidate: 0.10.21-1
  Version table:
 *** 0.10.21-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/multiverse amd64 Packages
        100 /var/lib/dpkg/status
gstreamer0.10-plugins-ugly-multiverse:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-buzztard:
  Installed: (none)
  Candidate: 0.5.0-2
  Version table:
     0.5.0-2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-plugins-cutter:
  Installed: (none)
  Candidate: 1.1.7-1
  Version table:
     1.1.7-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-lame:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-buzztard-doc:
  Installed: (none)
  Candidate: 0.5.0-2
  Version table:
     0.5.0-2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-ffmpeg-dbg:
  Installed: (none)
  Candidate: 0.10.12-1ubuntu1
  Version table:
     0.10.12-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-packagekit:
  Installed: (none)
  Candidate: 0.6.18-1
  Version table:
     0.6.18-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-plugins-farsight:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-schroedinger:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-sdl:
  Installed: (none)
  Candidate: 0.10.22-2ubuntu4
  Version table:
     0.10.22-2ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-plugins-bad-doc:
  Installed: (none)
  Candidate: 0.10.22-2ubuntu4
  Version table:
     0.10.22-2ubuntu4 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-x264:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-plugins-ugly-doc:
  Installed: (none)
  Candidate: 0.10.18-3ubuntu1
  Version table:
     0.10.18-3ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-pocketsphinx:
  Installed: (none)
  Candidate: 0.5.1+dfsg1-0ubuntu2
  Version table:
     0.5.1+dfsg1-0ubuntu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/universe amd64 Packages
gstreamer0.10-fluendo-mpegdemux:
  Installed: (none)
  Candidate: (none)
  Version table:
gstreamer0.10-plugins-bad-multiverse-dbg:
  Installed: (none)
  Candidate: 0.10.21-1
  Version table:
     0.10.21-1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ oneiric/multiverse amd64 Packages
gstreamer0.10-pitfdll:
  Installed: (none)
  Candidate: (none)
  Version table:

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libgstreamer0.10-0 0.10.35-1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu1
Architecture: amd64
Date: Sun Sep 25 18:28:40 2011
ExecutablePath: /usr/lib/totem/totem-plugin-viewer
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110901)
ProcCmdline: /usr/lib/totem/totem-plugin-viewer --plugin-type narrowspace --user-agent Quicktime/7.6.6 --referrer http://itunes.apple.com/us/album/nine-oclock-single/id465976129?ls=1 --mimetype video/quicktime --no-controls --no-autostart
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fa9e1bd6400 <g_type_check_instance_is_a+112>: testb $0x4,0x16(%rdi)
 PC (0x7fa9e1bd6400) ok
 source "$0x4" ok
 destination "0x16(%rdi)" (0x00000dba) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: gstreamer0.10
StacktraceTop:
 g_type_check_instance_is_a () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_get () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
 ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
 g_object_get_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: totem-plugin-viewer crashed with SIGSEGV in g_type_check_instance_is_a()
UpgradeStatus: Upgraded to oneiric on 2011-09-25 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tr33m4n (tr33m4n) wrote :
visibility: private → public

StacktraceTop:
 g_type_check_instance_is_a (type_instance=<optimized out>, iface_type=<optimized out>) at /build/buildd/glib2.0-2.29.92/./gobject/gtype.c:3952
 g_object_get (_object=0x7fa9e6030ae0, first_property_name=0x7fa9d4a8e3be "volume") at /build/buildd/glib2.0-2.29.92/./gobject/gobject.c:1881
 gst_play_sink_get_volume (playsink=0x7fa9e5d08140) at gstplaysink.c:806
 gst_play_bin_get_property (object=0x7fa9e5d04a20, prop_id=<optimized out>, value=0x7fff7410b4d0, pspec=<optimized out>) at gstplaybin2.c:2009
 object_get_property (value=0x7fff7410b4d0, pspec=<optimized out>, object=0x7fa9e5d04a20) at /build/buildd/glib2.0-2.29.92/./gobject/gobject.c:1138

Changed in gstreamer0.10 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
Changed in totem (Ubuntu):
status: New → Confirmed
Key Schmidt (khbgschmidt) wrote :

new installed system 64-bit

Vadim Peretokin (vperetokin) wrote :

Happened to me as well when trying to reload http://cluster.quantumart.ru/broadcast/default.aspx?media=rusradio

Moritz Naumann (mnaumann) wrote :

It also happened to me while trying to access http://chinascout.ru/music/gump/09.mp3 in Firefox

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers