Banshee crashes after playing a few seconds through the USB headset

Bug #845148 reported by Francis J. Lacoste on 2011-09-08
62
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Medium
Unassigned

Bug Description

Since I upgraded to Oneiric, whenever I try to play a mp3 file in Banshee (doesn't seem to matter which mp3 file), it plays for a 2-5 seconds and then crashes.

That's systemic when I use the 'Logitech USB headset' as the output source. When I use the external speakers (connected through the line-out), it seems to work (although when i first tried it Banshee froze the whole unity desktop while the file continued playing.) But trying again after that worked.

It never works when I try to play over the USB headset.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: libgstreamer0.10-0 0.10.35-1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.22.1-0ubuntu2
Architecture: amd64
AssertionMessage: banshee: ../../src/xcb_io.c:178: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.
CrashCounter: 1
Date: Thu Sep 8 16:48:12 2011
ExecutablePath: /usr/lib/banshee/Banshee.exe
InterpreterPath: /usr/bin/mono
ProcCmdline: banshee /usr/lib/banshee/Banshee.exe --redirect-log --play-enqueued
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_CA.UTF-8
Signal: 6
SourcePackage: gstreamer0.10
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 __assert_fail () from /lib/x86_64-linux-gnu/libc.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
Title: Banshee.exe assert failure: banshee: ../../src/xcb_io.c:178: dequeue_pending_request: Assertion `!xcb_xlib_unknown_req_in_deq' failed.
UpgradeStatus: Upgraded to oneiric on 2011-09-08 (0 days ago)
UserGroups: adm admin cdrom dialout fuse libvirtd lpadmin plugdev sambashare vboxusers

Francis J. Lacoste (flacoste) wrote :

StacktraceTop:
 mono_handle_native_sigsegv (signal=<optimized out>, ctx=<optimized out>) at mini-exceptions.c:2245
 <signal handler called>
 __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
 __GI_abort () at abort.c:92
 __GI___assert_fail (assertion=0x7f317ec8b705 "!xcb_xlib_unknown_req_in_deq", file=<optimized out>, line=178, function=<optimized out>) at assert.c:81

Changed in gstreamer0.10 (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Francis J. Lacoste (flacoste) wrote :

Hmm, it now works also for the USB headset...

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2012-02-27
visibility: private → public
tags: added: precise
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers