/usr/bin/gst-launch not available

Bug #82753 reported by Tommi Asiala on 2007-02-01
6
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gstreamer0.10-tools

Since there is only /usr/bin/gst-launch-0.10 but no /usr/bin/gst-launch gnome-power-manager can't play sounds.

[gpm_sound_force] gpm-sound.c:86 (23:59:40): Couldn't execute command: gst-launch filesrc location=/usr/share/gnome-power-manager/gpm-critical-power.wav ! decodebin ! audioconvert ! gconfaudiosink

This has been discussed at gnome-power-manager's bugzilla
http://bugzilla.gnome.org/show_bug.cgi?id=365700#c11

Using Feisty.

Sebastian Dröge (slomo) wrote :

gst-launch is in the unversioned gstreamer-tools package. g-p-m should depend/recommend it if it's needed or call gst-launch-0.10 directly.

Simon Law (sfllaw) wrote :

I agree that gnome-power-manager is not using gstreamer properly. At the very least, it should call gst-launch-0.10 directly.

Changed in gnome-power-manager:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Richard Hughes (richard-hughes) wrote :

Simon, could you comment on the upstream bug how g-p-m should do this? I don't want to link in gstreamer but could change to use gst-launch-0.10 if this is what we should do. Thanks.

Ted Gould (ted) wrote :

Reassigning to GStreamer as there should always be a gst-launch as per the GNOME bug.

Thanks. Ted.

Savvas Radevic (medigeek) wrote :

Perhaps the developers could take a look at how the "tclsh" command is handled between tcl8.4 and tcl8.5

Savvas Radevic (medigeek) wrote :

tcl8.5:
set -e

if [ "$1" = "configure" ]; then
    update-alternatives --install /usr/bin/tclsh tclsh /usr/bin/tclsh8.5 840 \
   --slave /usr/share/man/man1/tclsh.1.gz tclsh.1 \
    /usr/share/man/man1/tclsh8.5.1.gz
fi

tcl8.4:
if [ "$1" = "configure" ]; then
    update-alternatives --install /usr/bin/tclsh tclsh /usr/bin/tclsh8.4 841 \
   --slave /usr/share/man/man1/tclsh.1.gz tclsh.1 \
   /usr/share/man/man1/tclsh8.4.1.gz
fi

Savvas Radevic (medigeek) wrote :

(I mean the package developers, not upstream)

Pedro Villavicencio (pedro) wrote :

Thanks for the report Tommi Asiala , It has been a long time without any comment or a duplicate in this bug report and It is possible that the bug has been fixed. May you please try to reproduce it with the latest Stable Release of Ubuntu the Natty Narwhal and add the respective comments to the report? You can learn how to get that release at http://www.ubuntu.com/download . Thanks again and we appreciate your help.

Changed in gstreamer0.10 (Ubuntu):
status: Confirmed → Incomplete
Tommi Asiala (tommi-asiala) wrote :

Sorry, I'm no longer a user of Ubuntu and therefore I can not reproduce it.

Launchpad Janitor (janitor) wrote :

[Expired for gstreamer0.10 (Ubuntu) because there has been no activity for 60 days.]

Changed in gstreamer0.10 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers