Can't seek when playing MPEG layer 2 and layer 3 audio files

Bug #787777 reported by Alex Jones on 2011-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Undecided
Unassigned

Bug Description

Totem can't seek at all when playing MPEG Layer 2 or MPEG Layer 3 audio files. Strangely, layer 1 files seek properly, as do some layer 3 files. The attachment is a collection of sample files in all three formats, plus the lossless original. The audio I used is from the CELT codec test site. The layer 3 file in this archive plays properly, but some other layer 3 files don't. If I find one that doesn't work that can be distributed freely I'll upload it.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libgstreamer0.10-0 0.10.32-3ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue May 24 15:28:36 2011
ExecutablePath: /usr/bin/totem
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gstreamer0.10
UpgradeStatus: Upgraded to natty on 2011-05-05 (19 days ago)
XsessionErrors: (<unknown>:3500): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed

Alex Jones (blenheimears) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers