Ubuntu

Totem fails to play any media after upgrading to Ubuntu 11.04 Beta

Reported by Dylan Taylor on 2011-04-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Undecided
Unassigned

Bug Description

Upon playing any media in Totem, I get the following error message: "Failed to create a GStreamer play object. Please check your GStreamer installation.". Totem worked fine in 10.10, but broke after installing 11.04 Beta.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: libgstreamer0.10-0 0.10.32-3ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-28.50-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon Apr 25 04:40:50 2011
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gstreamer0.10
UpgradeStatus: Upgraded to natty on 2011-04-24 (1 days ago)

Dylan Taylor (aliendude5300) wrote :
Dylan Taylor (aliendude5300) wrote :

I can now say for certain that this is a configuration issue, and not a corrupt or missing package. After creating a new dummy user on the system, I can play music and videos just fine, however, it's still broken in my user account.

Dylan Taylor (aliendude5300) wrote :

Update: For anybody else who experiences this issue after updating to 11.04, the fix is to delete the folder ~/.gstreamer-0.10. After doing that, the issue should be fixed immediately without a need to logout or reboot your system. It would appear that the problem was a corrupt gstreamer configuration. Perhaps the error messages could be modified to make this more apparent?

Changed in gstreamer0.10 (Ubuntu):
status: New → Incomplete
status: Incomplete → New
Lars Ola Liavåg (l-liavag) wrote :

I can confirm this fix solves the same problem on a 64-bit system recently upgraded from Oneiric to Precise.

bonmario (bonmario) wrote :

I have the same error after upgrading to Ubuntu 12.04.
I've tried to delete ~/.gstreamer-0.10, but this don't solved the problem

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers