Debug Setting Broken in C++

Bug #708508 reported by Marco on 2011-01-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Critical
gstreamer0.10 (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Harald Sitter

Bug Description

issue:
wrong address handling breaks debug setting in C++ applications

test case:
* Install amarok or dragonplayer or something else that uses phonon as well as phonon-backend-gstreamer
* In a terminal export PHONON_GST_GST_DEBUG=5
* Start amarok (maybe try playing something)
* Vast amounts of debug output with time stamps should appear

----

Binary package hint: phonon-backend-gstreamer

hi, i have kde 4.6.0, amarok 2.4 and phonon/phonon backend gstreamer 4.4.4
when i launch amarok, i have this error:

KGlobal::locale::Warning your global KLocale is being recreated with a valid main component instead of a fake component, this usually means you tried to call i18n related functions before your main component was created. You should not do that since it most likely will not work

(amarok:5012): GStreamer-CRITICAL **: gst_debug_add_log_function: assertion `func != NULL' failed

and amarok doesn't start

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: phonon-backend-gstreamer 4:4.7.0really4.4.4-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Jan 27 09:52:19 2011
ProcEnviron:
 LANGUAGE=it_IT
 LANG=it_IT.utf8
 SHELL=/bin/bash
SourcePackage: phonon-backend-gstreamer

Marco (0m3g4) wrote :
affects: phonon-backend-gstreamer (Ubuntu) → gstreamer0.10 (Ubuntu)
Changed in gstreamer:
importance: Unknown → Critical
status: Unknown → Incomplete
Changed in gstreamer:
status: Incomplete → Fix Released
astro (bernard-godard) wrote :

Same problem here, updated Ubuntu 11.04 amd64.

All KDE audio application using phonon fail to start, but the process is still running and cannot even be killed with "kill -9".

Workaround : install phonon-xine backend and deinstall phonon-gstreamer backend.

This was apparently fixed upstream in gstreamer 0.10.33. However Ubuntu ships 0.10.32.

Shouldn't this bug be marked as critical if Ubuntu defaults to phonon gstreamer backend.

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
Harald Sitter (apachelogger) wrote :
summary: - amarok doesn't start with new phonon gstreamer
+ Debug Setting Broken in C++
Changed in gstreamer0.10 (Ubuntu):
status: Confirmed → Fix Released
Harald Sitter (apachelogger) wrote :

Incidentally the original issue of Amarok not starting due to fatal assert should not be a problem in natty final as asserts are not fatal in Ubuntu releases I understand.
However, the underlying bug prevents debug output when using gstreamer in a C++ application. This for example renders us unable to produce gstreamer debug output with Phonon, which is a major PITA for upstream.

Changed in gstreamer0.10 (Ubuntu Natty):
assignee: nobody → Harald Sitter (apachelogger)
status: New → In Progress
description: updated
astro (bernard-godard) wrote :

It is a problem in natty-final.

I just tried a fresh install of Ubuntu 11.04 final 32 bits and installed all the pending update. Amarok is still not starting.

Harald Sitter (apachelogger) wrote :
Chris Halse Rogers (raof) wrote :

SRU team ACK. Please accept into natty-proposed.

Hello Marco, or anyone else affected,

Accepted gstreamer0.10 into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gstreamer0.10 (Ubuntu Natty):
status: In Progress → Fix Committed
tags: added: verification-needed
Philip Muškovac (yofel) wrote :

Confirmed, debug output is there again after upgrading
libgstreamer0.10-0 0.10.32-3ubuntu3 -> 0.10.32-3ubuntu3.1

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gstreamer0.10 - 0.10.32-3ubuntu3.1

---------------
gstreamer0.10 (0.10.32-3ubuntu3.1) natty-proposed; urgency=low

  * Add fix_failing_symbol_lookup_from_cpp.patch from upstream.
    An not very necessary change to symbol lookup WRT debugging broke
    symbol lookup entirely when using Gst from C++ (such as in Phonon).
    This consequently prevents debugging and causes major headaches upstream.
    LP: #708508
  * Update maintainer field to use Ubuntu Developers
 -- Harald Sitter <email address hidden> Thu, 07 Jul 2011 22:12:37 +0200

Changed in gstreamer0.10 (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.