Not synchronize the subtitles when the film forward and backward

Bug #567523 reported by Cristian Aravena Romero on 2010-04-20
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Totem
Expired
Medium
gstreamer0.10 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: totem

not synchronize the subtitles when the film forward and backward

$ LANGUAGE=C GST_DEBUG_NO_COLOR=1 GST_DEBUG=*:2 totem 2> log
$ cat log

(totem:6667): GLib-GObject-WARNING **: value "10752000" of type `guint' is invalid or out of range for property `connection-speed' of type `guint'
0:00:08.499809054 6667 0xa654ed8 WARN subparse gstsubparse.c:544:convert_encoding:<parser> could not convert string from 'UTF-8' to UTF-8: Invalid byte sequence in conversion input
0:00:09.375832311 6667 0x9c05080 WARN totem bacon-video-widget-gst-0.10.c:1589:bvw_handle_element_message: Unhandled element message playbin2-stream-changed from play: element message from element 'play': playbin2-stream-changed, uri=(string)file:///home/caravena/Descargas/house.s06e14.hdtv.xvid-fqm.avi, suburi=(string)file:///home/caravena/Descargas/house.s06e14.hdtv.xvid-fqm.srt;
0:00:16.974911040 6667 0xa654ed8 WARN subparse gstsubparse.c:544:convert_encoding:<parser> could not convert string from 'UTF-8' to UTF-8: Invalid byte sequence in conversion input
0:00:53.048479388 6667 0xa654ed8 WARN subparse gstsubparse.c:544:convert_encoding:<parser> could not convert string from 'UTF-8' to UTF-8: Invalid byte sequence in conversion input
0:00:53.049495853 6667 0xa654ed8 WARN subparse gstsubparse.c:544:convert_encoding:<parser> could not convert string from 'UTF-8' to UTF-8: Invalid byte sequence in conversion input
0:00:53.050508267 6667 0xa654ed8 WARN subparse gstsubparse.c:544:convert_encoding:<parser> could not convert string from 'UTF-8' to UTF-8: Invalid byte sequence in conversion input
0:00:53.051302778 6667 0xa654ed8 WARN subparse gstsubparse.c:544:convert_encoding:<parser> could not convert string from 'UTF-8' to UTF-8: Invalid byte sequence in conversion input
0:00:59.527401603 6667 0xa654ed8 WARN subparse gstsubparse.c:544:convert_encoding:<parser> could not convert string from 'UTF-8' to UTF-8: Invalid byte sequence in conversion input
0:00:59.528307859 6667 0xa654ed8 WARN subparse gstsubparse.c:544:convert_encoding:<parser> could not convert string from 'UTF-8' to UTF-8: Invalid byte sequence in conversion input

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: totem 2.30.0git20100413-0ubuntu1
Uname: Linux 2.6.34-rc4.140410 i686
Architecture: i386
Date: Tue Apr 20 16:33:12 2010
ExecutablePath: /usr/bin/totem
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta i386 (20100406.1)
ProcEnviron:
 LANG=es_CL.utf8
 SHELL=/bin/bash
SourcePackage: totem

Changed in totem (Ubuntu):
status: New → Triaged
importance: Undecided → Low
affects: totem (Ubuntu) → gstreamer0.10 (Ubuntu)
Changed in totem:
status: Unknown → Incomplete
Changed in totem:
status: Incomplete → New
summary: - not synchronize the subtitles when the film forward and backward
+ Not synchronize the subtitles when the film forward and backward
Leonardo Torok (leotorok) wrote :

Same here, Ubuntu 10.04 final. When the film foward/ backward, subtitle is gone. There will be some fix to this?

Sebastien Bacher (seb128) wrote :

Upstream bug comment

"The problem is that the subtitle is not in UTF-8 and you did not set the
correct encoding for it in the preferences.

Despite that, gstsubparse should still show some garbage on the screen."

Do you get the issue using utf-8 subtitles or if you set the encoding?

With subtitle attach work fine

With subtitle attach work fine

Changed in totem:
status: New → Invalid
Changed in totem:
status: Invalid → Unknown
Changed in totem:
status: Unknown → New
Changed in totem:
importance: Unknown → Medium
Changed in totem:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.