DVD video playback pauses after ~1s, audio continues

Bug #522901 reported by Max Bowsher
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
GStreamer
Expired
Medium
gstreamer0.10 (Ubuntu)
Low
Unassigned

Bug Description

On two separate lucid installations, I find that when starting to play a DVD, the video freezes after ~1s, whilst the audio continues playing. If left like this, every 1-2 minutes or so, the video will switch to another freeze-frame further on in the film.

I'm uncertain if it's related, but very many of these errors are emitted if totem is run from a terminal:
** (totem:3870): CRITICAL **: gst_audio_buffer_clip: assertion `segment->format == GST_FORMAT_TIME || segment->format == GST_FORMAT_DEFAULT' failed

ProblemType: Bug
Architecture: amd64
Date: Tue Feb 16 22:44:46 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
Package: libgstreamer0.10-0 0.10.26-1
ProcEnviron:
 LC_COLLATE=C
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
SourcePackage: gstreamer0.10
Uname: Linux 2.6.32-12-generic x86_64

Revision history for this message
Max Bowsher (maxb) wrote :
Revision history for this message
Mark Smith (tntc-tig) wrote :

Ditto here. same platform.

Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
summary: - DVD video playback pauses after ~1s, audio continues [lucid regression]
+ DVD video playback pauses after ~1s, audio continues
Changed in gstreamer0.10 (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Revision history for this message
Alex Launi (alexlauni) wrote :

Gstreamer 0.10.27 was released a couple of days ago, I don't know if it fixes this issue or not, but it's worth trying. Can someone possibly push a ppa with 0.10.27 to test?

Revision history for this message
Sebastien Bacher (seb128) wrote :

0.10.27 has been uploaded to lucid

Revision history for this message
Alex Launi (alexlauni) wrote :

This is not fixed after 0.10.27 upgrade

Revision history for this message
Rafael Monica (monraaf-deactivatedaccount) wrote :

Same problem here. The culprit seems to be gstautoconvert.

(totem:8473): GLib-GObject-WARNING **: IA__g_object_set_valist: object class `GstAutoConvert' has no property named `initial-identity'

The original gstautoconvert version lives in gst-plugins-bad. But it's not included in the Ubuntu deb. Instead Ubuntu seems to have moved it to gst-plugins-good in the patch: 04_move_farsight_plugins_to_good.patch

But the version in the patch is outdated and doesn't provide the 'initial-identity' property. Building gst-plugins-bad and launching totem like this:

GST_PLUGIN_PATH=gst/autoconvert/.libs totem

Fixes DVD playback for me.

Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

I have just uploaded some fixed gst-plugins-good packages to my testing PPA here:

https://launchpad.net/~mdeslaur/+archive/testing

Could you see if it solves the issue for you?

Revision history for this message
Rafael Monica (monraaf-deactivatedaccount) wrote :

Yep, gst-plugins-good from the PPA fixes it for me.

Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

monraaf, thanks for the hint about gstautoconvert! It's much appreciated.

I'll upload the updated packages today.

Revision history for this message
Marc Deslauriers (mdeslaur) wrote :

gst-plugins-good0.10 (0.10.21-1ubuntu2) lucid; urgency=low

  * debian/patches/04_move_farsight_plugins_to_good.patch:
    - Rebased patch on gst-plugins-bad0.10 0.10.18 to fix DVD playing
      issue (LP: #522901, LP: #522897)
  * debian/patches/99_autoreconf.patch:
    - regenerated
 -- Marc Deslauriers < <email address hidden>> Tue, 30 Mar 2010 08:08:38 -0400

Changed in gstreamer0.10 (Ubuntu):
status: Triaged → Fix Released
Changed in gstreamer:
status: Unknown → Invalid
Changed in gstreamer:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.