Ubuntu

totem-gstreamer-firefox-plugin gives an error in a page

Reported by Nicolò Chieffo on 2006-05-23
30
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GStreamer
Invalid
Undecided
Unassigned
gstreamer0.10 (Ubuntu)
Medium
Geoffrey Ngigi

Bug Description

http://www.allmusic.tv/streaming.asp

try visiting this page. I get this error

Totem could not play 'fd://0'. can't detect stream type.

totem-xine-firefox-plugin can open this page!

note that if I open the media in the page outside the browser (link: http://live.mediaserver.kataweb.it/retea) totem-gstreamer will open it (although video is not shown I can hear audio well!)

Carl van Tonder (carlvantonder) wrote :

I get that error, seemingly randomly, viewing some videos in Firefox with said plugin. This error is not 100% reproducable and I did not get it just now when visiting the linked page. Also, totem is unable (even with w32codecs and all gstreamer plugins) to play some wmv files (audio only; no video playback) and this may well be the cause of the 'video not shown...' phenomenon.

ah! ok! I hope it will be able to support w32codecs at all soon!

Sebastien Bacher (seb128) wrote :

to use the w32codecs you can install the gstreamer0.10-pitfdll package

I've installed it, but it does not work with certain .asf or .wmv files!

Sebastien Bacher (seb128) wrote :

Could you try if you still have the issue on edgy with totem 1.5.91?

Changed in totem:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info

the output is (translated)

Totem could not play 'mmsh://live.mediaserver.kataweb.it/retea?MSWMExt=.asf'.
no URI handler is implemented for «mmsh».

Nicolò Chieffo (yelo3) wrote :

I have installed totem-gstreamer 1.5.91-1ubuntu3
and I have w32codecs, gstreamer0.10-plugins-bad,
gstreamer0.10-plugins-bad-multiverse, gstreamer0.10-plugins-base,
gstreamer0.10-plugins-good, gstreamer0.10-plugins-ugly,
gstreamer0.10-plugins-ugly-multiverse

Nicolò Chieffo (yelo3) wrote :

I have retested it and now is quite different:
sometimes everything is black with no output (with no network activity)
some other times the error message is

Totem could not play 'mmsh://live.mediaserver.kataweb.it/retea?MSWMExt=.asf'.
Could not open location; You may not have permission to open the file.

the other error is no more present

Tom Kirby (tc-kirby) wrote :

I am experiencing rather irritating problems visiting http://www.timesonline.co.uk/uk/

I don't just get one error message, but hundreds. They just keep coming, which is a far worse bug than a missing codec, as it means I have to quit Firefox to stop the messages clogging up my system. In fact, I'd go as far as to say that there's the slightest chance this could constitute a potential security hole in Firefox/Totem on systems that have the Firefox Totem plugin but not the WMV9 Totem plugin.

In other words, this could be serious.

The error looks something like: "Totem could not play 'mms://.../wm.rootmedia/84/84325_300.asf...

Video codec 'MS WMV 9 (win32)' is not handled..."

Sebastien Bacher (seb128) wrote :

works fine on edgy for me, could anybody having the issue forward that upstream?

Changed in totem:
status: Needs Info → Unconfirmed
Nicolò Chieffo (yelo3) wrote :

sebastian, do you mean that you can view the link
http://www.allmusic.tv/streaming.asp correctly?
In the latest updates the problem has changed: I get no more errors,
but the video is completely disabled! only audio works well...

Sebastien Bacher (seb128) wrote :

http://www.allmusic.tv/streaming.asp is working fine for me. Do you have gstreamer0.10-pitfdll installed? If that's the case could you try without it?

Nicolò Chieffo (yelo3) wrote :

just a question: can gstreamer handle w32codecs without the pitfdll
package? I cannot try it now because the partition in which I
installed edgy is completely broken.

Sebastien Bacher (seb128) wrote :

no, it can't without that package

Nicolò Chieffo (yelo3) wrote :

Ok these are my tests (of http://www.allmusic.tv/streaming.asp)

1)
after a clean edgy install + today updates (whith this gstreamer
packages installed)
gstreamer0.10-alsa
gstreamer0.10-esd
gstreamer0.10-gnomevfs
gstreamer0.10-plugins-base
gstreamer0.10-plugins-base-apps
gstreamer0.10-plugins-good
gstreamer0.10-tools
gstreamer0.10-x
libgstreamer-plugins-base0.10-0
libgstreamer0.10-0
totem-gstreamer
ERROR: can't reproduce the file
"mmsh://live.mediaserver.kataweb.it/retea?MSWMExt=.asf". No URI
handler for «mmsh».

2) ok it's mmsh, so I have to install gstreamer0.10-plugins-bad, which
contains a package that supports mssh.
ERROR: there is no codec to play this file
DEBUG: don't know how to handle video/x-ms-asf

3) I know it's a .asf file so I decided to install w32codecs (I think
the codec is here). since there is no package in repositories I used a
previously downloaded one (fond in RestrictedFormats wiki page)
w32codecs_20060611-1plf1_i386.deb which installs all the plugins in
/usr/lib/codecs
as you told me gstreamer0.10-pitfdll is required to handle w32codecs,
so I installed it, but the error continues, as if w32codecs package
does not contain any package to handle "video/x-ms-asf"

4) the package which unblock the error is gstreamer0.10-plugins-ugly,
but I get no video and no audio.
NO ERROR: DEBUG MESSAGE: DMO dll supports VO Optimizations 0 1
DMO dll might use previous sample when requested

(note that this package is not enough to unblock the error, I tried to
uninstall pitfdll+w32codecs to see what would have happened and totem
gived me a debug message:
don't know how to handle video/x-wma .. some values ... don't know how
to handle video/x-wmv ... )

5) I installed the multiverse and ffmpeg plugins but the situation is
the same. I'm wondering how did I get in my last configuration the
audio working!!

this is the list of packages installed (only gstreamer) at the end of the tests:
gstreamer0.10-alsa
gstreamer0.10-esd
gstreamer0.10-ffmpeg
gstreamer0.10-gnomevfs
gstreamer0.10-pitfdll
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad-multiverse
gstreamer0.10-plugins-base
gstreamer0.10-plugins-base-apps
gstreamer0.10-plugins-good
gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-ugly-multiverse
gstreamer0.10-tools
gstreamer0.10-x
w32codecs

can you give me the list of your installed packages?

Nicolò Chieffo (yelo3) wrote :

I'm sorry if I did not tell you before, but when pitfdll + w32codecs +
gstreamer0.10-plugins-bad + gstreamer0.10-plugins-ugly are installed,
totem gives a frequent error which is that it can't open the file
because it has no permissions
"unable to open, check if you have the correct permissions"

Sebastien Bacher (seb128) wrote :

Sorry for the delay to reply, we get lot of bugs and only few people work on them. Do you still have that problem on edgy or feisty?

Nicolò Chieffo (yelo3) wrote :

dear sebastian, just a little summary:
http://www.allmusic.tv/streaming.asp
gstreamer0.10-ffmpeg
gstreamer0.10-plugins-bad-multiverse
gstreamer0.10-plugins-bad
gstreamer0.10-plugins-ugly-multiverse
gstreamer0.10-plugins-ugly
gstreamer0.10-plugins-good
w32codecs

same error a few times, no video and no audio

Sebastien Bacher (seb128) wrote :

thank you for the clear comments and the detailled description, that seems to be a gstreamer problem, reassigning and confirming

Changed in totem:
status: Unconfirmed → Confirmed
Sebastian Dröge (slomo) wrote :

I only get this error sometimes, most of the time it starts "playing" something there... but without audio or video output. When running with mplayer (look up the correct URL in the page sources) I get at least sound... so really a GStreamer problem, I'll forward it upstream

Changed in gstreamer:
status: Unknown → Unconfirmed
Tom Kirby (tc-kirby) wrote :

I'm no longer getting the same specific problem on the same specific page. This could be due to the fact that I'm now on Edgy, or that the page has changed, or I might have installed some different firefox/gstreamer plugin since the problem first occurred. Will try to report back with more info later.

lek (wpinkaow) wrote :

Dear all,

I have the same prob with Totem.

"...I visited www.dmc.tv then clicked on Live Broadcast
I could not see the video streaming...."

First problem is error message which nothing has show up at all.

Later on I did not know how I did ; I could hear the audio but not video.

Any solution yet?

Thank you very much in advance

Allan Caeg (allancaeg) wrote :

I also have the same problem.

I can't play anything from
http://www.hayhouseradio.com/nowplaying.php

Nicolò Chieffo (yelo3) wrote :

gutsy situation: no more error is displayed, but totem does not emit video nor audio

Nicolò Chieffo (yelo3) wrote :

Ok I'm closing this bug since there is no more error, and open a new one for the unsupported media

Changed in gstreamer0.10:
status: Confirmed → Invalid
Changed in gstreamer:
status: New → Invalid
Changed in gstreamer0.10 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Geoffrey Ngigi (geoffrey-njuraita)
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.