Ubuntu

Rhythmbox seek doesn't work as expected

Reported by Vytas on 2006-03-21
12
Affects Status Importance Assigned to Milestone
GStreamer
Invalid
Medium
Ubuntu
Medium
Unassigned
gstreamer0.10 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Rhythmbox: 0.9.3.1

After seeking with a seek bar, playing sometimes (~50% cases) stops on both MP3 and Vorbis. It is possibly gstreamer unrelated cause totem media player works fine.

No errors in terminal.

After such stopping, when I press Pause/Play, the palying resumes.

Vytas (vytas) wrote :

Strange, same problem in banshee.

Changed in rhythmbox:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks for your bug. Do you still have that issue? Does it happen on some specific files or all the mp3 and ogg with rhythmbox and banshee? What soundcard do you have? Does the application hang (maybe bug #35447 which is fixed now)?

Changed in rhythmbox:
assignee: nobody → desktop-bugs
status: Confirmed → Needs Info
Vytas (vytas) wrote :

Yes, the issue is still there. It does not seem to depend on the specific file. The application does NOT hang, also totem works fine.

__________________________
vytas@naujas:~$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
                     HDA Intel at 0xffa3c000 irq 169
__________________________

Maybe it is hard to describe the every aspect of the bug precisely, so Ive made a screencast which is self explanatory (it's a GIF, no sound, but you can notice if a time is counting or not).

http://img66.imageshack.us/img66/25/bug2dc.gif

Sebastian Dröge (slomo) wrote :

I sometimes had the same problems but not as often as you, Vytas. But I don't remember having it lately... I'll add a comment here when it happens again for me with some backtrace information

Sebastian Dröge (slomo) wrote :

Haha, that's good. The first time I tried it again after replying here it hanged... ok, so here we go. first attachment is the complete backtrace with all the mono junk in there... the second is only the gst-related threads

I have a feeling that this mostly happens on vbr files but not sure yet...

backtrace with all threads

backtrace with all the gst threads

Changed in rhythmbox:
status: Needs Info → Confirmed
Sebastian Dröge (slomo) wrote :

And I can confirm that this only happens with rhythmbox and banshee, not totem. Maybe caused by the life-seeking that both have...

banshee running with GST_DEBUG=3. killed after a stalled seek

ok, this time without colours... an mp3, killed after stall

the same with a vorbis file

Sebastian Dröge (slomo) wrote :

should be assigned to gst-plugins-base0.10 imho as this should be a playbin problem

Sebastien Bacher (seb128) wrote :

enough tasks without that one

Vytas (vytas) wrote :

sorry that was mine misclick

Sebastian Dröge (slomo) wrote :

ok, this is fixed upstream (was in fact a duplicate...) 4 days ago :) we'll get it with the next upstream release

Changed in gst-plugins-base0.10:
status: Confirmed → Fix Committed
Clemens (clast) wrote :

It's not fixed for me in the latest dapper :(
That's why I changed the status back to "confirmed".

Changed in gst-plugins-base0.10:
status: Fix Committed → Confirmed
Sebastian Dröge (slomo) wrote :

But it is fixed upstream thus we will get it when they finally released new tarballs which should be the case in the next days

Changed in gst-plugins-base0.10:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

 gstreamer0.10 (0.10.5-0ubuntu1) dapper; urgency=low
 .
   * Sync with Debian
   * New upstream version:
     Changes since 0.10.4:
     - QoS in BaseTransform
     - gcc 4.1 fixes
     - BaseTransform reworked
     - Bus reworked; signal API added
     Bugs fixed since 0.10.4:
     - [PATCH] [api] loading a class leaves elementfactory blank
     - gstreamer Cygwin build fixes
     - Build fails with GCC 4.1
     - GStreamer CVS head files to build with GCC 4.1
     - [basesink] filesink spews warnings when used with flacenc
     - xml registry loader should use mmap() where possible
     - [GstQueue/GstPad] queue pauses immediately when linked, p...
       (Ubuntu: #32664, #33440)
     - Something wrong in caps checking...
     - pkg-config files must link with the same check library th...
     - Stale libgnomeui check in configure
     - Missing functions in def files for dlls
     - GST_BOILERPLATE_FULL etc isn' optimised
     - start with debugging disabled
     - totem goes (and stays) out of sync when running bittorrent
     - [queue] Queue might block in EOS
     - [filesink] throws error when writing 0 bytes
     - small cleanup in gstplugin.c
     - Pipeline bus is not initially flushing
     - Internal data flow error with latest updates for FC5 with...
     - basesink does not call the PAUSED- > PLAYING change_state f...
     - GstBaseSrc's send_event handler ignores seek requests aft...
   * debian/control.in:
     - list a -dbg package
     - updated the gstreamer0.8-tools Conflicts version for Ubuntu
   * debian/rules:
     - use dh_strip to build a debug package

Changed in gstreamer0.10:
status: Fix Committed → Fix Released
Changed in gstreamer:
importance: Unknown → Medium
status: Invalid → Unknown
Changed in gstreamer:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.