SoundConverter fails on batch conversion (SPC to MP3)

Bug #345032 reported by David Kolossa on 2009-03-18
0
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Low
Unassigned
soundconverter (Ubuntu)
Undecided
abhijith bhaskaran k

Bug Description

Binary package hint: soundconverter

I tried to convert some spc files to MP3 using SoundConverter. I dragged the files into the SoundConverter window but when I tried to convert them, I got the attached console output and SoundConverter crashed. In addition, sometimes SoundConverter even crashes when I'm just dropping the files in the window. I don't know if this could be related.

When I tried to convert them file after file, everything worked fine, so this has to do something with the batch conversion.

I'm using SoundConverter 1.4.1 on Ubuntu Jaunty. This might as well be a gstreamer issue, but I don't know how to check whether only SoundConverter is affected.

GautierPortet (kassoulet) wrote :

Can you please run "soundconverter --debug", retry the operation, and paste here the console output ?
Thanks !

Of course.
This console output is from a session where SoundConverter crashed just when I dropped the files into the window.

Another session, now I dropped every single file for its own into the window.
Then I started the conversion, leading to a crash.

If I remember right, this is how I have done it when I produced the very first console output in this bug report.

GautierPortet (kassoulet) wrote :

Thank you

GautierPortet (kassoulet) wrote :

disclaimer: I don't have the plug-in to read spc files.

That said, the SPC registers related message at the end seems to indicate that something gone wrong while decoding the file.
The files are probably broken, can you try with another player ?
Anyway the problem is not in SoundConverter, you should contact the gstreamer-spc authors.

Well, if the files are REALLY broken, they are broken in a weird way, because SoundConverter can handle every single file on its own without crashing, and Totem and some player called Audio Overload can play them too.

Can you point me to the location where I can contact the gstreamer-spc team?

GautierPortet (kassoulet) wrote :

Wow.
Well you can try to run this command, and see what happen:
"gst-launch giosrc location=file:///home/david/ffsoundtrack/3.14%20-%20Dancing%20mad%20%234.2.spc ! decodebin ! audioconvert ! autoaudiosink"
If it keeps crashing, then it's definitelly gstreamer-spc's fault.

But, as I'm writing this, I have an horrible suspicion: maybe gstreamer-spc is just not thread-safe...
Can you try to use "soundconverter --debug --jobs 1" to disable threads ?

Yes, that should be it.
I've tried "soundconverter --debug --jobs 1" and it doesn't crash anymore. Thank you so far for this workaround. I'm attaching the console output.

(By the way: I've also tried the command you mentioned above. I had to install the package gstreamer-tools, but then the command "gst-launch giosrc location=file:///home/david/ffsoundtrack/3.14%20-%20Dancing%20mad%20%234.2.spc ! decodebin ! audioconvert ! autoaudiosink" worked just fine.)

GautierPortet (kassoulet) wrote :

Ok, thank you very much for your patience.
It's time for a blacklist of non-thread-safe plugins :(

Changed in soundconverter (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? May you please try the same with Karmic and comment back? Thanks in advance.

Changed in gstreamer0.10 (Ubuntu):
status: New → Incomplete
importance: Undecided → Low

 As this is a gst-bad-plugin I'd change the importance to wishlist. The underlying libopenspc hasn't changed for years so this bug very likely still exists. Are gstreamer-plugins required to be thread safe?

GautierPortet (kassoulet) wrote :

There are thread related bugs in soundconverter. I just can't reproduce them propertly. So it's maybe soundconverter, or the SPC gst plugin, or even the SPC lib itself. Anyway, launch with "--jobs 1" when problem occurs, I can't do more for now...

Changed in soundconverter (Ubuntu):
assignee: nobody → abhijith bhaskaran k (abhijithbhaskarank)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers