totem: can't skip chapters in matroska files

Bug #288762 reported by Alex Mauer on 2008-10-24
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Low
Unassigned
Declined for Jaunty by Sebastien Bacher
xine-lib (Ubuntu)
Low
Unassigned
Declined for Jaunty by Sebastien Bacher

Bug Description

Binary package hint: totem-xine

Totem is unable to access the chapters of Matroska files. The Next/Previous chapter menu options are disabled.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Could you add an example to the bug?

 This will help us to find and resolve the problem.

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Alex Mauer (hawke) wrote :

Yes.
Create a matroska file with chapters.

Load it in totem.

Note that the chapter buttons don't work.

Attached please find a matroska file containing 5 chapters.

Changed in totem:
status: Incomplete → New
Pedro Villavicencio (pedro) wrote :

does this works at all with xine-ui for example? i don't get anything here with totem-gstreamer.

Changed in totem:
status: New → Incomplete
Alex Mauer (hawke) wrote :

No, it doesn't work with xine-ui either.

Sebastien Bacher (seb128) wrote :

do you still get the issue in jaunty? are you sure the example is working with any software?

Sebastien Bacher (seb128) wrote :

reassigning to xine-lib since xine-ui has the same issue

affects: totem (Ubuntu) → xine-lib (Ubuntu)
Changed in xine-lib (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Alex Mauer (hawke) wrote :

Yes, it's still a problem in Jaunty. The example works fine in mplayer.

Alex Mauer (hawke) wrote :

And in VLC.

Alex Mauer (hawke) wrote :

Re-adding to totem, because it also applies to totem-gstreamer.

Sebastien Bacher (seb128) wrote :

still not a totem bug though

affects: totem (Ubuntu) → gstreamer0.10 (Ubuntu)
Changed in gstreamer0.10 (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xine-lib - 1.1.17-1ubuntu1

---------------
xine-lib (1.1.17-1ubuntu1) lucid; urgency=low

  * merge from debian, remaining changes:
    - dont build and install the jack plugin
    - build the faad plugin against the internal copy of libfaad
    - tighten dependencies on ffmpeg.
    - change order of the alternate dependencies libxine-plugins and
      libxine1-misc-plugins. The former would drag in libxine1-ffmpeg
      via recommends on the live cd.
  * new upstream release fixes:
    - Add support for Matroska SIMPLEBLOCK. LP: #288762
    - Make ~/.xine/catalog.cache writing safer. should fix LP: #331889

xine-lib (1.1.17-1) unstable; urgency=low

  * New upstream release.
    - Fixes the upstream part of the FTBFS on Hurd. (Closes: #530796)
    - Gapless playback fixes. (Closes: #467110)
    - Supports Matroska chapters. (Closes: #515212)
    - No longer truncates catalog.cache. This fixes problems with failure to
      recognise supported media types. (Closes: #523859)
  * Build-depend on libvcdinfo-dev, fixing libcdio static linkage.
    (Closes: #537078)
  * Convert to source format 3.0 (quilt), with adaptations for Mercurial
    queue usage.

  [Marc Dequènes]
  * Arch-specific install files generation for GNU/Hurd (similar to
    kfreebsd-i386). (Ref. #530796)
 -- Reinhard Tartler <email address hidden> Tue, 26 Jan 2010 16:14:12 +0100

Changed in xine-lib (Ubuntu):
status: Incomplete → Fix Released
madbiologist (me-again) wrote :

I can play the file from comment 2 here on Ubuntu 10.10 "Maverick Meerkat" alpha 3 updated to the latest package versions (see below), however the video quality is abysmal and the chapter buttons still don't work.

Uname: Linux 2.6.35-14-generic i686
Package versions: totem 2.31.6-0ubuntu1
                              libgstreamer0.10-0 0.10.30-1build2
                              gstreamer0.10-plugins-base 0.10.30-1build1
                              gstreamer0.10-plugins-good 0.10.24.3-1ubuntu1
                              gstreamer0.10-plugins-bad 0.10.19-1ubuntu3
                              gstreamer0.10-plugins-ugly 0.10.15-1
                              gstreamer0.10-ffmpeg 0.10.11-1

Remco (remco47) on 2010-10-15
Changed in gstreamer0.10 (Ubuntu):
status: New → Confirmed
madbiologist (me-again) wrote :

On Ubuntu 12.04.1 things are exactly as described in comment #12.

Uname: Linux 3.2.0-32-generic-pae i686
Package versions: totem 3.0.1-0ubuntu21.1
                                        libgstreamer0.10-0 0.10.36-1ubuntu1
                                        gstreamer0.10-plugins-base 0.10.36-1ubuntu0.1
                                        gstreamer0.10-plugins-good 0.10.31-1ubuntu1
                                        gstreamer0.10-plugins-bad 0.10.22.3-2ubuntu2.1
                                        gstreamer0.10-plugins-ugly 0.10.18.3-1ubuntu1
                                        gstreamer0.10-ffmpeg 0.10.13-1

tags: added: jaunty maverick precise
david6 (andrew-dowden) wrote :

This issue is still present in Ubuntu 14.04 LTS, fully updated.

An .mkv file with OR without chapters is treated the same by Totem. Most of my files played on VLC (or other player) have chpater information and you can navigate to next/previous chapter.

What is the root cause?

Why did this fix (xine-lib v1.1.17, per comment #11) never reach/affect Trusty (14.04)?

madbiologist (me-again) wrote :

Note that this bug has two tasks - gstreamer and xine-lib. The xine-lib task is fixed but the gstreamer one is not. Totem does not use xine-lib. It uses gstreamer. You might like to try mplayer or VLC instead.

tags: added: trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers