Ubuntu

rhythmbox, dead-lock between songs

Reported by Fabien Tassin on 2008-09-06
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Medium
Unassigned
Declined for Intrepid by Steve Beattie

Bug Description

Binary package hint: rhythmbox

On intrepid, rhythmbox recently started to stop playing between songs (some, not all). At the end of a song, the next one is not played, the CPU jumps and stays like that. When I click next, the UI freezes.
It happens very frequently, forcing me to kill rhythmbox. I use x-fading between songs.

Under gdb, if I break during the freeze, i see a dead-lock..
Assigning to rhythmbox but it could be gstreamer's fault. Feel free to re-assign.

(gdb) bt
#0 0xb7f08430 in __kernel_vsyscall ()
#1 0xb7ce1cf9 in __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb7cdd104 in _L_lock_89 () from /lib/tls/i686/cmov/libpthread.so.0
#3 0xb7cdca32 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#4 0xb6e5bef3 in IA__g_static_rec_mutex_lock (mutex=0x99c7778) at /build/buildd/glib2.0-2.18.0/glib/gthread.c:313
#5 0xb7084eb8 in post_activate (pad=0x9957a58, new_mode=161249148) at gstpad.c:607
#6 0xb708e469 in gst_pad_activate_push (pad=0x9957a58, active=0) at gstpad.c:903
#7 0xb707b322 in gst_ghost_pad_do_activate_push (pad=0x9957700, active=0) at gstghostpad.c:583
#8 0xb708e35b in gst_pad_activate_push (pad=0x9957700, active=0) at gstpad.c:896
#9 0xb708f21d in gst_pad_set_active (pad=0x9957700, active=0) at gstpad.c:665
#10 0xb7060f8e in activate_pads (pad=0x9957700, ret=0xbfd21998, active=0xbfd21988) at gstbin.c:1955
#11 0xb70817e7 in gst_iterator_fold (it=0xb3fc1a58, func=0xb7060f60 <activate_pads>, ret=0xbfd21998, user_data=0xbfd21988) at gstiterator.c:502
#12 0xb7060e48 in gst_bin_src_pads_activate (bin=0x9914858, active=0) at gstbin.c:1979
#13 0xb7061d54 in gst_bin_change_state_func (element=0x9914858, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstbin.c:2135
#14 0xb7070c98 in gst_element_change_state (element=0x9914858, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstelement.c:2428
#15 0xb7070a2e in gst_element_continue_state (element=0x9914858, ret=GST_STATE_CHANGE_SUCCESS) at gstelement.c:2135
#16 0xb7070e93 in gst_element_change_state (element=0x9914858, transition=GST_STATE_CHANGE_PLAYING_TO_PAUSED) at gstelement.c:2465
#17 0xb7073bfc in gst_element_set_state_func (element=0x9914858, state=GST_STATE_NULL) at gstelement.c:2378
#18 0xb706fec2 in gst_element_set_state (element=0x9914858, state=GST_STATE_NULL) at gstelement.c:2281
#19 0xb7ec6e88 in unlink_and_dispose_stream (player=0x8e93800, stream=0x8c89440) at rb-player-gst-xfade.c:1338
#20 0xb7ec71e4 in reap_streams (player=0x8e93800) at rb-player-gst-xfade.c:1397
#21 0xb6e2f751 in g_idle_dispatch (source=0x993fab0, callback=0xfffffe00, user_data=0x8e93800) at /build/buildd/glib2.0-2.18.0/glib/gmain.c:4232
#22 0xb6e316b1 in IA__g_main_context_dispatch (context=0x8c5b9f8) at /build/buildd/glib2.0-2.18.0/glib/gmain.c:2142
#23 0xb6e34d53 in g_main_context_iterate (context=0x8c5b9f8, block=1, dispatch=1, self=0x8c3d408) at /build/buildd/glib2.0-2.18.0/glib/gmain.c:2775
#24 0xb6e35272 in IA__g_main_loop_run (loop=0x981fd10) at /build/buildd/glib2.0-2.18.0/glib/gmain.c:2983
#25 0xb7518fc9 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#26 0x08063130 in main (argc=Cannot access memory at address 0x80
) at main.c:330
(gdb)

ii gstreamer-dbus-media-service 0.1.17-upstream-0ubuntu3
ii gstreamer-tools 0.10.20-3
ii gstreamer0.10-alsa 0.10.20-1
ii gstreamer0.10-esd 0.10.10-1
ii gstreamer0.10-ffmpeg 0.10.4-3
ii gstreamer0.10-fluendo-mp3 0.10.7.debian-1
ii gstreamer0.10-fluendo-mpegdemux 0.10.15-1
ii gstreamer0.10-gl 0.10.5-5ubuntu4
ii gstreamer0.10-gnomevfs 0.10.20-1
ii gstreamer0.10-pitfdll 0.9.1.1+cvs20080215-1
ii gstreamer0.10-plugins-bad 0.10.8-1
ii gstreamer0.10-plugins-bad-multiverse 0.10.6-1
ii gstreamer0.10-plugins-base 0.10.20-1
ii gstreamer0.10-plugins-base-apps 0.10.20-1
ii gstreamer0.10-plugins-good 0.10.10-1
ii gstreamer0.10-plugins-ugly 0.10.9-1
ii gstreamer0.10-plugins-ugly-multiverse 0.10.7-2
ii gstreamer0.10-pulseaudio 0.10.10-1
ii gstreamer0.10-schroedinger 1.0.5-1
ii gstreamer0.10-sdl 0.10.8-1
ii gstreamer0.10-tools 0.10.20-3
ii gstreamer0.10-x 0.10.20-1
ii libgstreamer-plugins-base0.10-0 0.10.20-1
ii libgstreamer0.10-0 0.10.20-3
ii rhythmbox 0.11.6svn20080903-0ubuntu2

Linux ix 2.6.27-2-generic #1 SMP Thu Aug 28 17:20:02 UTC 2008 i686 GNU/Linux

Sebastien Bacher (seb128) wrote :

Could you try if that's still an issue using the current versions and report the bug to GNOME?

Changed in gstreamer0.10:
importance: Undecided → Medium
status: New → Incomplete
Gert van Dijk (gertvdijk) wrote :

Last night I got this same issue. In Hardy it was more often though and only when enabling crossfading between songs, now also when doing a fast forward in a song.

Steve Beattie (sbeattie) wrote :

Gert, are you claiming you had this problem in Hardy as well?

Fabien, are you still seeing this issue?

Gert van Dijk (gertvdijk) wrote :

It was present for me in Hardy in particular and I kept having this problem a few weeks in Intrepid. It was about 30 songs (random/shuffle from library) it would last for the first freeze to occur.
Now, with intrepid-updates, -proposed and -backports enabled I haven't had this problem in weeks.

Steve Beattie (sbeattie) wrote :

Fabien, are you still having this issue? If not, can you mark this bug as Fix Released? Thanks.

Rilium (rilium) wrote :
Download full text (5.0 KiB)

Hello, it looks like i have same bug at this moment
I found that UI in rhytmbox is frozen, than i attach to it with gdb
gdb backtrace:
#0 0xb80d0430 in __kernel_vsyscall ()
#1 0xb7e94d09 in __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb7e90114 in _L_lock_89 () from /lib/tls/i686/cmov/libpthread.so.0
#3 0xb7e8fa42 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#4 0xb7001f93 in IA__g_static_rec_mutex_lock (mutex=0x9ec10c0) at /build/buildd/glib2.0-2.18.2/glib/gthread.c:313
#5 0xb72b0421 in gst_base_transform_activate (trans=0x9b8cc08, active=166465732) at gstbasetransform.c:2000
#6 0xb72b0602 in gst_base_transform_sink_activate_push (pad=0x9aa5e58, active=0) at gstbasetransform.c:2029
#7 0xb72362bb in gst_pad_activate_push (pad=0x9aa5e58, active=0) at gstpad.c:899
#8 0xb723717d in gst_pad_set_active (pad=0x9aa5e58, active=0) at gstpad.c:668
#9 0xb721c2db in activate_pads (pad=0x9aa5e58, ret=0xbf9cf578, active=0xbf9cf5d8) at gstelement.c:2511
#10 0xb7228f37 in gst_iterator_fold (it=0xa126548, func=0xb721c2b0 <activate_pads>, ret=0xbf9cf578, user_data=0xbf9cf5d8) at gstiterator.c:540
#11 0xb721bd5f in iterator_activate_fold_with_resync (iter=0xa126548, func=0xb721c2b0 <activate_pads>, user_data=0xbf9cf5d8) at gstelement.c:2543
#12 0xb721be9d in gst_element_pads_activate (element=0x9b8cc08, active=0) at gstelement.c:2587
#13 0xb721c229 in gst_element_change_state_func (element=0x9b8cc08, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstelement.c:2665
#14 0xb3a1184e in ?? () from /usr/lib/libgstaudio-0.10.so.0
#15 0xb72182f8 in gst_element_change_state (element=0x9b8cc08, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstelement.c:2427
#16 0xb721b25c in gst_element_set_state_func (element=0x9b8cc08, state=GST_STATE_READY) at gstelement.c:2377
#17 0xb7217522 in gst_element_set_state (element=0x9b8cc08, state=GST_STATE_READY) at gstelement.c:2280
#18 0xb7208b2a in gst_bin_change_state_func (element=0x9b87350, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstbin.c:1932
#19 0xb72182f8 in gst_element_change_state (element=0x9b87350, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstelement.c:2427
#20 0xb721808e in gst_element_continue_state (element=0x9b87350, ret=GST_STATE_CHANGE_SUCCESS) at gstelement.c:2134
#21 0xb72184f3 in gst_element_change_state (element=0x9b87350, transition=GST_STATE_CHANGE_PLAYING_TO_PAUSED) at gstelement.c:2464
#22 0xb721b25c in gst_element_set_state_func (element=0x9b87350, state=GST_STATE_NULL) at gstelement.c:2377
#23 0xb7217522 in gst_element_set_state (element=0x9b87350, state=GST_STATE_NULL) at gstelement.c:2280
#24 0xb807c818 in ?? () from /usr/lib/librhythmbox-core.so.0
#25 0xb807cb74 in ?? () from /usr/lib/librhythmbox-core.so.0
#26 0xb6fd57e1 in g_idle_dispatch (source=0xa0e0388, callback=0xfffffe00, user_data=0x91e2800) at /build/buildd/glib2.0-2.18.2/glib/gmain.c:4235
#27 0xb6fd7718 in IA__g_main_context_dispatch (context=0x8fb0db8) at /build/buildd/glib2.0-2.18.2/glib/gmain.c:2144
#28 0xb6fdadc3 in g_main_context_iterate (context=0x8fb0db8, block=1, dispatch=1, self=0x8f90408) at /build/buildd/glib2.0-2.18.2/glib/gmain.c:2778
#29 0xb6fdb2e2 in IA__g_main_loop_r...

Read more...

Changed in gstreamer0.10 (Ubuntu):
status: Incomplete → New
Rilium (rilium) wrote :

May be relevant information:
before rhytmbox frozen, i pause'd it, made call with skype, while speaking in skype, tryed to start playing music, what failed, but without UI freezing, later after i ended to speak in skype, i pressed FN+F9(continue music playing), it didn't continue music playing, than i opened UI by clicking tray icon and found that it is frozen.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. A new version of GStreamer is available in both Lucid and Maverick and we are wondering if this is still reproducible in any of those versions, May you please test and give us of feedback about it? Thanks in advance.

Changed in gstreamer0.10 (Ubuntu):
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in gstreamer0.10 (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers