Rhytmbox frezes when attempting to seek

Bug #263066 reported by Munchkinguy on 2008-08-30
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: rhythmbox

When playing an audio file in Rhythmbox and then dragging the "play position indicator" toward the end of the file, Rhythmbox refuses to continue playing the file. Playback stops and any attempt to force it to resume will result in the entire application freezing.

The following message appears in the terminal:
(rhythmbox:7348): Rhythmbox-WARNING **: Failed to pause pipeline before seek

Marcus Asshauer (mcas) wrote :

Thank you for reporting this bug. Please add your ubuntu version and the output of "apt-cache policy rhythmbox".

Changed in rhythmbox:
status: New → Incomplete
Munchkinguy (10068660) wrote :

Ubuntu 8.04

~$ apt-cache policy rhythmbox
rhythmbox:
  Installed: 0.11.5-0ubuntu8
  Candidate: 0.11.5-0ubuntu8
  Version table:
 *** 0.11.5-0ubuntu8 0
        500 http://archive.ubuntu.com hardy-updates/main Packages
        100 /var/lib/dpkg/status
     0.11.5-0ubuntu6 0
        500 http://archive.ubuntu.com hardy/main Packages

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in rhythmbox:
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

also does using alsa rather than pulseaudio makes a difference?

Munchkinguy (10068660) wrote :

It doesn't crash. Just freezes indefinately. Also, I did this using alsa, not pulseaudio.

Sebastien Bacher (seb128) wrote :

can you get a stacktrace of the freeze using gdb?

Munchkinguy (10068660) wrote :

I tried:
(gdb) thread apply all bt
No registers.
(gdb) bt
No stack.

The thing is, the program doesn't crash. It just hangs until you use Force Quit to close it.

Munchkinguy (10068660) wrote :

I had some success:

(gdb) bt
#0 0xb7eec410 in __kernel_vsyscall ()
#1 0xb6e10c07 in poll () from /lib/tls/i686/cmov/libc.so.6
#2 0xb6f361c6 in ?? () from /usr/lib/libglib-2.0.so.0
#3 0xb6f36577 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4 0xb7543264 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#5 0x08062a50 in main (argc=Cannot access memory at address 0x9
) at main.c:327

Munchkinguy (10068660) wrote :
Download full text (4.4 KiB)

More success:

(gdb) thread apply all bt

Thread 14 (Thread 0xafdffb90 (LWP 25094)):
#0 0xb7eec410 in __kernel_vsyscall ()
#1 0xb7c63aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb2953149 in ?? () from /usr/lib/libgstaudio-0.10.so.0
#3 0xb6f5ae2f in ?? () from /usr/lib/libglib-2.0.so.0
#4 0xb7c5f4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5 0xb6e1ae5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 13 (Thread 0xb075fb90 (LWP 25093)):
#0 0xb7eec410 in __kernel_vsyscall ()
#1 0xb7c63aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb718647f in ?? () from /usr/lib/libgstreamer-0.10.so.0
#3 0xb6f5cabb in ?? () from /usr/lib/libglib-2.0.so.0
#4 0xb6f5ae2f in ?? () from /usr/lib/libglib-2.0.so.0
#5 0xb7c5f4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb6e1ae5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 12 (Thread 0xb0f60b90 (LWP 25092)):
#0 0xb7eec410 in __kernel_vsyscall ()
#1 0xb7c63aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
---Type <return> to continue, or q <return> to quit---
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb718647f in ?? () from /usr/lib/libgstreamer-0.10.so.0
#3 0xb6f5cabb in ?? () from /usr/lib/libglib-2.0.so.0
#4 0xb6f5ae2f in ?? () from /usr/lib/libglib-2.0.so.0
#5 0xb7c5f4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb6e1ae5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 11 (Thread 0xb1761b90 (LWP 25091)):
#0 0xb7eec410 in __kernel_vsyscall ()
#1 0xb7c63aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb718647f in ?? () from /usr/lib/libgstreamer-0.10.so.0
#3 0xb6f5cabb in ?? () from /usr/lib/libglib-2.0.so.0
#4 0xb6f5ae2f in ?? () from /usr/lib/libglib-2.0.so.0
#5 0xb7c5f4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb6e1ae5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 10 (Thread 0xb1f62b90 (LWP 25090)):
#0 0xb7eec410 in __kernel_vsyscall ()
#1 0xb7c63aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb718647f in ?? () from /usr/lib/libgstreamer-0.10.so.0
#3 0xb6f5cabb in ?? () from /usr/lib/libglib-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#4 0xb6f5ae2f in ?? () from /usr/lib/libglib-2.0.so.0
#5 0xb7c5f4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb6e1ae5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 9 (Thread 0xb294ab90 (LWP 25086)):
#0 0xb7eec410 in __kernel_vsyscall ()
#1 0xb7c63aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb718647f in ?? () from /usr/lib/libgstreamer-0.10.so.0
#3 0xb6f5cabb in ?? () from /usr/lib/libglib-2.0.so.0
#4 0xb6f5ae2f in ?? () from /usr/lib/libglib-2.0.so.0
#5 0xb7c5f4fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb6e1ae5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 8 (Thread 0xb4cecb90 (LWP 25085)):
#0 0xb7eec410 in __kernel_vsyscall ()
#1 0xb7c67196 in nanosleep () from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb6f5d5e2 in g_usleep () from /usr/lib/libgl...

Read more...

Sebastien Bacher (seb128) wrote :

the stacktrace lacks debug symbols, you need to install libgstreamer0.10-0-dbgsym libglib2.0-0-dbgsym and get a new one. could you also open the bug on bugzilla.gnome.org where people writting the code will read it?

Matthew Woerly (nattgew) wrote :

I have a similar problem with Intrepid. When I seek, it freezes the whole program right away. Is that what you're experiencing? You seem to indicate that it's only after you try to do something else that it freezes.
I was able to get a basic gdb trace, but I couldn't figure out how to get a backtrace since, like you said, it doesn't crash, it freezes.

Munchkinguy (10068660) wrote :
Download full text (9.2 KiB)

I installed the debug symbols. The trace is below. Please tell me if, in the future, you want me to attach the traces as separate text files.

(rhythmbox:12473): Rhythmbox-WARNING **: Failed to pause pipeline before seek

(rhythmbox:12473): Rhythmbox-WARNING **: Failed to pause pipeline before seek

Program received signal SIGINT, Interrupt.
[Switching to Thread 0xb6568740 (LWP 12473)]
0xb7f5f410 in __kernel_vsyscall ()
(gdb) thread apply all bt

Thread 48 (Thread 0xaf5ffb90 (LWP 12572)):
#0 0xb7f5f410 in __kernel_vsyscall ()
#1 0xb7cd6aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb1b14149 in ?? () from /usr/lib/libgstaudio-0.10.so.0
#3 0xb6fcde2f in g_thread_create_proxy (data=0x1d60)
    at /build/buildd/glib2.0-2.16.4/glib/gthread.c:635
#4 0xb7cd24fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#5 0xb6e8de5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 47 (Thread 0xb017eb90 (LWP 12571)):
#0 0xb7f5f410 in __kernel_vsyscall ()
#1 0xb7cd6aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb71f95bf in gst_task_func (task=0xaf84c100, tclass=0x8c22308)
    at gsttask.c:180
#3 0xb6fcfabb in g_thread_pool_thread_proxy (data=0x8be2e00)
    at /build/buildd/glib2.0-2.16.4/glib/gthreadpool.c:265
#4 0xb6fcde2f in g_thread_create_proxy (data=0x8cee460)
    at /build/buildd/glib2.0-2.16.4/glib/gthread.c:635
#5 0xb7cd24fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb6e8de5e in clone () from /lib/tls/i686/cmov/libc.so.6
---Type <return> to continue, or q <return> to quit---

Thread 46 (Thread 0xb097fb90 (LWP 12570)):
#0 0xb7f5f410 in __kernel_vsyscall ()
#1 0xb7cd6aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb71f95bf in gst_task_func (task=0xaf801280, tclass=0x8c22308)
    at gsttask.c:180
#3 0xb6fcfabb in g_thread_pool_thread_proxy (data=0x8be2e00)
    at /build/buildd/glib2.0-2.16.4/glib/gthreadpool.c:265
#4 0xb6fcde2f in g_thread_create_proxy (data=0x8ca1c58)
    at /build/buildd/glib2.0-2.16.4/glib/gthread.c:635
#5 0xb7cd24fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb6e8de5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 45 (Thread 0xb4d40b90 (LWP 12569)):
#0 0xb7f5f410 in __kernel_vsyscall ()
#1 0xb7cd6aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb71f95bf in gst_task_func (task=0xaf8cbe80, tclass=0x8c22308)
    at gsttask.c:180
#3 0xb6fcfabb in g_thread_pool_thread_proxy (data=0x8be2e00)
    at /build/buildd/glib2.0-2.16.4/glib/gthreadpool.c:265
#4 0xb6fcde2f in g_thread_create_proxy (data=0x8cec4d8)
---Type <return> to continue, or q <return> to quit---
    at /build/buildd/glib2.0-2.16.4/glib/gthread.c:635
#5 0xb7cd24fb in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#6 0xb6e8de5e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 44 (Thread 0xb1180b90 (LWP 12568)):
#0 0xb7f5f410 in __kernel_vsyscall ()
#1 0xb7cd6aa5 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb71f95bf in gst_task_func (task=0xaf81e6e8, tclass=0x8c22308)
    at ...

Read more...

Matthew Woerly (nattgew) wrote :

Ok, I did a backtrace for mine.

Martin-Éric Racine (q-funk) wrote :

I get this same bug, but at random and doing normal playback, when clicking on a new song while another is already playing back. Rhythmbox simply freezes while playing back some files, since Intrepid, with the same symptoms shown by others. The backtrace is similar too.

Martin-Éric Racine (q-funk) wrote :

To rephrase this better: I get random freezes while playing back some songs, and freezes after selecting a new song that interrupts playback of the current song.

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in rhythmbox:
status: Incomplete → Invalid
Munchkinguy (10068660) wrote :

We've responded to every request for further detail. If you would like something specific, please say so.

Changed in rhythmbox:
status: Invalid → Confirmed

I am sorry, Munchkinguy, I made a misstake here. I had two bugs opened in my webbrowser and wanted to close the other one, but somehow I closed this one. I apologize.

Munchkinguy (10068660) wrote :

That's alright. Thanks for explaining.

Pedro Villavicencio (pedro) wrote :

more like a gstreamer issue. reassigning.

Munchkinguy (10068660) wrote :

In Ubuntu 10.04 Lucid, it is not possible to seek at all. If I click on a different position on the file, the play position indicator just jumps back to its original position.

Matthew Woerly (nattgew) wrote :

I just tried it with Lucid. Dragging the position indicator is working fine for me now (with an Ogg file). When I click on a position, it moves there and plays, but audio goes away. Once I click pause, the audio fades out and stops. I have to click play and then it plays fine.

Yes, ogg vorbis and flac work fine. It is mp3 files that cause the problem.

Matthew Woerly (nattgew) wrote :

Hmm, I just tried an mp3 and it immediately started playing from whatever position I clicked on.

Pedro Villavicencio (pedro) wrote :

that's a different report, this was a duplicate of bug 270700. May you please open a new bug if you're facing something similar with Lucid? please use ubuntu-bug rhythmbox for that, thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments