nautilus crashed with signal 5 in g_return_if_fail_warning()

Bug #188219 reported by Egon Kocjan
6
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
gstreamer0.10 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

I right clicked avi file, selected "Properties..." and nautiles crashed.
nautilus: 1:2.21.90-0ubuntu1
on hardy

ProblemType: Crash
Architecture: i386
Date: Sat Feb 2 00:35:23 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/nautilus
NonfreeKernelModules: cdrom
Package: nautilus 1:2.21.90-0ubuntu1
PackageArchitecture: i386
ProcCmdline: nautilus --no-default-window --sm-client-id default2
ProcCwd: /home/egon
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 5
SourcePackage: nautilus
StacktraceTop:
 g_return_if_fail_warning () from /usr/lib/libglib-2.0.so.0
 g_object_set () from /usr/lib/libgobject-2.0.so.0
 ?? () from /usr/lib/gstreamer-0.10/libgstplaybin.so
 ?? ()
Title: nautilus crashed with signal 5 in g_return_if_fail_warning()
Uname: Linux konan 2.6.24-5-generic #1 SMP Thu Jan 24 19:45:21 UTC 2008 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Revision history for this message
Egon Kocjan (egon-kocjan) wrote :
Revision history for this message
Apport retracing service (apport) wrote : Symbolic stack trace

StacktraceTop:IA__g_return_if_fail_warning (log_domain=0xb7695a6b "GLib-GObject",
IA__g_object_set (_object=0x0, first_property_name=0xb3aef9da "volume")
gen_audio_element (play_bin=0x8686808) at gstplaybin.c:1055
setup_sinks (play_base_bin=0x8686808, group=0x8944648) at gstplaybin.c:1522
group_commit (play_base_bin=0x8686808, fatal=<value optimized out>, subtitle=0)

Revision history for this message
Apport retracing service (apport) wrote : Symbolic threaded stack trace
Revision history for this message
Apport retracing service (apport) wrote : Stack trace with source code
Changed in nautilus:
importance: Undecided → Medium
Revision history for this message
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=514307

Changed in nautilus:
assignee: nobody → desktop-bugs
status: New → Triaged
Changed in nautilus:
status: Unknown → Incomplete
Revision history for this message
Pedro Villavicencio (pedro) wrote :

comment from upstream:

"Can you run: GST_DEBUG=*:2 gst-inspect-0.10 volume"

Changed in nautilus:
status: Triaged → Incomplete
Revision history for this message
Egon Kocjan (egon-kocjan) wrote :
Download full text (4.7 KiB)

I can't seem to reproduce the crashes anymore, I've dist-upgraded and rebooted in between, and everything seems to be fine now.
probably related bug reports:
https://bugs.launchpad.net/ubuntu/+source/gdebi/+bug/188232
https://bugs.launchpad.net/ubuntu/+source/tracker/+bug/188022

But here's the output anyway:
$ GST_DEBUG=*:2 gst-inspect-0.10 volume
Factory Details:
  Long name: Volume
  Class: Filter/Effect/Audio
  Description: Set volume on audio/raw streams
  Author(s): Andy Wingo <email address hidden>
  Rank: none (0)

Plugin Details:
  Name: volume
  Description: plugin for controlling audio volume
  Filename: /usr/lib/gstreamer-0.10/libgstvolume.so
  Version: 0.10.17
  License: LGPL
  Source module: gst-plugins-base
  Binary package: GStreamer Base Plugins (Ubuntu)
  Origin URL: https://launchpad.net/distros/ubuntu/+source/gst-plugins-base0.10

GObject
 +----GstObject
       +----GstElement
             +----GstBaseTransform
                   +----GstAudioFilter
                         +----GstVolume

Implemented Interfaces:
  GstMixer
  GstImplementsInterface

Pad Templates:
  SRC template: 'src'
    Availability: Always
    Capabilities:
      audio/x-raw-float
                   rate: [ 1, 2147483647 ]
               channels: [ 1, 2147483647 ]
             endianness: 1234
                  width: { 32, 64 }
      audio/x-raw-int
               channels: [ 1, 2147483647 ]
                   rate: [ 1, 2147483647 ]
             endianness: 1234
                  width: 8
                  depth: 8
                 signed: true
      audio/x-raw-int
               channels: [ 1, 2147483647 ]
                   rate: [ 1, 2147483647 ]
             endianness: 1234
                  width: 16
                  depth: 16
                 signed: true
      audio/x-raw-int
               channels: [ 1, 2147483647 ]
                   rate: [ 1, 2147483647 ]
             endianness: 1234
                  width: 24
                  depth: 24
                 signed: true
      audio/x-raw-int
               channels: [ 1, 2147483647 ]
                   rate: [ 1, 2147483647 ]
             endianness: 1234
                  width: 32
                  depth: 32
                 signed: true

  SINK template: 'sink'
    Availability: Always
    Capabilities:
      audio/x-raw-float
                   rate: [ 1, 2147483647 ]
               channels: [ 1, 2147483647 ]
             endianness: 1234
                  width: { 32, 64 }
      audio/x-raw-int
               channels: [ 1, 2147483647 ]
                   rate: [ 1, 2147483647 ]
             endianness: 1234
                  width: 8
                  depth: 8
                 signed: true
      audio/x-raw-int
               channels: [ 1, 2147483647 ]
                   rate: [ 1, 2147483647 ]
             endianness: 1234
                  width: 16
                  depth: 16
                 signed: true
      audio/x-raw-int
               channels: [ 1, 2147483647 ]
                   rate: [ 1, 2147483647 ]
             endianness: 1234
                  width: 24
                  depth: 24
                 signed: true
      audio/x-raw-int
               channels: ...

Read more...

Revision history for this message
Sebastien Bacher (seb128) wrote :

Those crashers are warnings, gnome-session was setting G_DEBUG to crash on warnings during a day

Changed in nautilus:
status: Incomplete → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

The bug has been fixed upstream now

Changed in gstreamer0.10:
status: Incomplete → Fix Committed
Revision history for this message
Sebastien Bacher (seb128) wrote :

the new version is available in hardy

Changed in gstreamer0.10:
status: Fix Committed → Fix Released
Changed in nautilus:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.