gnome-gettings-daemon crashes on login

Bug #145492 reported by imjustabill on 2007-09-27
4
Affects Status Importance Assigned to Milestone
gstreamer0.10 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

When I log into Gutsy, i get the following error message:

There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The Settings Daemon restarted too many times.

GNOME will still try to restart the Settings Daemon next time you log in.

When I start from a terminal, I get this:
[1190878581,000,xklavier.c:xkl_engine_start_listen/] The backend does not require manual layout management - but it is provided by the applicationCould not initialize GStreamer: Error re-scanning registry , child terminated by signal

Crash report and backtrace attached

imjustabill (imjustabill) wrote :
Sebastien Bacher (seb128) wrote :
Download full text (3.8 KiB)

The debug backtrace

"#0 0xb7f6ef8f in memset () from /lib/ld-linux.so.2
#1 0xb7f607ed in _dl_map_object_from_fd () from /lib/ld-linux.so.2
#2 0xb7f61a08 in _dl_map_object () from /lib/ld-linux.so.2
#3 0xb7f6af84 in dl_open_worker () from /lib/ld-linux.so.2
#4 0xb7f67016 in _dl_catch_error () from /lib/ld-linux.so.2
#5 0xb7f6a99e in _dl_open () from /lib/ld-linux.so.2
#6 0xb73fdc19 in dlopen_doit () from /lib/tls/i686/cmov/libdl.so.2
#7 0xb7f67016 in _dl_catch_error () from /lib/ld-linux.so.2
#8 0xb73fe2bc in _dlerror_run () from /lib/tls/i686/cmov/libdl.so.2
#9 0xb73fdb51 in dlopen@@GLIBC_2.1 () from /lib/tls/i686/cmov/libdl.so.2
#10 0xb7403684 in g_module_open (file_name=0x8233e60 "/usr/lib/gstreamer-0.10/libgstpostproc.so",
    flags=G_MODULE_BIND_LOCAL) at /build/buildd/glib2.0-2.14.1/gmodule/gmodule-dl.c:98
#11 0xb77764f5 in gst_plugin_load_file (filename=0x8233e60 "/usr/lib/gstreamer-0.10/libgstpostproc.so", error=0x0)
    at gstplugin.c:456
#12 0xb777b8a0 in gst_registry_scan_path_level (registry=0x8095900, path=0xb77a6ae5 "/usr/lib/gstreamer-0.10", level=10)
    at gstregistry.c:938
#13 0xb777bfc8 in gst_registry_scan_path (registry=0x8095900, path=0xb77a6ae5 "/usr/lib/gstreamer-0.10")
    at gstregistry.c:987
#14 0xb773d2d0 in scan_and_update_registry (default_registry=0x8095900,
    registry_file=0x81130e8 "/home/bill/.gstreamer-0.10/registry.i486.xml", write_changes=1, error=0x0) at gst.c:726
#15 0xb773dd38 in ensure_current_registry (error=0xbfcc09d0) at gst.c:829
#16 0xb773ed2a in init_post (context=0x8106070, group=0x8106790, data=0x0, error=0xbfcc09d0) at gst.c:1019
#17 0xb76618b1 in IA__g_option_context_parse (context=0x8106070, argc=0x0, argv=0x0, error=0xbfcc09d0)
    at /build/buildd/glib2.0-2.14.1/glib/goption.c:1743
#18 0xb773e791 in gst_init_check (argc=0x0, argv=0x0, err=0xbfcc09d0) at gst.c:422
#19 0xb773e912 in gst_init (argc=0x0, argv=0x0) at gst.c:469
#20 0x0806bc7b in acme_volume_gstreamer_class_intern_init (klass=0x8106018) at acme-volume-gstreamer.c:425
#21 0xb7711d41 in IA__g_type_class_ref (type=135290664) at /build/buildd/glib2.0-2.14.1/gobject/gtype.c:1874
#22 0xb76f829a in IA__g_object_newv (object_type=135290664, n_parameters=0, parameters=0x0)
    at /build/buildd/glib2.0-2.14.1/gobject/gobject.c:853
#23 0xb76f878f in IA__g_object_new_valist (object_type=135290664, first_property_name=0x0, var_args=<value optimized out>)
    at /build/buildd/glib2.0-2.14.1/gobject/gobject.c:986
#24 0xb76f8940 in IA__g_object_new (object_type=135290664, first_property_name=0x0)
    at /build/buildd/glib2.0-2.14.1/gobject/gobject.c:795
#25 0x0806b853 in acme_volume_new () at acme-volume.c:104
#26 0x0805e49b in gnome_settings_module_multimedia_keys_start (module=0x80b87d0) at gnome-settings-multimedia-keys.c:849
#27 0x0805cd2d in gnome_settings_module_start (module=0x80b87d0) at gnome-settings-module.c:141
#28 0x08058923 in start_modules (daemon=<value optimized out>, runlevel=GNOME_SETTINGS_MODULE_RUNLEVEL_GNOME_SETTINGS)
    at gnome-settings-daemon.c:112
#29 0x0805898f in start_modules_idle_cb (user_data=0x80b6da0) at gnome-settings-daemon.c:232
#30 0xb7652551 in g_idle_dispatch (source=0x80c5fb0, callback=0xa0...

Read more...

Sebastien Bacher (seb128) wrote :

The issue looks like a gstreamer0.10 one, reassigning

Markus (makkus) wrote :

I had the same issue.

I did a 'sudo aptitude --purge reinstall' for all installed gstreamer* packages. That fixed it.

Dunno which of the packages is the responsible one.

imjustabill (imjustabill) wrote :

That fixed it!

Sebastien Bacher (seb128) wrote :

Looks like a corrupted installation and not a package bug and that's fixed now, closing, feel free to reopen if you get the issue again though

Changed in gstreamer0.10:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers