Cannot install "ubuntu-desktop" on gutsy (kubuntu-desktop works) on SPARC

Bug #138911 reported by Jose Castillo on 2007-09-11
2
Affects Status Importance Assigned to Milestone
gnome-power-manager (Ubuntu)
Undecided
Unassigned
gstreamer0.10 (Ubuntu)
Medium
Unassigned

Bug Description

I installed Gutsy Tribe 5 on a Ultra 60 via netboot. After everything was installed, I tried to install the package "ubuntu-desktop" to have the GUI interface and not only console.

I have this on my sources.list
--
deb http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse

deb http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse

deb http://us.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
--

I ran this command: "sudo apt-get update; sudo apt-get install ubuntu-desktop"

And I get the following error:
--
Some packages could not be installed. This may mean that you have
requestes an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ubuntu-desktop: Depends: gnome-power-manager but it is not going to be installed
                         Depends: gnome-session but it is not going to be installed
E: Broken packages
--

I checked and if I try to manually install gnome-power-manager I get the following unmet dependency
--
gnome-power-manager: Depends: libwnck18 (>= 2.15.90) but it is not installable
--

And gnome-session
--
gnome-session: Depends: gnome-power-manager but it is not going to be installed
--

So I think libwnck18 has an old version or maybe it's not available under SPARC.

Thanks

Jose Castillo (jcastill) wrote :

Add package with problem

Oliver Grawert (ogra) wrote :

gnome-power-manager (2.19.92-0ubuntu2) gutsy; urgency=low

  * turn -Wcast-align into -Wno-cast-align to work around LP: #138911
    and fix ftbfs on sparc

 -- Oliver Grawert <email address hidden> Wed, 12 Sep 2007 11:46:51 +0200

Changed in gnome-power-manager:
status: New → Fix Released
Oliver Grawert (ogra) wrote :
Changed in gstreamer0.10:
importance: Undecided → Medium
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers