totem-mozilla cannot play embeded video, although mozilla-mplayer does

Bug #112183 reported by Roman Polach on 2007-05-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GStreamer
Expired
Medium
Totem
Invalid
Undecided
Unassigned
gstreamer0.10 (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

In feisty (and edgy too), the embeded video in following page cannot
be played by totem-mozilla, although mozilla-mplayer plays it correctly...
http://www.nova.cz/tvarchiv/?238d=21.11.2006&238m=p&238p=112&238v=43116

Roman Polach (rpolach) wrote :

Still the same problem with Gutsy..

wolfger (wolfger) wrote :

There doesn't seem to be a totem-mozilla package in Launchpad; associating this bug with the totem package.

Pedro Villavicencio (pedro) wrote :

Thanks for the bug report. This particular bug has already been reported into our bug tracking system, but please feel free to report any further bugs you find.

Changed in totem:
status: New → Invalid
wolfger (wolfger) wrote :

Pedro,
Instead of marking this "Invalid", it would be better to "mark as duplicate" so that the original submitter can follow the progress on the issue.

Leon van der Ree (lvanderree) wrote :

where is the original bug-report for this bug?

I cannot find it, but have the same problem with this url:
http://www.rtl.nl/(vm=/service/gemist/home/,id_by_component)/system/video/html/components/shows/idols4/miMedia/2007/week51/za19.Idols_4.xml

totem-mozilla seems to resolve the url to the stream incorrectly (when you copy the url from the embedded totem plugin you get an url to a transparant.gif) while mozilla-mplayer works correct.

Roman Polach (rpolach) wrote :

I cannot find the same or similar bug in launchpad.
Pedro,
do you agree to change status to "New" until somebody find original bug?

Emmet Hikory (persia) on 2007-12-28
Changed in totem:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Sure, btw the url leon posted works fine for me with Hardy, can someone else try to test it too?

Changed in totem:
status: New → Incomplete
Roman Polach (rpolach) wrote :

leon's url does not work for me,
nor in Hardy with totem-mozilla, nor in Gutsy with mozilla-mplayer.
It seems that stream server is down for me.
I tried it today and yesterday too.
Thats strange because it works for Pedro.

Anyway, the original link
http://www.nova.cz/tvarchiv/?238d=21.11.2006&238m=p&238p=112&238v=43116
works in Gutsy with with mozilla-mplayer
but still does not play in Hardy with totem-mozilla.

Roman Polach (rpolach) wrote :

seems to leon's url stream server works for me now...

here are summary results:

totem-mozilla, original url: does not play (nor in gutsy, nor in hardy a2)
totem-mozilla, leon's url: does not play in gutsy, but plays ok in hardy a2
mozilla-mplayer, original url: plays ok (both in gutsy and in hardy a2)
mozilla-mplayer, leon's url: does not play (nor in gutsy, nor in hardy a2)

Roman Polach (rpolach) wrote :

shouldn't be "incomplete" status cleared now?

Roman Polach (rpolach) wrote :

"This bug report will be marked for expiration in 48 days if no further activity occurs."
- this message is displayed because this bug stays in "Incomplete" status.
Why? Isn't provided info sufficient?

wolfger (wolfger) wrote :

Changing status to "New" since I don't see any unanswered questions.

I am running Gutsy Kubuntu with Mozilla-Mplayer, and I can play the original URL, but not Leon's.
I installed Totem-Mozilla and uninstalled Mozilla-Mplayer, and I can still play the original URL, but not Leon's.

Changed in totem:
status: Incomplete → New
Basilio Kublik (sourcercito) wrote :

Hi there
It works fine for me too, could you please check with an up-to-date hardy heron, and report back.

Thanks

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Roman Polach (rpolach) wrote :

another try on hardy - beta:

original link; totem-mozilla --- playback is very chopping, probably gstreamer issue
leon's link; totem-mozilla --- ok
original link; mozilla-mplayer --- ok
leon's link; mozilla-mplayer --- not played

Roman Polach (rpolach) wrote :

I should note that original link with totem-mozilla work only sometimes.
But I cannot say what is this dependent on.

Any more information needed or "Incomplete" status can be cleared now?

Roman Polach (rpolach) wrote :

In Hardy final,
original link is now played ok in totem-mozilla...
still no success with leon's link and mozilla-mplayer.

Pedro Villavicencio (pedro) wrote :

still an issue ? may someone get a firefox log ? just run firefox from the command line and try to see the video after that attach the output to the report, thanks.

Leon van der Ree (lvanderree) wrote :

The links now work for me with FF3 and totem in hardy, but not in FF2 with totem in hardy.

I have a lot of problems with FF2 and media/java-plugins, it keeps asking me to install the appropriate plugin, but it already is installed and is working in FF3.

attached is the log of a working FF3 combined with totem, I will add another log of FF2, which fails

Leon van der Ree (lvanderree) wrote :

I cannot make firefox 2 output a log...

but it comes down to FF2 not capable of finding a plugin, and when I ask to install the plugin it says:

No suitable plugins where found.
Unknown Plugin (application/x-mplayer2)

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Intrepid Ibex. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Roman Polach (rpolach) wrote :

In Intrepid alpha4, with totem-mozilla:
videos from www.nova.cz are played but with several minutes wait before it starts playing.
It does not play leon's link video at all.

I cannot test mozilla-mplayer in Intrepid, because it is not available in repos.

Roman Polach (rpolach) wrote :

I cannot test it with totem-mozilla on intrepid alpha6 or beta,
because https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/274922

Sebastien Bacher (seb128) wrote :

could you try on intrepid now?

Roman Polach (rpolach) wrote :

1) leon's url works for me...
2) www.nova.cz site has been redesigned and seems to use flash video now so it is not more subject to this issue..

I have found some more sites that totem-mozilla FAILS to play:
3) http://www.tvinfo.cz/stranky/stream11
4) http://www.ceskatelevize.cz/vysilani/10169539755-72-jmen-ceske-historie/208572232200020-11.11.2008-17:40-tadeas-hajek-z-hajku.html

At both those urls some caching probably started (according to network monitor) but video never started to play
(although download rate was about 80K/s and I have wait more than 10 minutes...)

Changed in totem:
status: Incomplete → New
Lionel Dricot (ploum) wrote :

I confirm this bug.

Changed in totem:
status: New → Confirmed
Changed in totem:
status: Unknown → New
Changed in totem:
status: Confirmed → Triaged
Arne Holmström (ar-holst) wrote :

Totem vägrar att spela filmer med kod "video TS vob. Inte heller video från youtube och inte direktsändningar från Sreambowl TV
Standardsvar "du kanske inte har tillåtelse att spela upp videon"

affects: totem (Ubuntu) → gstreamer0.10 (Ubuntu)
Changed in totem:
importance: Unknown → Undecided
status: New → Invalid
Changed in gstreamer:
importance: Unknown → Medium
status: Unknown → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.