MKV with PCM sound track in very bad quality on Totem-Gstreamer

Bug #94506 reported by Jérôme Dubois on 2007-03-21
2
Affects Status Importance Assigned to Milestone
gstreamer (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, i converted a AVI file into MKV (Matroska) with mkvtoolnix-gui and, the sound is very very bad quality with Gstreamer (Totem-Gstreamer).
Mplayer and VLC do not have the problem.

The sound track is in PCM format, not problem with MP3 or Vorbis.

AVI version does not have the problem.

For the test, download this file http://ia300124.us.archive.org/3/items/TrustedComputing/TrustedComputing_LAFKON_SUPERHIGH_XivD.avi .

Convert the file with mkvtoolnix-gui.

And play your MKV files with Totem-Gstreamer.

The problem exists on Ubuntu 6.10 and 7.04

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 alpha?

Changed in gstreamer:
status: New → Incomplete
Jérôme Dubois (jeromedubois) wrote :

Yes, this symptom is reproducible in Ubuntu 8.04 and 8.10 (Beta) up-to-date.

Ubuntu 8.10 :
The MKV file is tested with VLC 0.9.3, Mplayer 1.0 RC2 and Totem-Gstreamer 2.24.1 (GStreamer 0.10.20).

AVI file is converted with MKVToolnix 2.0.2.

VLC and Mplayer reads the file normally, Totem-Gstreamer reads but sound is very bad quality. This problem looks like a "saturation".

Jérôme Dubois (jeromedubois) wrote :

The symptoms disappeared with updates (currently Totem 2.24.3 and Gstreamer 0.10.21)

Changed in gstreamer:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers