Aspect ratio wrong with twinview enabled

Bug #164977 reported by Andy Owen on 2007-11-25
2
Affects Status Importance Assigned to Milestone
gstreamer (Ubuntu)
Undecided
Unassigned

Bug Description

When showing videos using gstreamer, e.g:

gst-launch-0.10 playbin uri=file:///path/to/video

The aspect ratio is calculated incorrectly (it looks like it is half the width it should be)

Changing my xorg.conf to disable TwinView:

< Option "TwinView" "0"
< # Option "metamodes" "CRT: 1600x1200 +0+0, DFP: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0, DFP: nvidia-auto-select +1280+0; CRT: 1024x768 +0+0, DFP: nvidia-auto-select +1024+0; CRT: 800x600 +0+0, DFP: nvidia-auto-select +800+0; CRT: 640x480 +0+0, DFP: nvidia-auto-select +640+0"
---
> Option "TwinView" "1"
> Option "metamodes" "CRT: 1600x1200 +0+0, DFP: nvidia-auto-select +0+0; CRT: 1280x1024 +0+0, DFP: nvidia-auto-select +1280+0; CRT: 1024x768 +0+0, DFP: nvidia-auto-select +1024+0; CRT: 800x600 +0+0, DFP: nvidia-auto-select +800+0; CRT: 640x480 +0+0, DFP: nvidia-auto-select +640+0"

Fixes the problem.
(I don't really understand how TwinView works, but the metamodes line looked like it was related, so it got commented out).

The video card is a GeForce 6600, using the restricted driver (v1.0-9639) (as installed by the restricted manager)

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10?

Changed in gstreamer:
status: New → Incomplete
Andy Owen (the-new-andy) wrote :

No, I don't think it is. Mark as fixed.

Changed in gstreamer:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers