[Gutsy] Erratic volume control behaviour

Bug #158590 reported by tranqy on 2007-10-30
26
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Unknown
gstreamer (Ubuntu)
Low
Unassigned

Bug Description

I have Creative Xmod. Trying to control volume with the knob on it or with gnome volume control applet results in random effects like disconnect of left and right channel lock, mute, and volume jumps. This bug is also submitted in alsa-driver:

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/155109

but closing volume control applet and using alsamixer seems to work ok, so this bug is not ALSA related.

Øyvind Stegard (oyvinst) wrote :

Seeing the exact same problem, Creative Xmod + Ubuntu Gutsy = very funky volume control. The volume control worked fine in Feisty, so this is a regression.

Using alsamixer _alone_ works fine.

This problem might apply to any USB audio device in general, I'm not sure, I've only got the Xmod.

tipsqueal (cptch4os) wrote :

I am having the same issue stated above by both people. The volume adjustment is not working properly with my USB headset. If I try to adjust the volume with the Volume Applet (with my mouse) it does the same thing, so it's not just the buttons on my headset. I found that I don't actually have to close the volume control applet (although it is pretty useless) and the alsamixer still fixes the problem.

My system:
Clean install Ubuntu 7.10
Plantronics DSP 500 (now called GAMECONPRO 1)
http://www.newegg.com/Product/Product.aspx?Item=N82E16826106070

nSTER (navst3r) wrote :

I got the exact same problem, It only happens on gnome. As xfce, and kde are both fine. I have the same headsets as tipsqual. This is the only thing preventing me from using ubuntu.

filipebrandao_ (filipebrandao-) wrote :

Same problem with:
 Clean install Ubuntu 7.10
 Plantronics DSP 500 (now called GAMECOMPRO 1):
 http://www.newegg.com/Product/Product.aspx?Item=N82E16826106070

James Cockshaw (jacockshaw) wrote :

Yep same problem for me on Gutsy... USB Logitech V20.

Anyone found a solution yet?

No proper solutions that I know of, only work-arounds .. basically just use alsamixer or amixer for plain volume control. It's also possible to get volume control buttons on a device to work (if applicable) without letting Gnome handle it (/screw it up). Most USB audio-devices send key events for volume up/down and mute (those that have a volume control), so these keys can be re-mapped to a script which adjusts volume up/down or toggles mute using amixer. Not very elegant, but works, I'm currently doing this, so that I can use the volume control button on my Creative Xmod.

Allard Hoeve (allard) wrote :

Same bug here with a Plantronics DSP 300. Please fix.

Armand Delcros (armand-delcros) wrote :

Same problem for me on gutsy gibbon with "Creative Sound Blaster XMOD". Nobody find a good workaround ? (for the moment I use "alsamixer").

Regards guys

resoli (resoli-libero) wrote :

The same here. I'm using "Ensoniq Audio PCI" (es1370 driver).
I installed gnome-alsamixer package and it works well.
Gnome-sound-recorder gives an error on startup (Capture settings invalid), but recording fom Audacity works. Hence i guess the problem is inside Gnome audio applets.

Roberto

Patrick Walton (pcwalton) wrote :

I'm getting this too, with my Logitech laptop USB V20 speakers. All ALSA-based volume controls work, all GNOME-based volume controls fail. It's not just the left channel: both volume controls are extremely erratic when controlled through GNOME. If running a GNOME-based volume control, then ALSA can control the right channel properly, but the left channel fails. Only by shutting down all GNOME volume controls can the volume be controlled properly.

Possibly an issue in the gstreamer framework?

Joachim Sauer (saua) wrote :

I've got the same issue with the Logitech USB headset, that's already been mentioned.

I've found a bug in the GStreamer Bugzilla which seems to describe exactly this issue (see gnome-bugs link above)

Changed in gstreamer:
status: Unknown → Incomplete
Allard Hoeve (allard) wrote :

Dear Joachim, what's that link you refer to? Don't seem to be able to find it. Thanks!

Nikolay Belikov (cre8r) wrote :

There is a bug, https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/155109 , which describes the same problem, but refers to different package, alsa-driver. Should we mark it as a duplicate of this one?

mb (mattb108) wrote :

I started having this in my fresh install of Hardy. I do not have USB sound. I have a PCI Razer Barracuda (CMedia CMI8788), attached to surround speakers. For me the erratic volume control behavior was only associated with the "Master" channel, and happened whether I used keyboard volume keys or mouse to adjust. I got around this problem by setting the master channel to full and hiding it in volume control, so only PCM showed. I then right-clicked on the Notification Area volume applet -> preferences and switched to PCM. I then went to System -> Preferences -> Sound and chose PCM at the bottom as the track controlled by keyboard.

Fixed it for me.

Changed in gstreamer:
status: Incomplete → New
Nikolay Belikov (cre8r) wrote :

mb, unfortunately, some devices, such as my Logitech v20, do have only PCM control, so your hotfix won't help :(

tranqy (linas-n) wrote :

Yes 155109 is a duplicate, it does not seem to be ALSA problem though.

Changed in gstreamer:
status: New → Confirmed
Maxim Levitsky (maximlevitsky) wrote :

This is clearly a gstremer alsa mixer bug.

I found a workaround, which is to switch to OSS mixer in sound settings
OSS mixer is just an emulation on top of alsa, but gsteremer doesn't have this bug
in oss mixer code.

Henry Finucane (h-finucane) wrote :

That workaround works beautifully- but the underlying problem should still get fixed. And it doesn't look like there has been any progress upstream.

8-bit Blaster (neon-lime) wrote :

I am running Hardy Heron and have a CMEDIA ASUS onboard sound...

Have had this exact same problem and it's very discouraging. I have absolutely no way of changing my volume because the sliders and buttons make the volume bar move so erratically.

Changed in gstreamer:
importance: Undecided → Low
status: New → Triaged
Maxim Levitsky (maximlevitsky) wrote :

This seems to be finally fixed in interpid, take a look
Here this bug vanished

Øyvind Stegard (oyvinst) wrote :

Well, that is definitely not true for everyone. I have huge hardware volume control problems with Intrepid and USB audio (Creative Xmod) from the standard Gnome mixer. In addition to that, Pulseaudio does not control the hardware mixer, so now I have FOUR volume controls that together determine the final volume (CRAZY !):
* Application-internal volume (GStreamer, software)
* Pulseaudio per-application volume (software)
* Pulseaudio device-volume (software again!)
* Hardware mixer volume
* (The volume knob on my amplifier)

*Sigh*

I wish Pulseaudio could take control of the hardware mixers as well.. I'm going mad adjusting all the volume sliders, here ..

Changed in gstreamer:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.