Apple WWDC 2007 video stream fails to play

Bug #121225 reported by gobbles414 on 2007-06-19
4
Affects Status Importance Assigned to Milestone
gstreamer (Ubuntu)
Undecided
Unassigned
mplayer (Ubuntu)
Undecided
Unassigned

Bug Description

I am new to Launchpad... so forgive me if I am going about this incorrectly.

In the i386 version of Ubuntu 7.04, I am unable to access Apple's video stream of the WWDC 2007 keynote presentation (http://events.apple.com.edgesuite.net/d7625zs/event/). My Firefox version is 2.0.0.4+1-0Ubuntu1. I have replaced the default Totem plugin with the MPlayer plugin (version 3.31+main-1Ubuntu1). I also have w32codecs and the good/bad/ugly gstreamer0.10 packages installed. I was able to get sound in Firefox on my first attempt playing the stream, but no picture. All subsequent attempts to play the stream in Firefox have resulted in total failure. The stream acts like it is loading; but then it stops before loading any sound or picture. The stream also fails to load in the Totem, MPlayer, and VLC media players.

This bug has actually been reported once before (Bug #119963). Unfortunately, the bug was incorrectly attributed to an Apple server problem. I confirm that on my home network, OS 10.4 (PPC) and Vista Ultimate (32 bit) play the stream flawlessly in QuickTime 7.x while Ubuntu 7.04 fails to even load the stream.

gobbles414 (gobbles414) wrote :

In an email, a user called Jivan requested that I post a procedure on how to replace the Totem plugin with the MPlayer plugin in Ubuntu 7.04. Here is the text of that email:
"Hi there, I saw your bug. I am curious how you were able to replace the default Totem plugin with the MPlayer plugin (version 3.31+main-1Ubuntu1) . Please lemme know the procedure so I'll try to confirm the same.-- Shanti Om! Jivan"

And the procedure...
(1) Go to System --> Administration --> Synaptic Package Manager
(2) Search for the term: totem-mozilla
(3) Right-click on the package and select "mark for complete removal".
(4) Search for the term: mozilla-mplayer
(5) Right click on the package and select "mark for installation"
(6) Apply

Shirish Agarwal (shirishag75) wrote :

hi all,
       On gutsy on firefox 2.0.0.4 I am able to hear the sound output with the Mplayer plugin . I am using mplayer plugin (3.40-5ubuntu2) and have configured oss as my audio output decoder while I have tried all the 3 video output decoders (gl, x11, xv) but picture isn't happening. There is possibility that I need to configure somethings more in the video decoder stuff (which I don't know) but the audio is easily heard.

You can see the CLI output on http://paste.ubuntu-nl.org/28043/ esp. line 23 which does tell that its unable to find a suitable codec :(

I played the file no. of times and as far as sound is concerned there are no issues.

Shirish Agarwal (shirishag75) wrote :

Actually http://paste.ubuntu-nl.org/28044/ is the full info. of the firefox session. I also tried with granparadiso & the audio works there as well :) . Hence as far as audio streaming part is concerned it works (in gutsy atleast) but video doesn't (might be user issue also). If any further tests have to be done or further guidance please lemme know.

Brian Murray (brian-murray) wrote :

Directly accessing the url with mplayer reveals the following message:

Connecting to server a2047.v1413b.c1413.g.vq.akamaistream.net[64.194.248.136]: 554...
A single media stream only is supported atm.
rtsp_session: unsupported RTSP server. Server type is 'QTSS-Akamai/5.0.2 (Build/452.2.1; Platform/Linux; Release/Panther; )'.
STREAM_LIVE555, URL: rtsp://a2047.v1413b.c1413.g.vq.akamaistream.net/5/2047/1413/2_h264_110/1a1a1ae656c632970267e04ebd3196c428970e7ce857b81c4aab1677e445aedc3fae1b4a7bafe013/99427722_2_110.mov

gobbles414 (gobbles414) wrote :

Well, it's good to know that the audio situation is solved either by changes in MPlayer 3.3 to 3.4 and/or Feisty to Gusty. However, the lack of video is still disappointing. Has anyone tried accessing the stream with Totem or VLC plugins?

gobbles414 (gobbles414) wrote :

Hi all,

I thought that it was important to post that a new QuickTime stream is failing to play. It is of Jobs presenting the new iMac. The URL is (http://events.apple.com.edgesuite.net/r27842e/event/index.html?test=q1wa2sz3x). Note that since my last post I have enabled backports on my computer, with no change in this bug's behavior.

kop (luis-kop) wrote :

I have the same problem that Brian Murray.

How you play movies like http://events.apple.com.edgesuite.net/r27842e/event/index.html?test=q1wa2sz3x in ubuntu?
I can't.

gobbles414 (gobbles414) wrote :

After installing Ubuntu 7.10 Gusty, mplayer 3.40-5ubuntu5 and mozillia-mplayer 2.10~rc2~0ubuntu1~gusty1, I have had some success playing the files at the Apple Events website. However, this problem still needs to be worked on before we declare the bug fixed.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 beta or later?

Changed in mplayer:
status: New → Incomplete
Shirish Agarwal (shirishag75) wrote :

This sympton is still reproducible in 8.10 beta

Have the same issue as Brian Murray said .

 I tried playing through mplayer

mplayer http://stream.qtv.apple.com/events/aug/r27842e/m_428396549_650_ref.mov

The results were sadly the same as Brian's . This btw is on firefox 3.0.3 version and similarly for mplayer and others.

Shirish Agarwal (shirishag75) wrote :

There is success in playing the first clip through mplayer (directly connecting)

http://stream.qtv.apple.com/events/jun/d7625zs/m_99427722_650_ref.mov

as well as gmplayer but with one major difference. In mplayer I get the sound and the picture, in gmplayer only the picture, no sound.

The sound picture quality leaves much to be desired but that I guess is another bug for another time.

Attaching the success play thing as well.

So right now its 50-50 in my book. As far as getting it through firefox is concerned, really don't know, for ff still crashes or hangs sometimes while playing streaming. (Another bug unrelated)

Reinhard Tartler (siretart) wrote :

I've been able to play that file in intrepid with both mplayer and totem (using gstreamer) with both sound and video. I'm therefore marking this bug as 'fix released' for both bug tasks.

some notes:

 - my browser plugin didn't work, I had to download that file and play it directly (i.e. without browser)
 - the file is a redirect file, the media is always directly streamed.

Changed in gstreamer:
status: New → Fix Released
Changed in mplayer:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers