Totem using GStreamer as backend cannot play RealVideo RV30/40 files

Bug #111557 reported by Roman Polach on 2007-05-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gstreamer (Ubuntu)
Undecided
Unassigned
gstreamer0.10-pitfdll (Debian)
Fix Released
Unknown

Bug Description

In Feisty,
Totem cannot play RealVideo RV30/40 *.rm files, although mplayer can play them correctly.
Gstreamer displays error message "GStreamer encountered a general stream error".
MPlayer uses its "rv3040" codec to play them.

Installed relevant packages:
gstreamer0.10-ffmpeg,
gstreamer0.10-pitfdll,
gstreamer0.10-plugins-bad,
gstreamer0.10-plugins-bad-multiverse,
gstreamer0.10-plugins-ugly,
gstreamer0.10-plugins-ugly-multiverse,
w32codecs (medibuntu).

Roman Polach (rpolach) wrote :

When a rv3040 video is contained in an MKV file,
then the Totem/gstreamer error message is different:

An error occured:
GstPlayBin: A subtitle stream was detected, but no video stream.

Roman Polach (rpolach) wrote :

In Gutsy, Totem plays correctly rv3040 .rm file with ffcook audio,
but it crashes when opening rv3040 .rm file with rasipr audio.

Stéphane Loeuillet (leroutier) wrote :

Can't find gstreamer0.10-pitfdll anymore in Gutsy.
Anyway, no 0.10.x release has never been done (latest available is 0.8.x)
But it shouldn't be needed

gstreamer0.10-ffmpeg should do the work

Could you provide such a file please ? (smaller is better)

Stéphane Loeuillet (leroutier) wrote :

Marking as Incomplete until file is provided

Changed in gstreamer:
status: New → Incomplete
Roman Polach (rpolach) wrote :

I see (and have installed) gstreamer0.10-pitfdll 0.9.1.1+cvs20070321-1ubuntu1 form Gutsy Universe repository.

Attaching .rm file that crashes totem but not mplayer... sorry, it has about 1M, I do not have smaller one.

Changed in gstreamer:
status: Incomplete → New
Stéphane Loeuillet (leroutier) wrote :

Unfortunatly, I'm on AMD64, where pitfdll isn't available.
So someone else would have to do the testing

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 beta?

Changed in gstreamer:
status: New → Incomplete
Anthony Fok (foka) wrote :

I doubt that this bug is fixed in 8.10 beta.

According to this post http://www.unixresources.net/linux/clf/game/archive/00/00/61/34/613465.html "GStreamer still cannot play rmvb files?" (in Chinese) from year 2006, the root cause is that the gstreamer0.10-pitfdll package does not yet contain any code to handle proprietary RealVideo codecs from w32codecs. The versions of gstreamer0.10-pitfdll in hardy 8.04 and intrepid 8.10 are exactly the same.

While ffmpeg can decode some older RealVideo files, it does not yet handle RV30/40 ones.

So, this symptom won't magically cure itself. Either an open-source implementation of the RV30/40 codec appears (unlikely), or pitfdll adapts more code (from xine or mplayer) to handle the proprietary binary RV30/40 codec library, GStreamer would not be able handle RV30/40 RealVideo files.

but I'll try it out later today on intrepid 8.10 beta to make sure.

Changed in gstreamer:
status: Incomplete → Confirmed
Anthony Fok (foka) on 2008-10-15
Changed in gstreamer0.10-pitfdll:
importance: Undecided → Unknown
status: New → Unknown
Anthony Fok (foka) wrote :

My mistake. I spoke too soon. :-)

With w32codecs installed, the "video" portion of Real Video 4.0 file can indeed play on Intrepid 8.10 beta! And, contrary to what I thought, it is not handled by gstreamer0.10-pitfdll, but rather by gstreamer0.10-plugins-bad (0.10.8), which is a new version in Intrepid (and in Debian experimental). The upstream NEWS.gz list the following fix (among many others):

    * Fix the Real codec wrapper plugin

Unfortunately, there is no audio:

    ** Message: don't know how to handle audio/x-pn-realaudio, raversion=(int)10, flavor=(int)0, rate=(int)32000, channels=(int)2, width=(int)16, leaf_size=(int)256, packet_size=(int)256, height=(int)1, codec_data=(buffer)021290
    ** Message: Missing plugin: gstreamer|0.10|totem|RealAudio decoder|decoder-audio/x-pn-realaudio, raversion=(int)10, flavor=(int)0 (RealAudio decoder)
    ** Message: Automatic missing codec installation not supported (helper script missing)

When mplayer is used to play the same file, the following is shown:
    ==========================================================================
    Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
    FAAD: compressed input bitrate missing, assuming 128kbit/s!
    AUDIO: 32000 Hz, 2 ch, s16le, 128.0 kbit/12.50% (ratio: 16000->128000)
    Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
    ==========================================================================

But gst-inspect does show the existence of the faad plugin. Hmm...

Changed in gstreamer0.10-pitfdll:
status: Unknown → New
Krinn (kr86420) wrote :

RV40 is decodable by libavcodec as of svn20081203.

Krinn (kr86420) wrote :

Works fine in Jaunty.

Changed in gstreamer (Ubuntu):
status: Confirmed → Fix Released
Roman Polach (rpolach) wrote :

Still not fixed in Lucid.
http://launchpadlibrarian.net/10218170/underworld1.rm gives the error message described.
Please reopen

Changed in gstreamer0.10-pitfdll (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.