Totem displays a green screen on H264 videos with gstreamer1.0-vaapi

Bug #1784242 reported by Mossroy on 2018-07-29
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gstreamer-vaapi (Ubuntu)
Undecided
Unassigned

Bug Description

On a Ubuntu 18.04 (amd64) laptop, all H264 videos read by Totem display a green screen (but the audio is fine, and the subtitles are displayed above the green screen). VLC reads them properly. Totem reads them properly on another Ubuntu 18.04 computer.
If I remove the package gstreamer1.0-vaapi, the videos are read properly.
If I install it back (version 1.14.1-1~ubuntu18.04.1), the videos are green again.

There is no error message in the kernel log, or in the standard output of Totem.
I suppose the hardware decoding is failing?
All the packages are up-to-date.

The laptop is a Lenovo X201 with a Core i5 M 540 CPU, with no other graphics card.

All videos should be read properly (with hardware acceleration if possible, but it should fallback to software decoding if something goes wrong).

vainfo output :
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_1
libva info: va_openDriver() returns 0
vainfo: VA-API version: 1.1 (libva 2.1.0)
vainfo: Driver version: Intel i965 driver for Intel(R) Ironlake Mobile - 2.1.0
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple : VAEntrypointVLD
      VAProfileMPEG2Main : VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264Main : VAEntrypointVLD
      VAProfileH264High : VAEntrypointVLD
      VAProfileNone : VAEntrypointVideoProc

Mossroy (mossroy) wrote :

After some more tests, the green screen does not affect all the H264 videos, but only some of them.
It does not seem to depend on the container (Matroska or Quicktime), on the FPS, on the H264 profile or on the encoding software.

It seems to me that it depends on the resolution (not 100% sure anyway) :
All the 1920x1080 videos I tested gave a green screen. And also the following resolutions : 720x302, 720x384, 712x574.
All the 1280x720 videos I tested were working fine. And also the following resolutions : 640x480, 320x240, 720x576.

Removing the gstreamer1.0-vaapi package is a working workaround.

Mossroy (mossroy) wrote :

There seems to be similar reports about green screens with Ironlake Intel CPUs and VA-API :
https://askubuntu.com/a/1053324/555062
https://github.com/mpv-player/mpv/issues/2123
https://bugs.freedesktop.org/show_bug.cgi?id=91309

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer-vaapi (Ubuntu):
status: New → Confirmed
Radek Dostal (radekdostal) wrote :

I can also confirm the issue.

Software: fresh Ubuntu 18.04 installation
Computer: Dell Latitude E6510
CPU: Intel(R) Core(TM) i5 CPU M 540 @ 2.53GHz (Ironlake)
Test file: H264 1920x1080

totem: shows only green screen, no video playback

mpv: video does not play smoothly + following is printed to console:
Audio/Video desynchronisation detected! Possible reasons include too slow
hardware, temporary CPU spikes, broken drivers, and broken files. Audio
position will not match to the video (see A-V status field).

mpv --hwdec=no: plays perfectly - ca 60% of cpu is idle

vlc (video output set to "Automatic"): video does not play smoothly + following is printed to console:
[00007fccb4c1a930] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)

vlc (video output set to "XVideo output (XCB): plays perfectly - ca 55% of cpu is idle

Radek Dostal (radekdostal) wrote :

One more comment - I recently discovered this libva bug:

https://bugs.freedesktop.org/show_bug.cgi?id=47858

and I can confirm, that decoding of 720p video using libva works on "Intel(R) Core(TM) i5 CPU M 540 @ 2.53GHz (Ironlake)", but decoding of 1080p does not.

I had the same problem, I solved it by running sudo apt remove gstreamer1.0-vaapi and sudo apt autoremove.

Mario Galan (mario-galan-gmail) wrote :

The solution from Christhian worked for me, thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.