gstreamer-vaapi + nvidia driver causes firefox to crash on animated gifs / video tags

Bug #1395070 reported by Joe Barnett on 2014-11-21
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Fix Released
Medium
gstreamer-vaapi (Ubuntu)
Low
Unassigned

Bug Description

when loading pages with animated gifs wtih gstreamer-vaapi packages installed, firefox crashes with the following stacktrace:
https://bugs.launchpad.net/ubuntu/+source/gstreamer-vaapi/+bug/1395070/+attachment/4273341/+files/stacktrace.txt

The Mozilla Crash Reporter IDs are available from:
https://launchpadlibrarian.net/191714886/SubmittedCrashIDs.txt

An example URL that demonstrates this problem is = ?

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: gstreamer1.0-vaapi (not installed)
ProcVersionSignature: Ubuntu 3.16.0-23.31-generic 3.16.4
Uname: Linux 3.16.0-23-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.14.7-0ubuntu8
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Nov 21 08:41:48 2014
InstallationDate: Installed on 2014-02-24 (269 days ago)
InstallationMedia: Ubuntu-GNOME 14.04 "Trusty Tahr" - Alpha amd64 (20140218)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gstreamer-vaapi
UpgradeStatus: Upgraded to utopic on 2014-08-17 (95 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gstreamer-vaapi (Ubuntu):
status: New → Confirmed
Changed in gstreamer-vaapi (Ubuntu):
status: Confirmed → Invalid
Joe Barnett (thejoe) wrote :

Hi Christopher,

Would love to open up an apport-created bug for this, but I don't get anything in /var/crash when firefox crashes, or get any apport dialogs (i do get them for other apps). I do get the mozilla crashreporter to show up, and i've used that to "submit a bugreport" many times, but don't know where it gets sent to.

Changed in gstreamer-vaapi (Ubuntu):
status: Invalid → Confirmed

Joe Barnett, fair enough. It would appear Firefox is a one-off exception to this. Hence, could you please provide the stack trace ID URLs as per https://wiki.ubuntu.com/MozillaTeam/Bugs?action=show&redirect=DebuggingFirefox#Submitting_Crashes_to_Mozilla ?

As well, could you please provide the specific URL with animated gifs that demonstrate this issue?

Changed in gstreamer-vaapi (Ubuntu):
status: Confirmed → Incomplete

Cut from Bug Description.

description: updated
description: updated

Joe Barnett, you don't need to file a new report, or do any further apport-collect'ing at this point, unless someone specifically asks. What is still needed though is an example URL that demonstrates this problem.

Joe Barnett (thejoe) wrote :

trying to seek in http://media02.nfl.info/NFL/Media/2014/Video14/Officiating_Media_Video_11-26-14.mp4 causes the crash 100% for me with gstreamer-vaapi installed. scrolling through animated gifs on deadspin.com articles is not quite 100%, but happens often.

Changed in gstreamer-vaapi (Ubuntu):
status: Incomplete → Confirmed

Joe Barnett, when I went to the advised link via Firefox after installing the package gstreamer1.0-vaapi (no additional entries were seen in Firefox > Add-ons > plugins) it noted:
Video can't be played because the file is corrupt.

However, if I open it in Chrome, the video does work.

Hence, could you please advise which package precisely to install in order to test to this issue?

lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04

apt-cache policy firefox
firefox:
  Installed: 34.0+build2-0ubuntu0.14.04.1
  Candidate: 34.0+build2-0ubuntu0.14.04.1
  Version table:
 *** 34.0+build2-0ubuntu0.14.04.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
        100 /var/lib/dpkg/status
     28.0+build2-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

apt-cache policy gstreamer1.0-vaapi
gstreamer1.0-vaapi:
  Installed: 0.5.7-0ubuntu4
  Candidate: 0.5.7-0ubuntu4
  Version table:
 *** 0.5.7-0ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

Changed in gstreamer-vaapi (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Joe Barnett (thejoe) wrote :

you can also try http://media02.nfl.info/NFL/Media/2014/Video15/Officiating_Media_Video_12-05-14.mp4 if that works better -- not sure why it would say file is corrupt, as you saw with chrome it clearly isn't...

here are related packages i have installed when it crashes:

libvdpau1:amd64 0.7-2
vdpau-va-driver:amd64 0.7.4-3
libva-drm1:amd64 1.3.1-3
libva-glx1:amd64 1.3.1-3
libva-wayland1:amd64 1.3.1-3
libva-x11-1:amd64 1.3.1-3
libva1:amd64 1.3.1-3
libgstreamer-vaapi1.0-0:amd64 0.5.9-2
gstreamer1.0-vaapi:amd64 0.5.9-2
firefox 34.0+build2-0ubuntu0
nvidia-331-updates 331.89-0ubuntu5
nvidia-331-updates-uvm 331.89-0ubuntu5
nvidia-cg-toolkit 3.1.0013-1
 nvidia-libopencl1-331-updates 331.89-0ubuntu5
nvidia-opencl-icd-331-updates 331.89-0ubuntu5
nvidia-settings 331.20-0ubuntu8

removal of gstreamer1.0-vaapi also removes libgstreamer-vaapi1.0-0 and libva-glx1, after which firefox is able to successfully play and seek within the video without crashing.

Changed in gstreamer-vaapi (Ubuntu):
status: Incomplete → Confirmed

Joe Barnett, it may be the reason I can't reproduce is I have different extensions and plugins installed then you that cause the plugin to not work. Unfortunately, I'm at a loss as to what precisely is causing my not being able to view the video.

Forage (forage) wrote :

The same issue occurs with the AMD catalyst drivers, so it's not related to just NVIDIA. I'm using Catalyst 14.12.
Starting to play a HTML5 video will instantly crash the browser, no need to seek.

Mantas Kriaučiūnas (mantas) wrote :

This bug should be closed because Firefox doesn't use gstreamer anymore, see last comment at https://bugzilla.mozilla.org/show_bug.cgi?id=894372

Changed in firefox:
importance: Unknown → Medium
status: Unknown → Fix Released

Mantas Kriaučiūnas, the package gstreamer-vaapi is still available in latest Ubuntu. Also, upstream report notes folks who desire gstream-vaapi with Firefox in select use cases.

Given this report is scoped to the package gstreamer-vaapi crashing when in use, and not firefox support of gstreamer-vaapi, I don't see a problem with leaving this report open until issue is resolved for the original reporter, or issue tested resolved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.