All icons in notification area are removed

Bug #541467 reported by Mike Rushton on 2010-03-18
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gSTM
Fix Committed
Undecided
Mike Rushton
gstm (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gstm

Since Ubuntu 9.10 menu icons are removed by default with the option to turn them back on in the interfaces tab in the appearance preferences. Now in 10.04 the option to turn them back on has been removed completely.

This affects gSTM as all the icons in the notification area rely in these menu icons to show connection status of the saved ssh tunnels.

I have attached screenshots of this behavior as an example.

Related branches

lp:~leftyfb/gstm/gstm
Mattias Eriksson: Approve (code) on 2010-03-19
Mike Rushton (leftyfb) wrote :
Mike Rushton (leftyfb) wrote :

attaching screenshot of problem

Linux000 (michael-yoyo) on 2010-03-18
tags: added: regression-potential
Mike Rushton (leftyfb) wrote :

What does regression-potential mean?

Linux000 (michael-yoyo) wrote :

A regression is when the feature works in one version, however, in the latest version no longer works, this isn't a regression yet, because 10.04 isn't the official version, however if it goes unfixed, when 10.04 is released, there will be a regression, thus regression-potential.

Linux000 (michael-yoyo) wrote :

How did you enable the icons in 9.10? I can't find the interfaces tab.

Mike Rushton (leftyfb) wrote :

The interfaces tab should be in preferences - appearance in 9.10. That tab has been removed in 10.04.

You can use ubuntu-tweak ( A must have now that Gnome and Ubuntu love removing options) or:

Open your terminal and type in:

gconf-editor

In GConf-Editor, navigate to desktop -> gnome -> interface

There should be two checkboxes, one for buttons_have_icons and one for menus_have_icons,

enable those and close gconf-editor, but don’t close the terminal

Type in:

killall nautilus

Linux000 (michael-yoyo) wrote :

Ugly fix, but it still works in 10.04, does need a better way though.

Changed in gstm (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Brian Murray (brian-murray) wrote :

The merge proposal for this bug report was made for lp:gstm which is the launchpad project for gstm, not the ubuntu package. The merge proposal should really be made for lp:ubuntu/gstm/.

Emmet Hikory (persia) wrote :

Merge proposal accepted upsteam. Just waiting on release.

Changed in gstm (Ubuntu):
status: Triaged → Won't Fix
assignee: nobody → Mike Rushton (leftyfb)
status: Won't Fix → Fix Committed
Emmet Hikory (persia) on 2010-03-21
Changed in gstm:
status: New → Fix Committed
assignee: nobody → Mike Rushton (leftyfb)
Changed in gstm (Ubuntu):
assignee: Mike Rushton (leftyfb) → nobody
status: Fix Committed → Triaged
tags: added: patch-accepted-upstream
Mike Rushton (leftyfb) wrote :

packaging debdiff

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gstm - 1.2-7ubuntu1

---------------
gstm (1.2-7ubuntu1) lucid; urgency=low

  * Always show the status icons (LP: #541467)
 -- Mike Rushton <email address hidden> Sun, 21 Mar 2010 22:12:54 -0400

Changed in gstm (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers