totem crashed with SIGSEGV

Bug #162500 reported by Matt C on 2007-11-13
6
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Critical
gst-plugins-ugly0.10 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

I was attempting to play a .rm file.

ProblemType: Crash
Architecture: amd64
Date: Tue Nov 13 15:36:12 2007
Disassembly: 0x2abc8e75ec7b <free@plt+24>:
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/totem
NonfreeKernelModules: cdrom
Package: totem-gstreamer 2.20.0-0ubuntu3
PackageArchitecture: amd64
ProcCmdline: totem file:///home/matt/Desktop/city_lights.rm
ProcCwd: /home/matt
ProcEnviron:
 PATH=/home/matt/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_CA.UTF-8
 SHELL=/bin/zsh
Signal: 11
SourcePackage: totem
Stacktrace:
 #0 0x00002abc8e75ec7b in ?? () from /lib64/ld-linux-x86-64.so.2
 #1 0x00000000000000f0 in ?? ()
 #2 0x0000000000000140 in ?? ()
 #3 0x0000000001223b30 in ?? ()
 #4 0x0000000000000000 in ?? ()
StacktraceTop:
 ?? () from /lib64/ld-linux-x86-64.so.2
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: totem crashed with SIGSEGV
Uname: Linux waterloo.openflows.com 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

Matt C (mvc1095) wrote :
Matt C (mvc1095) wrote :

StacktraceTop:?? ()
?? ()
?? ()
?? ()
?? ()

Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Matt C (mvc1095) wrote :

Attached.

Matt C (mvc1095) wrote :

strace attached.

Pedro Villavicencio (pedro) wrote :

I was able to reproduce the crash with the attached file, it seems to be a gstreamer problem. re assigning. thanks.

Changed in totem:
status: Incomplete → Triaged
Matt C (mvc1095) wrote :

Actually, I get the same result using totem-xine.

In case these are separate issues, I've filed a new bug for that crash: https://bugs.launchpad.net/bugs/172867

Pedro Villavicencio (pedro) wrote :

Comment from upstream:

"works fine with latest gst-ffmpeg pre-release + rmdemux from cvs
gst-plugins-ugly.

After having a closer look, this crasher is most likely fixed by the rmdemux
fixes.

Moving bug against gst-plugins-ugly, changing title and marking as fixed
"

Changed in gstreamer0.10-ffmpeg:
status: Triaged → Fix Committed
Changed in gstreamer:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

the new version has been uploaded to ubuntu

Changed in gst-plugins-ugly0.10:
status: Fix Committed → Fix Released
Changed in gstreamer:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.