Totem Plugin isn't working properly with LiveStream in Firefox RC1

Bug #239279 reported by martin on 2008-06-11
4
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
gst-plugins-good0.10 (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu 8.04, Firefox 3 RC1, Totem Web Browser Plugin 2.22.1, all Add-Ons deactivated, Flash Player 10 Beta b218 ...

I tried to watch Live-Stream on "http://www.zdf.de/ZDFmediathek/content/499580?inPopup=true", but nothing happens. Console shows:

** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: NP_Initialize
** Message: NP_Initialize succeeded
** Message: totemPlugin ctor [0xae826c40]
** Message: Init mimetype 'application/x-vlc-plugin' mode 1
** Message: Base URI is 'http://www.zdf.de/ZDFmediathek/content/499580?inPopup=true'
** Message: Real mimetype for 'application/x-vlc-plugin' is 'application/octet-stream'
argv[0] version VideoLAN.VLCPlugin.2
argv[1] progid VideoLAN.VLCPlugin.2
argv[2] type application/x-vlc-plugin
argv[3] id mediaplayer
argv[4] name mediaplayer
argv[5] class vlc
argv[6] autoplay yes
argv[7] loop no
argv[8] target http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx
argv[9] width 100%
argv[10] height 100%
** Message: mSrc: http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx
** Message: mCache: 0
** Message: mControllerHidden: 0
** Message: mShowStatusbar: 0
** Message: mHidden: 0
** Message: mAudioOnly: 0
** Message: mAutostart: 1, mRepeat: 0
** Message: Launching: /usr/lib/totem/gstreamer/totem-plugin-viewer --plugin-type cone --user-agent Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9) Gecko/2008061015 Firefox/3.0 --mimetype application/octet-stream
** Message: Viewer spawned, PID 6134
** Message: GetValue variable 14 (e)
** Message: GetValue variable 15 (f)
** Message: Unhandled variable NPPVpluginScriptableNPObject
** Message: GetValue variable 11 (b)
** Message: GetValue variable 268435466 (1000000a)
** Message: GetScriptable [0xae826c40]
** Message: totemConePlugin ctor [0x9940b10]
** Message: GetValue variable 15 (f)
** Message: Unhandled variable NPPVpluginScriptableNPObject
** Message: GetValue variable 11 (b)
** Message: GetValue variable 268435466 (1000000a)
** Message: GetScriptable [0xae826c40]
** Message: NOTE: Site uses function 'totemIConeInput::GetState'
** Message: Initial window set, XID 30015c3 size 912x513
** Message: No viewer proxy yet, deferring SetWindow
** Message: Viewer DBus interface name is 'org.gnome.totem.PluginViewer_6134'
** Message: NameOwnerChanged old-owner '' new-owner ':1.31'
** Message: Viewer now connected to the bus
** Message: ViewerSetup
** Message: Calling SetWindow
** Message: NameOwnerChanged old-owner '' new-owner ':1.31'
** Message: Already have owner, why are we notified again?
Viewer: SetWindow XID 50337219 size 912:513
TotemEmbedded-Message: Viewer state: STOPPED
** Message: SetWindow reply
** Message: ViewerReady
** Message: IsSchemeSupported scheme 'http': yes
TotemEmbedded-Message: totem_embedded_open_stream called: uri http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx, base_uri: http://www.zdf.de/ZDFmediathek/content/499580?inPopup=true
TotemEmbedded-Message: totem_embedded_open_internal 'fd://0' is-browser-stream 1 start-play 1
TotemEmbedded-Message: BEFORE _open
TotemEmbedded-Message: AFTER _open (ret: 1)
TotemEmbedded-Message: Viewer state: PLAYING
** Message: OpenStream reply
** Message: NewStream mimetype 'video/x-ms-asf' URL 'http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx'
** Message: Should be dual type 'audio/x-ms-asx', making sure now
** Message: Is dual type 'audio/x-ms-asx'
** Message: Is playlist; need to wait for the file to be downloaded completely
** Message: StreamAsFile filename '/home/martin/.mozilla/firefox/phkgnhdp.default/Cache/53CE4B85d01'
TotemEmbedded-Message: Setting the current playlist to /home/martin/.mozilla/firefox/phkgnhdp.default/Cache/53CE4B85d01 (base: http://www.zdf.de/ZDFmediathek/content/499580?inPopup=true)
** Message: DestroyStream reason 0
** Message: URLNotify URL 'http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx' reason 0
added URI 'rtsp://c36000-ls.w.core.cdn.streamfarm.net/2R38HDlo3/36000zdf/live/3546zdf/encoder.geozdf.geoevent_vh.wmv'
TotemEmbedded-Message: totem_embedded_open_internal 'rtsp://c36000-ls.w.core.cdn.streamfarm.net/2R38HDlo3/36000zdf/live/3546zdf/encoder.geozdf.geoevent_vh.wmv' is-browser-stream 0 start-play 0
TotemEmbedded-Message: BEFORE _open
TotemEmbedded-Message: AFTER _open (ret: 1)
** Message: Error: Konnte nicht in die Ressource schreiben.
gstrtspsrc.c(3772): gst_rtspsrc_setup_streams (): /play/source:
Could not send message. (OK)

TotemEmbedded-Message: Viewer state: STOPPED
TotemEmbedded-Message: totem_embedded_set_error: 'Konnte nicht in die Ressource schreiben.'
TotemEmbedded-Message: totem_embedded_set_error_logo called by browser plugin

Alexander Sack (asac) wrote :

locked audio device? pulseaudio issue?

Changed in totem:
status: Unknown → New
Andreas Moog (ampelbein) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Do you still have that issue? I can at least see the stream saying "Zurzeit kein Livestream".

Changed in totem:
assignee: nobody → andreas-moog
status: New → Incomplete
Download full text (10.8 KiB)

yes... almost the same message... except the firefox version...

** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: NP_Initialize
** Message: NP_Initialize succeeded
** Message: totemPlugin ctor [0x8da5770]
** Message: Init mimetype 'application/x-vlc-plugin' mode 1
** Message: Base URI is '
http://www.zdf.de/ZDFmediathek/content/499580?inPopup=true'
** Message: Real mimetype for 'application/x-vlc-plugin' is
'application/octet-stream'
argv[0] version VideoLAN.VLCPlugin.2
argv[1] progid VideoLAN.VLCPlugin.2
argv[2] type application/x-vlc-plugin
argv[3] id mediaplayer
argv[4] name mediaplayer
argv[5] class vlc
argv[6] autoplay yes
argv[7] loop no
argv[8] target http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx
argv[9] width 100%
argv[10] height 100%
** Message: mSrc: http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx
** Message: mCache: 0
** Message: mControllerHidden: 0
** Message: mShowStatusbar: 0
** Message: mHidden: 0
** Message: mAudioOnly: 0
** Message: mAutostart: 1, mRepeat: 0
** Message: Launching: /usr/lib/totem/gstreamer/totem-plugin-viewer
--plugin-type cone --user-agent Mozilla/5.0 (X11; U; Linux i686; de; rv:
1.9.0.1) Gecko/2008072820 Firefox/3.0.1 --mimetype application/octet-stream
** Message: Viewer spawned, PID 6919
** Message: GetValue variable 14 (e)
** Message: GetValue variable 15 (f)
** Message: Unhandled variable NPPVpluginScriptableNPObject
** Message: GetValue variable 11 (b)
** Message: GetValue variable 268435466 (1000000a)
** Message: GetScriptable [0x8da5770]
** Message: totemConePlugin ctor [0x8ff7990]
** Message: GetValue variable 15 (f)
** Message: Unhandled variable NPPVpluginScriptableNPObject
** Message: GetValue variable 11 (b)
** Message: GetValue variable 268435466 (1000000a)
** Message: GetScriptable [0x8da5770]
** Message: NOTE: Site uses function 'totemIConeInput::GetState'
** Message: Initial window set, XID 2c00cd9 size 912x513
** Message: No viewer proxy yet, deferring SetWindow
** Message: Viewer DBus interface name is
'org.gnome.totem.PluginViewer_6919'
** Message: NameOwnerChanged old-owner '' new-owner ':1.40'
** Message: Viewer now connected to the bus
** Message: ViewerSetup
** Message: Calling SetWindow
** Message: NameOwnerChanged old-owner '' new-owner ':1.40'
** Message: Already have owner, why are we notified again?
Viewer: SetWindow XID 46140633 size 912:513
TotemEmbedded-Message: Viewer state: STOPPED
** Message: SetWindow reply
** Message: ViewerReady
** Message: IsSchemeSupported scheme 'http': yes
TotemEmbedded-Message: totem_embedded_open_stream called: uri
http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx, base_uri:
http://www.zdf.de/ZDFmediathek/content/499580?inPopup=true
TotemEmbedded-Message: totem_embedded_open_internal 'fd://0'
is-browser-stream 1 start-play 1
TotemEmbedde...

Andreas Moog (ampelbein) on 2008-09-10
Changed in totem:
assignee: andreas-moog → desktop-bugs
importance: Undecided → Low
status: Incomplete → Confirmed
Andreas Moog (ampelbein) wrote :

Could you also try with intrepid live-cd?

Changed in totem:
status: Confirmed → Incomplete
martin (maddin-mastert-es) wrote :
Download full text (5.8 KiB)

nope... sorry

On Wed, Sep 10, 2008 at 10:42 AM, Andreas Moog <email address hidden>wrote:

> Could you also try with intrepid live-cd?
>
> ** Changed in: totem (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> Totem Plugin isn't working properly with LiveStream in Firefox RC1
> https://bugs.launchpad.net/bugs/239279
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Totem Movie Player: New
> Status in "totem" source package in Ubuntu: Incomplete
>
> Bug description:
> Ubuntu 8.04, Firefox 3 RC1, Totem Web Browser Plugin 2.22.1, all Add-Ons
> deactivated, Flash Player 10 Beta b218 ...
>
> I tried to watch Live-Stream on "
> http://www.zdf.de/ZDFmediathek/content/499580?inPopup=true", but nothing
> happens. Console shows:
>
> ** Message: GetValue variable 1 (1)
> ** Message: GetValue variable 2 (2)
> ** Message: GetValue variable 1 (1)
> ** Message: GetValue variable 2 (2)
> ** Message: GetValue variable 1 (1)
> ** Message: GetValue variable 2 (2)
> ** Message: GetValue variable 1 (1)
> ** Message: GetValue variable 2 (2)
> ** Message: GetValue variable 1 (1)
> ** Message: GetValue variable 2 (2)
> ** Message: GetValue variable 1 (1)
> ** Message: GetValue variable 2 (2)
> ** Message: NP_Initialize
> ** Message: NP_Initialize succeeded
> ** Message: totemPlugin ctor [0xae826c40]
> ** Message: Init mimetype 'application/x-vlc-plugin' mode 1
> ** Message: Base URI is '
> http://www.zdf.de/ZDFmediathek/content/499580?inPopup=true'
> ** Message: Real mimetype for 'application/x-vlc-plugin' is
> 'application/octet-stream'
> argv[0] version VideoLAN.VLCPlugin.2
> argv[1] progid VideoLAN.VLCPlugin.2
> argv[2] type application/x-vlc-plugin
> argv[3] id mediaplayer
> argv[4] name mediaplayer
> argv[5] class vlc
> argv[6] autoplay yes
> argv[7] loop no
> argv[8] target http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx
> argv[9 <http://wgeostreaming.zdf.de/encoder/livestream15_vh.asxargv%5B9>]
> width 100%
> argv[10] height 100%
> ** Message: mSrc: http://wgeostreaming.zdf.de/encoder/livestream15_vh.asx
> ** Message: mCache: 0
> ** Message: mControllerHidden: 0
> ** Message: mShowStatusbar: 0
> ** Message: mHidden: 0
> ** Message: mAudioOnly: 0
> ** Message: mAutostart: 1, mRepeat: 0
> ** Message: Launching: /usr/lib/totem/gstreamer/totem-plugin-viewer
> --plugin-type cone --user-agent Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9)
> Gecko/2008061015 Firefox/3.0 --mimetype application/octet-stream
> ** Message: Viewer spawned, PID 6134
> ** Message: GetValue variable 14 (e)
> ** Message: GetValue variable 15 (f)
> ** Message: Unhandled variable NPPVpluginScriptableNPObject
> ** Message: GetValue variable 11 (b)
> ** Message: GetValue variable 268435466 (1000000a)
> ** Message: GetScriptable [0xae826c40]
> ** Message: totemConePlugin ctor [0x9940b10]
> ** Message: GetValue variable 15 (f)
> ** Message: Unhandled variable NPPVpluginScriptableNPObject
> ** Message: GetValue variable 11 (b)
> ** Message: GetValue variable 268435466 (1000000a)
> ** Message: GetScriptable [0xae826c40]
> ** Message: NOTE: Site uses function 'totemIConeInput::GetState'
> ** Message: Initial window set, XID 30015c...

Read more...

Changed in totem:
status: Incomplete → Triaged
Changed in totem:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

affects: totem (Ubuntu) → gst-plugins-good0.10 (Ubuntu)
Changed in gst-plugins-good0.10 (Ubuntu):
status: Triaged → Fix Committed
Changed in totem (Ubuntu):
assignee: desktop-bugs → nobody
Sebastien Bacher (seb128) wrote :

the new version is in karmic

Changed in gst-plugins-good0.10 (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.