video thumbnails are not generated for some divx files

Bug #1378397 reported by Ricardo Salveti on 2014-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gst-plugins-bad1.0 (Ubuntu)
High
Unassigned
gst-plugins-base1.0 (Ubuntu)
High
Unassigned
libhybris (Ubuntu)
High
Unassigned

Bug Description

krillin build #187
last known good build: ?
device build: b5e7e45
specific to krillin: Y

Other references:
- bug 1356331

Video thumbnails are not generated on krillin and mediascanner-service-2.0 crashes. It does not happen with all the videos but most of the one I tried and any format.

Test Case:
1. Upload videos from http://www.divx.com/en/devices/profiles/video to the device
2. Go to the video scope and wait

Expected result
Thumbnails appear after a moment

Actual Result
No thumbnail. Connect to the device to watch apport running and a crash file of mediascanner-service-2.0 in /var/crash and mediascanner-service-2.0 using lot of CPU.

Ricardo Salveti (rsalveti) wrote :

From Alfonso Sanchez-Beato (alfonsosanchezbeato):

I finally managed to play these files. Two pieces of information were not being passed to MTK OMX library:

* Some codec specific data that was not being copied by libhybris downwards, although gstreamer was actually providing the data.

* The suggested size for the input buffers is not provided by libhybris/gstreamer, so defaults are taken. It looks like the fact that the video is interleaved implies that bigger than normal input buffers are needed. I made a quick workaround that made a file play, but to solve this properly implies modifications to gstreamer that I am currently analysing. Android takes the input buffer size from the AVI header. From http://msdn.microsoft.com/en-us/library/windows/desktop/dd318180(v=vs.85).aspx :

dwSuggestedBufferSize:
<<
Specifies the suggested buffer size for reading the file. Generally, this size should be large enough to contain the largest chunk in the file. If set to zero, or if it is too small, the playback software will have to reallocate memory during playback, which will reduce performance. For an interleaved file, the buffer size should be large enough to read an entire record, and not just a chunk.
>>

Ricardo Salveti (rsalveti) wrote :

gst-plugins-base part available at https://bugzilla.gnome.org/show_bug.cgi?id=737599

Changed in gst-plugins-bad1.0 (Ubuntu):
status: New → Confirmed
Changed in gst-plugins-base1.0 (Ubuntu):
status: New → Confirmed
Changed in libhybris (Ubuntu):
status: New → Confirmed
Changed in gst-plugins-bad1.0 (Ubuntu):
importance: Undecided → High
Changed in gst-plugins-base1.0 (Ubuntu):
importance: Undecided → High
Changed in libhybris (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libhybris - 0.1.0+git20131207+e452e83-0ubuntu28

---------------
libhybris (0.1.0+git20131207+e452e83-0ubuntu28) utopic; urgency=medium

  [ Alfonso Sanchez-Beato ]
  * media/compat: Add CSD to data for configuring codec (LP: #1378397)

  [ Ricardo Mendoza ]
  * Implement Observer interface for the MediaRecorder class
    (LP: #1362658)
 -- Ricardo Salveti de Araujo <email address hidden> Tue, 14 Oct 2014 22:05:15 -0300

Changed in libhybris (Ubuntu):
status: Confirmed → Fix Released
tags: added: rtm14
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.