Totem hangs while loading a video with .srt (or .txt in MicroDVD format) sub from nautilus

Bug #441396 reported by abujafar on 2009-10-03
494
This bug affects 96 people
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Medium
Release Notes for Ubuntu
Undecided
Unassigned
Totem
Invalid
Undecided
Unassigned
gst-plugins-base0.10 (Ubuntu)
Medium
Ubuntu Desktop Bugs
Karmic
Low
Unassigned

Bug Description

I have just upgraded to karmic beta1.
When the option "automatically load subtitle files when movie is loaded" is
enabled, totem stops responding while loading a video with subtitle file. If
the option is disabled and the subtitle file is specified manually it works.
It seems that this bug shows up only during the program startup from nautilus.

The program doesn't crash, it sticks on loading (the window is unresponsive)
and i have to force quit (kill the application). In this way a crash report is
not produced. I have used "killall -SEGV totem" to trigger apport.

ProblemType: Crash
Architecture: i386
Date: Sat Oct 3 15:44:49 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/totem
Package: libgstreamer0.10-0 0.10.24.3-1
ProcCmdline: totem /home/username/Desktop/test.avi
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SegvAnalysis:
 Segfault happened at: 0x2e3422 <__kernel_vsyscall+2>: ret
 PC (0x002e3422) ok
 Reason could not be automatically determined.
Signal: 11
SourcePackage: gstreamer0.10
StacktraceTop:
 __kernel_vsyscall ()
 __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
 _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
 pthread_mutex_lock ()
 gst_object_get_parent ()
Title: totem crashed with SIGSEGV in __kernel_vsyscall()
Uname: Linux 2.6.31-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare tape

abujafar (abujafar) wrote :
summary: - Totem hangs while loading a video with .srt sub from nautilus crashed
- with SIGSEGV in __kernel_vsyscall()
+ Totem hangs while loading a video with .srt sub from nautilus
abujafar (abujafar) on 2009-10-03
tags: added: totem

StacktraceTop:__kernel_vsyscall ()
__lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
_L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
pthread_mutex_lock ()
gst_object_get_parent ()

Changed in ubuntu:
importance: Undecided → Medium
tags: removed: need-i386-retrace
affects: ubuntu → totem (Ubuntu)
Changed in totem (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Confirmed
visibility: private → public
Changed in totem (Ubuntu):
status: Confirmed → Triaged

i have also the same bug. I try to backtrace it.

Hladen Spricar (hladenspricar) wrote :

Same here.

Ubuntu 9.10 Beta 64bit with all updates applied.

It happens to .txt subs as well! totem 2.28.1

summary: - Totem hangs while loading a video with .srt sub from nautilus
+ Totem hangs while loading a video with .srt (or .txt in MicroDVD format)
+ sub from nautilus
abujafar (abujafar) on 2009-10-18
Changed in gstreamer:
status: New → Confirmed
affects: totem (Ubuntu) → gstreamer0.10 (Ubuntu)
NAQuan (naq2112) wrote :

I think the bug 's only affect some specific subtitle files, I have the same bug but when I try open another movie with same type of subtitle(srt) it seems to be ok. This attachment 's the srt file that has problem opening.

Augusto Santos (mkhaos7) wrote :

For me this happens with every subtitle i tried.
I don't think this is a subtitle issue since loading the subtile once the movie is playing all is fine.

Julien Olivier (julo) wrote :

I also have this bug on Karmic Koala, and what's strange is that loading the subtitles file after the video has already started works perfectly. But if the srt file name matches the video file name, it is loaded automatically and Totem hangs forever.

Xisco Faulí Tarazona (x1sc0) wrote :

The same here. If I set "automatically load subtitle files when movie is loaded" on, it doesn't work. I have tried with .srt subs.

Kevin (kevinshlee) wrote :

Ubuntu Linux 9.10 Karmic Koala RC1 Desktop amd64

I've got the same problem but in my case, if I select the subtitle manually after totem plays the video, it loses the sound. The video is still displayed yet audio's completely gone. The audio is back in about 10 seconds yet the video and audio are not synchronised correctly.

Without subtitle -> fine
Automatic load of subtitle -> totem freezes
Manual load of subtitle after playing video -> no sound -> in 10 sec, audio is back yet out of sync.

By the way, some of the subtitle files I tried are smi files, and the others are srt files.

Regards,
Kevin

vIndEx (vindex) wrote :

same problem here

u-foka (ufooka) wrote :

Hy there!

I've sucking with this since I'm upgraded to karmic around it's beta release...
I can live with that, but I think it's a major problem... think that someone (a new ubuntu user) installs ubuntu, inserts a disc with a movie to watch it....
Ubuntu probably asks the user to install codecs, and after the codec installation the movie never starts :S
Then anyone entitled to say that "Ubuntu/Linux is useless, it can't even play a movie...."

So in my opinion, this issue must be solved somehow until the final release :S

abujafar (abujafar) on 2009-10-28
Changed in gstreamer:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in totem:
importance: Unknown → Undecided
status: Unknown → New
status: New → Confirmed
Changed in ubuntu-release-notes:
status: New → Invalid
abujafar (abujafar) wrote :

Invalid why?

Brian Murray (brian-murray) wrote :

While this is a valid bug and an unfortunate one we do not feel that it is appropriate for the documenting in the Ubuntu release notes.

Everthon Valadão (valadao) wrote :

What an awful bug! I'm using Karmic *final release* and automatic load of subtitle still freezes totem... I must load it manually to avoid this annoying bug :(

Pedro Gauna (lapega) wrote :

I have the same problem, and because I'm uruguayan (spanish language) all my movies have subtitles, so I miss a lot the auto load option....

Please, correct this as soon as you can

Karthanis (antoine-karthanis) wrote :

I'm also affected by this bug.

Disabling subs autoloading works fine, but I can't even load them manually (triggers the bug)

Balazs Scheidler (bazsi) wrote :
Download full text (4.8 KiB)

I can also reproduce the problem, here's a backtrace:

(gdb) bt
#0 0x0011a422 in __kernel_vsyscall ()
#1 0x0014b829 in __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
#2 0x00146f3b in _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
#3 0x00146d51 in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
#4 0x0093a1c3 in gst_object_get_parent (object=0x9592fe0) at gstobject.c:830
#5 0x0093b7d8 in gst_object_dispatch_properties_changed (object=0x9c08060, n_pspecs=1, pspecs=0xbffbc008) at gstobject.c:527
#6 0x002e1daf in g_object_notify_dispatcher (object=0x9c08060, n_pspecs=1, pspecs=0xbffbc008) at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:326
#7 0x002e62db in g_object_notify_queue_thaw (object=0x9c08060, first_property_name=0x414a2ba "subtitle-encoding", var_args=0xbffbc0f8 "(u+\t")
    at /build/buildd/glib2.0-2.22.2/gobject/gobjectnotifyqueue.c:120
#8 IA__g_object_set_valist (object=0x9c08060, first_property_name=0x414a2ba "subtitle-encoding", var_args=0xbffbc0f8 "(u+\t")
    at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:1482
#9 0x002e6446 in IA__g_object_set (_object=0x9c08060, first_property_name=0x414a2ba "subtitle-encoding") at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:1582
#10 0x0413fcce in gst_decode_bin_set_subs_encoding (object=0x945d208, prop_id=2, value=0xbffbc238, pspec=0x999e930) at gstdecodebin2.c:865
#11 gst_decode_bin_set_property (object=0x945d208, prop_id=2, value=0xbffbc238, pspec=0x999e930) at gstdecodebin2.c:898
#12 0x002e5e85 in object_set_property (object=0x945d208, first_property_name=0x414a2ba "subtitle-encoding", var_args=0xbffbc2ac "")
    at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:968
#13 IA__g_object_set_valist (object=0x945d208, first_property_name=0x414a2ba "subtitle-encoding", var_args=0xbffbc2ac "") at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:1476
#14 0x002e6446 in IA__g_object_set (_object=0x945d208, first_property_name=0x414a2ba "subtitle-encoding") at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:1582
#15 0x0414868d in gst_uri_decode_bin_set_encoding (object=0x9598130, prop_id=5, value=0xbffbc3e8, pspec=0x9575550) at gsturidecodebin.c:491
#16 gst_uri_decode_bin_set_property (object=0x9598130, prop_id=5, value=0xbffbc3e8, pspec=0x9575550) at gsturidecodebin.c:522
#17 0x002e5e85 in object_set_property (object=0x9598130, first_property_name=0x2c183d6 "subtitle-encoding", var_args=0xbffbc45c "")
    at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:968
#18 IA__g_object_set_valist (object=0x9598130, first_property_name=0x2c183d6 "subtitle-encoding", var_args=0xbffbc45c "") at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:1476
#19 0x002e6446 in IA__g_object_set (_object=0x9598130, first_property_name=0x2c183d6 "subtitle-encoding") at /build/buildd/glib2.0-2.22.2/gobject/gobject.c:1582
#20 0x02bfda3d in gst_play_bin_set_encoding (object=0x94700a8, prop_id=11, value=0xbffbc598, pspec=0x9448ae8) at gstplaybin2.c:1519
#21 gst_play_bin_set_property (object=0x94700a8, prop_id=11, value=0xbffbc598, pspec=0x9448ae8) at gstplaybin2.c:1574
#22 0x002e5e85 in object_set_property (object=0x94700a8, first_property_name=0x80a92aa "subtitle-encoding", var_args=0xbffb...

Read more...

Geert Jan Alsem (gj-alsem) wrote :

On GNOME Bugzilla there is another duplicate of this bug: https://bugzilla.gnome.org/show_bug.cgi?id=599970

I posted my findings there because I couldn't find any other bug reports at first (I was searching for Totem bugs).

Igor Wojnicki (wojnicki) wrote :

It affects me too! What's even worse, I've just experienced a freez upon loading subtitles manually.
I opened a movie. It played well, added subtitles.... freez... :(

Xavier Lopez (xavierlr) wrote :

I solved this bug purging totem packages and reinstall it again. Try with synaptic package manager to complete removal.

I hope you fix it too. :)

Hy!

tryed that solution but it wont help...

--
Eisenberger Tamás <email address hidden>

On Thu, 2009-11-05 at 08:27 +0000, Xavier Lopez wrote:
> I solved this bug purging totem packages and reinstall it again. Try
> with synaptic package manager to complete removal.
>
> I hope you fix it too. :)
>

picomike (picomike) wrote :

#22 solution doesn't worked for me neither :(

It worked for me.

I've removed each totem pakage and configuration and reinstalled THX!

2009/11/5 picomike <email address hidden>

> #22 solution doesn't worked for me neither :(
>
> --
> Totem hangs while loading a video with .srt (or .txt in MicroDVD format)
> sub from nautilus
> https://bugs.launchpad.net/bugs/441396
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The GStreamer Multimedia Framework: Unknown
> Status in Totem Movie Player: Confirmed
> Status in Ubuntu Release Notes: Invalid
> Status in “gstreamer0.10” package in Ubuntu: Triaged
>
> Bug description:
> I have just upgraded to karmic beta1.
> When the option "automatically load subtitle files when movie is loaded" is
> enabled, totem stops responding while loading a video with subtitle file.
> If
> the option is disabled and the subtitle file is specified manually it
> works.
> It seems that this bug shows up only during the program startup from
> nautilus.
>
> The program doesn't crash, it sticks on loading (the window is
> unresponsive)
> and i have to force quit (kill the application). In this way a crash report
> is
> not produced. I have used "killall -SEGV totem" to trigger apport.
>
> ProblemType: Crash
> Architecture: i386
> Date: Sat Oct 3 15:44:49 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/totem
> Package: libgstreamer0.10-0 0.10.24.3-1
> ProcCmdline: totem /home/username/Desktop/test.avi
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
> SegvAnalysis:
> Segfault happened at: 0x2e3422 <__kernel_vsyscall+2>: ret
> PC (0x002e3422) ok
> Reason could not be automatically determined.
> Signal: 11
> SourcePackage: gstreamer0.10
> StacktraceTop:
> __kernel_vsyscall ()
> __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
> _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
> pthread_mutex_lock ()
> gst_object_get_parent ()
> Title: totem crashed with SIGSEGV in __kernel_vsyscall()
> Uname: Linux 2.6.31-11-generic i686
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare tape
>

--
Andrea Dolcini

cell.: +39 338 8650925
e-mail: <email address hidden>

No sorry!

it worked only 1 time

2009/11/5 Andrea Dolcini <email address hidden>

> It worked for me.
>
> I've removed each totem pakage and configuration and reinstalled THX!
>
> 2009/11/5 picomike <email address hidden>
>
> #22 solution doesn't worked for me neither :(
>>
>> --
>> Totem hangs while loading a video with .srt (or .txt in MicroDVD format)
>> sub from nautilus
>> https://bugs.launchpad.net/bugs/441396
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug.
>>
>> Status in The GStreamer Multimedia Framework: Unknown
>> Status in Totem Movie Player: Confirmed
>> Status in Ubuntu Release Notes: Invalid
>> Status in “gstreamer0.10” package in Ubuntu: Triaged
>>
>> Bug description:
>> I have just upgraded to karmic beta1.
>> When the option "automatically load subtitle files when movie is loaded"
>> is
>> enabled, totem stops responding while loading a video with subtitle file.
>> If
>> the option is disabled and the subtitle file is specified manually it
>> works.
>> It seems that this bug shows up only during the program startup from
>> nautilus.
>>
>> The program doesn't crash, it sticks on loading (the window is
>> unresponsive)
>> and i have to force quit (kill the application). In this way a crash
>> report is
>> not produced. I have used "killall -SEGV totem" to trigger apport.
>>
>> ProblemType: Crash
>> Architecture: i386
>> Date: Sat Oct 3 15:44:49 2009
>> DistroRelease: Ubuntu 9.10
>> ExecutablePath: /usr/bin/totem
>> Package: libgstreamer0.10-0 0.10.24.3-1
>> ProcCmdline: totem /home/username/Desktop/test.avi
>> ProcEnviron:
>> LANG=en_US.UTF-8
>> SHELL=/bin/bash
>> ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
>> SegvAnalysis:
>> Segfault happened at: 0x2e3422 <__kernel_vsyscall+2>: ret
>> PC (0x002e3422) ok
>> Reason could not be automatically determined.
>> Signal: 11
>> SourcePackage: gstreamer0.10
>> StacktraceTop:
>> __kernel_vsyscall ()
>> __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
>> _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
>> pthread_mutex_lock ()
>> gst_object_get_parent ()
>> Title: totem crashed with SIGSEGV in __kernel_vsyscall()
>> Uname: Linux 2.6.31-11-generic i686
>> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare tape
>>
>
>
>
> --
> Andrea Dolcini
>
> cell.: +39 338 8650925
> e-mail: <email address hidden>
>

--
Andrea Dolcini

cell.: +39 338 8650925
e-mail: <email address hidden>

Yes, it works some time but it surely under five percent!

--
Eisenberger Tamás <email address hidden>

On Thu, 2009-11-05 at 19:58 +0000, andrea.dolcini wrote:
> No sorry!
>
> it worked only 1 time
>
> 2009/11/5 Andrea Dolcini <email address hidden>
>
> > It worked for me.
> >
> > I've removed each totem pakage and configuration and reinstalled THX!
> >
> > 2009/11/5 picomike <email address hidden>
> >
> > #22 solution doesn't worked for me neither :(
> >>
> >> --
> >> Totem hangs while loading a video with .srt (or .txt in MicroDVD format)
> >> sub from nautilus
> >> https://bugs.launchpad.net/bugs/441396
> >> You received this bug notification because you are a direct subscriber
> >> of a duplicate bug.
> >>
> >> Status in The GStreamer Multimedia Framework: Unknown
> >> Status in Totem Movie Player: Confirmed
> >> Status in Ubuntu Release Notes: Invalid
> >> Status in “gstreamer0.10” package in Ubuntu: Triaged
> >>
> >> Bug description:
> >> I have just upgraded to karmic beta1.
> >> When the option "automatically load subtitle files when movie is loaded"
> >> is
> >> enabled, totem stops responding while loading a video with subtitle file.
> >> If
> >> the option is disabled and the subtitle file is specified manually it
> >> works.
> >> It seems that this bug shows up only during the program startup from
> >> nautilus.
> >>
> >> The program doesn't crash, it sticks on loading (the window is
> >> unresponsive)
> >> and i have to force quit (kill the application). In this way a crash
> >> report is
> >> not produced. I have used "killall -SEGV totem" to trigger apport.
> >>
> >> ProblemType: Crash
> >> Architecture: i386
> >> Date: Sat Oct 3 15:44:49 2009
> >> DistroRelease: Ubuntu 9.10
> >> ExecutablePath: /usr/bin/totem
> >> Package: libgstreamer0.10-0 0.10.24.3-1
> >> ProcCmdline: totem /home/username/Desktop/test.avi
> >> ProcEnviron:
> >> LANG=en_US.UTF-8
> >> SHELL=/bin/bash
> >> ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
> >> SegvAnalysis:
> >> Segfault happened at: 0x2e3422 <__kernel_vsyscall+2>: ret
> >> PC (0x002e3422) ok
> >> Reason could not be automatically determined.
> >> Signal: 11
> >> SourcePackage: gstreamer0.10
> >> StacktraceTop:
> >> __kernel_vsyscall ()
> >> __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
> >> _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
> >> pthread_mutex_lock ()
> >> gst_object_get_parent ()
> >> Title: totem crashed with SIGSEGV in __kernel_vsyscall()
> >> Uname: Linux 2.6.31-11-generic i686
> >> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare tape
> >>
> >
> >
> >
> > --
> > Andrea Dolcini
> >
> > cell.: +39 338 8650925
> > e-mail: <email address hidden>
> >
>
>
> --
> Andrea Dolcini
>
> cell.: +39 338 8650925
> e-mail: <email address hidden>
>

Jim Walsh 3 (jimwalsh3) wrote :

NOT me.

Complete removal and re-installation of Totem (and related programs like Brasero) did NOT work for me.

abujafar (abujafar) wrote :

Bug has been resolved upstream. Please rebuild an updated package.
Thank you

Changed in gstreamer0.10 (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Confirmed
Changed in totem:
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now and will be backport next week there, there is no need to add extra comments

Changed in gstreamer0.10 (Ubuntu):
status: Confirmed → Fix Committed

Hey guys, you are rights! my solution only works one time! I don' t
understand why

2009/11/6 Sebastien Bacher <email address hidden>

> the bug has been fixed upstream now and will be backport next week
> there, there is no need to add extra comments
>
> ** Changed in: gstreamer0.10 (Ubuntu)
> Status: Confirmed => Fix Committed
>
> --
> Totem hangs while loading a video with .srt (or .txt in MicroDVD format)
> sub from nautilus
> https://bugs.launchpad.net/bugs/441396
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The GStreamer Multimedia Framework: Unknown
> Status in Totem Movie Player: Invalid
> Status in Ubuntu Release Notes: Invalid
> Status in “gstreamer0.10” package in Ubuntu: Fix Committed
>
> Bug description:
> I have just upgraded to karmic beta1.
> When the option "automatically load subtitle files when movie is loaded" is
> enabled, totem stops responding while loading a video with subtitle file.
> If
> the option is disabled and the subtitle file is specified manually it
> works.
> It seems that this bug shows up only during the program startup from
> nautilus.
>
> The program doesn't crash, it sticks on loading (the window is
> unresponsive)
> and i have to force quit (kill the application). In this way a crash report
> is
> not produced. I have used "killall -SEGV totem" to trigger apport.
>
> ProblemType: Crash
> Architecture: i386
> Date: Sat Oct 3 15:44:49 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/totem
> Package: libgstreamer0.10-0 0.10.24.3-1
> ProcCmdline: totem /home/username/Desktop/test.avi
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
> SegvAnalysis:
> Segfault happened at: 0x2e3422 <__kernel_vsyscall+2>: ret
> PC (0x002e3422) ok
> Reason could not be automatically determined.
> Signal: 11
> SourcePackage: gstreamer0.10
> StacktraceTop:
> __kernel_vsyscall ()
> __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
> _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
> pthread_mutex_lock ()
> gst_object_get_parent ()
> Title: totem crashed with SIGSEGV in __kernel_vsyscall()
> Uname: Linux 2.6.31-11-generic i686
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare tape
>

Gonzalo (gonzpk) wrote :

could someone tell me how to update to commit the fix?

abujafar (abujafar) wrote :

you have to wait until an updated package is released (next week)

Gonzalo (gonzpk) wrote :

will it appear on the repos, or should i add some sources?

Łukasz Jeż (lukasz-jez) wrote :

I'm affected as well. I confirm that in my case "It seems that this bug shows up only during the program startup from nautilus." --- I never had a crash when I first run Totem and opened video file afterwards.

Linuxboy (linuxboy) wrote :

I confirm this bug. It is still here. My case is the same of lukasz-jez.

This bug is really annoying.

Gonzalo (gonzpk) wrote :

The update just got in, but no fix? All it's still the same, pls help!!!

Linuxboy (linuxboy) wrote :

I'm sorry for my previous report, about 12 hours ago. I'm wrong, the bug persists also if i run "totem file.avi" from shell.

If I have set the option to load automatically subtitles at movie start, if I want to see a movie which has a subtitle file to load, totem freezes when I start it from nautilus (double click on movie) or from shell (by writing "totem file.avi" in the console).

If I run totem from gnome application menu and then open the movie from totem file menu, subtitles are correctly loaded and movie works. The same happens if I run totem from shell (by writing "totem" into shell) and then open the movie from totem file menu.

Lucio M Nicolosi (lmnicolosi) wrote :

Just updated last Totem and Gstreamer releases (nov/11) from Ubuntu
Proposed Repo (Karmic 64), although still didn't restart. The problem
persists. Totem freezes while opening .avi w/ corresponding .srt file.

--
L M Nicolosi, Eng.
Lat.: 23°34'4.79"S - Long.: 46°39'59.53"W

abujafar (abujafar) wrote :

No packages were released today, what the hell are you talking about?
When a package that fixes this bug is released it will be reported here.

Lucio M Nicolosi (lmnicolosi) wrote :

On Wed, Nov 11, 2009 at 7:41 PM, abujafar <email address hidden> wrote:
> No packages were released today, what the hell are you talking about?
> When a package that fixes this bug is released it will be reported here.

Some Totem and Gstreamer files WERE released today because every
single day I run aptitude update and safe-upgrade and today, Nov/11, a
new set of files were available and downloaded and installed. That's
what I'm talking about. Of course these were not the files I expected
to address the subject although you said a week ago that probably at
this time a new package would be released.

--
L M Nicolosi, Eng.
Lat.: 23°34'4.79"S - Long.: 46°39'59.53"W
Linux Regist. User #481505 - http://counter.li.org/
5E42 E02F E21D 171B EA82 1876 621D 17EB AEBA 4B50

damores (diego-amores) wrote :

Just to clarify, a new version of package gst-plugins-base0.10 (0.10.25-2ubuntu1.1) made it today to the karmic-proposed repository. It does not however contain the upstream patch that fixes this bug, as its purpose is fixing another one (#460535).

So, I guess we will have to wait for the backport in upstream (as stated in comment #30) and then for the SRU process to finish before we can load subtitles automatically in totem.

Lucio M Nicolosi (lmnicolosi) wrote :

On Wed, Nov 11, 2009 at 9:58 PM, damores <email address hidden> wrote:
>
> [] we will have to wait for the backport in upstream and then for the SRU process to finish before we can load subtitles automatically in totem.
>

No need to hurry, this bug is just an inconvenience that can easily be
circumvented. However (and this is OT, sorry) I noticed in my system
(Jaunty & Karmic 64) that Totem is disturbed while playing downloaded
DVD files. Although the first half plays perfectly, the second messes
with the timer, and back and forth commands. Tested VLC with the same
files and it seems to work. Anyone could tell me if this is a bug (I
didn't find) or it's just my system? Thanks.

--
L M Nicolosi, Eng.
Lat.: 23°34'4.79"S - Long.: 46°39'59.53"W
Linux Regist. User #481505 - http://counter.li.org/
5E42 E02F E21D 171B EA82 1876 621D 17EB AEBA 4B50

Pedro Villavicencio (pedro) wrote :

There's no update on Ubuntu containing the fix yet, the status of the report is Fix committed which means that the bug was fixed upstream not here, as soon as the package having the fix is released on Ubuntu the status of the report is going to be "Fix Released" so until you don't see that reflected on the status please do not ask again, it only creates noise for the users subscribed to this report and more bug email to read for the maintainers and triagers, Thanks all.

Fortunato Ventre (voria) wrote :

I've build a new 'gst-plugins-base0.10' package which includes the (adapted) upstream patch.
It's based on version '0.10.25-2ubuntu1' (not the proposed '0.10.25-2ubuntu1.1'), and it's available on my testing PPA:

https://launchpad.net/~voria/+archive/archive

u-foka (ufooka) wrote :

Hy!

Many thanks Fortunato! I've upgaded from your ppa, and now totem work's as expected! :)

Thanks!

Linuxboy (linuxboy) wrote :

Thank you Fortunato, here now Totem works as expected.

Grazie.

THX a lot!
works for me too!

2009/11/13 Linuxboy <email address hidden>

> Thank you Fortunato, here now Totem works as expected.
>
>
> Grazie.
>
> --
> Totem hangs while loading a video with .srt (or .txt in MicroDVD format)
> sub from nautilus
> https://bugs.launchpad.net/bugs/441396
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The GStreamer Multimedia Framework: Unknown
> Status in Totem Movie Player: Invalid
> Status in Ubuntu Release Notes: Invalid
> Status in “gstreamer0.10” package in Ubuntu: Fix Committed
>
> Bug description:
> I have just upgraded to karmic beta1.
> When the option "automatically load subtitle files when movie is loaded" is
> enabled, totem stops responding while loading a video with subtitle file.
> If
> the option is disabled and the subtitle file is specified manually it
> works.
> It seems that this bug shows up only during the program startup from
> nautilus.
>
> The program doesn't crash, it sticks on loading (the window is
> unresponsive)
> and i have to force quit (kill the application). In this way a crash report
> is
> not produced. I have used "killall -SEGV totem" to trigger apport.
>
> ProblemType: Crash
> Architecture: i386
> Date: Sat Oct 3 15:44:49 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/totem
> Package: libgstreamer0.10-0 0.10.24.3-1
> ProcCmdline: totem /home/username/Desktop/test.avi
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
> SegvAnalysis:
> Segfault happened at: 0x2e3422 <__kernel_vsyscall+2>: ret
> PC (0x002e3422) ok
> Reason could not be automatically determined.
> Signal: 11
> SourcePackage: gstreamer0.10
> StacktraceTop:
> __kernel_vsyscall ()
> __lll_lock_wait () from /lib/tls/i686/cmov/libpthread.so.0
> _L_lock_752 () from /lib/tls/i686/cmov/libpthread.so.0
> pthread_mutex_lock ()
> gst_object_get_parent ()
> Title: totem crashed with SIGSEGV in __kernel_vsyscall()
> Uname: Linux 2.6.31-11-generic i686
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare tape
>

--
Andrea Dolcini

cell.: +39 338 8650925
e-mail: <email address hidden>

CharlieAshford (chezzo) wrote :

I'm using totem-xine and have the same issue... Will the update fix totem-xine too?

Pedro Gauna (lapega) wrote :

Thanks Fortunato, I works great!!!

scalawag (scalawag-) wrote :

After almost 2 months and still no OFFICIAL patch released????

Sesivany (jiri-eischmann) wrote :

to #30

27 days has been a pretty long week. I think there is a significant need to add extra comments. I have been using Ubuntu for almost 4 years and I have never seen a more disturbing bug which hasn't been fixed for such a long time! It's not such a big problem for us - powerusers. We always find some workaround. BUT there are thousands of normal users out there and this bug affects many of them. You want to make Linux for people, but you can't rebuild a package with an upstream fix for more than a month...

Linuxboy (linuxboy) wrote :

I apologize for the strong word: shame.

This is only my opinion, I do not mean to offend anyone.

I thank all the Ubuntu developers for giving the world this distribution, but 1 month of waiting for this bug so annoying is not appropriate. That's all, folks.

Once again I thank Fortunato Ventre for having prepared an interim package.

abujafar (abujafar) wrote :

It's not a shame. I think this bug well shows the pros and cons of open-source.

[Cons] Developers are not paid for their work so they feel no hurry to backport and release a bug fix.

[Pro] There is the possibility for random volunteer to grab the code and fix it.

Linuxboy (linuxboy) wrote :

I rather think that after 30 days of waiting for a bug already solved, it would take a few more words of "Pro" and "Cons".

> I apologize for the strong word: shame.

Strong? It's too weak...

Sebastien Bacher (seb128) wrote :

you really think that insulting volunteer because you think they are not working quick enough on your issue for free during their after work hours is likely to motivate them working on the issue? you should rethink about all that before commenting...

Sebastien Bacher (seb128) wrote :

replying to previous comments too, there is no patch attached to this bug and thousand of bugs opened every day if there is a fix which could be used somewhere you might want to consider adding it to the bug and subscribing the sponsors so it gets reviewed too

Yann Papouin (yann-papouin) wrote :

I agree with you Sebastien!

Just in reply to your previous comment, a patch is attached to gnome-bugs #600479. This bug is RESOLVED and FIXED. I don't understand why the bug watcher didn't seen it.

Maybe Fortunato Ventre could attach it's adapted upstream patch.

Fortunato Ventre (voria) wrote :

Here it is.
It applies correctly to the package version '0.10.25-2ubuntu1.1', after all the other patches in 'debian/patches/'.

Linuxboy (linuxboy) wrote :

Sebastian, in message number 30 you have been told that the bug was fixed and an upgrade would be released next week. Has passed one month. Now there is also the patch for the bug attached by Fortunato Ventre. We can now expect an official release of a package in a short time?

Sebastien Bacher (seb128) wrote :

I've been travelling for work and busy with other things, not sure if an update can be excepted soon, depends on who is motivated to be working on this one

Linuxboy (linuxboy) on 2009-12-07
Changed in gstreamer0.10 (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Linuxboy (linuxboy) wrote :

Sorry for wrong click, I've lost the mouse control for a bit.

Sebastian, I remains in my opinion, especially after a reply of this type. If we had done these things in the past, no distribution would never be born. This is my last comment. Good work.

Massimo Mund (qos) wrote :

Just want to know: When there is a fix ... and there seems to be a fix ;) ... why does not somebody just add it and build new packages? I am not that experienced with packaging as maintainers are, but it took me 10 minutes to complete the task.
I don't want to insult somebody, i just want to know where this delay comes from.

I am pretty motivated to build new packages but i guess not everyone may upload new ones ;)

Sebastien Bacher (seb128) wrote :

You can read https://wiki.ubuntu.com/StableReleaseUpdates about stable update and work on the update if you want to give an hand, the frustration for users there is understandable but blaming it on overworked people for not working quick enough is not really of use, the issue there is just that the team working on those package is very small and if anybody is not around for whatever reason things get stucked, anybody is welcome to work on the stable update add a debdiff to the bug with a testcase and subscribe the sponsors if you want to get that update being worked quickly that would be constructive and appreciated by the desktop team and ubuntu users!

Massimo Mund (qos) wrote :

Okay ... i've read the page you mentioned. now i realize what kind of responsibility everyone of you carries.
every package you publish is get by millions of different computers in the world, but that doesn't means that packages which are running fine on your computers do so at every other computer in the world. patches also can cause regessions.
its not that simple just to add a fix.
these fixes CAN cause more trouble than benefit.
everyone should now imaging that updates are applied in general automaticly. imaging what effect it could have to ubuntu if every patch would be added without a certain caution.
thats (and the fact that everyone of you also has a private live) is in this case the reason for the delay.

the other side is ... the patch seems to be really fine.
no regressions ... as it seems ... and many users are waiting for it.
there must be a way between it ... perhaps a voting system for urgency of patches?

Sebastien Bacher (seb128) wrote :

how voting would solve a manpower issue? note also that not everybody watch divx movies, would it be only for legal reasons and not everybody has use of subtitle, I've no local example of movie with subtitle there and never use those, not that I deny it's an issue for some people but it would be easier to work on the update for somebody having access to buggy materials there

Voting isn't necessary, this bug has 10 duplicates (with 23 subscribers) and 49 direct subscribers. I think that is a lot for a little bug. The manpower issue is a endemic problem to the packaging in Linux.

Sebastien, the problem is not only with divx movies also affects other formats. The legality or illegality must decide a judge. In Spain a lot of people use subtitles for tv shows and the autoload of subtitles of totem is a very useful feature.

If you need numbers of users of divx/xvid/h264 codecs in ubuntu:
Installations of totem: 1162459 ( http://popcon.ubuntu.com/main/by_vote )
Installations of gstreamer0.10-ffmpeg: 907482 ( http://popcon.ubuntu.com/universe/by_inst )

I think that the users expect more of a package supported by canonical.

.srt subtitles for "Elephants dream": http://members.chello.nl/j.kassenaar/elephantsdream/subtitles.html

Thanks for your work :)

Amr Hassan (amr-hassan) wrote :

I'm still suffering from this bug!

affects: gstreamer0.10 (Ubuntu) → gst-plugins-base0.10 (Ubuntu)
Changed in gst-plugins-base0.10 (Ubuntu Karmic):
importance: Undecided → Low
status: New → Triaged
Sebastien Bacher (seb128) wrote :

the change has been uploaded now

Changed in gst-plugins-base0.10 (Ubuntu Karmic):
status: Triaged → Fix Committed

Accepted gst-plugins-base0.10 into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Martin Pitt wrote:
> Accepted gst-plugins-base0.10 into karmic-proposed, the package will
> build now and be available in a few hours.
>
> ** Tags added: verification-needed
Tested new package on Karmic 64. It now can open .avi files with
corresponding .srt legend files. Problem seems solved.

--
L M Nicolosi, Eng.

Igor Wojnicki (wojnicki) wrote :

It seems to be working fine for me. However automatic subtitle loading used to work both with .srt and .txt files. Now it works with .srt files only. Is it on purpose? or coincidental regression?

Martin Pitt (pitti) on 2009-12-15
tags: added: verification-done
removed: verification-needed
CoudCoud (coudertmatthieu) wrote :

Seems to work better than on jaunty (when I go forward in a movie, the subtitle seems to resynchronize more quickly). I only tested with a .srt.

Pedro Villavicencio (pedro) wrote :

Igor, That's expected yes, see bug 448900.

Pepehillo (julian-glez) wrote :

It worked for me too. Karmic NBR. Thanks!

For my work fine. Thanks

For my work fine. Thanks

$ dpkg -l | grep gst | grep base
ii gstreamer0.10-plugins-base 0.10.25-2ubuntu1.2 GStreamer plugins from the "base" set
ii gstreamer0.10-plugins-base-apps 0.10.25-2ubuntu1.2 GStreamer helper programs from the "base" se
ii libgstreamer-plugins-base0.10-0 0.10.25-2ubuntu1.2 GStreamer libraries from the "base" set

Kevin (kevinshlee) wrote :

It now works fine on my Ubuntu 9.10 64 bit, yet I still have some weird problem.

If I open a video clip with the subtitle then don't close it and open another one without any subtitle, it displays the following error message.

"Can't play a text file without video."

Of course, if I close the totem and double-click the one without the subtitle, it's perfectly fine.

So, if I open
with subtitle : Fine
without subtitle : Fine
with subtitle -> without subtitle : *** Error ***
with subtitle -> with subtitle : Fine
without subtitle -> with subtitle : Fine
without subtitle -> without subtitle : Fine
without subtitle -> with subtitle -> without subtitle : *** Error ***

It means once I open the one with the subtitle then I can't open the one without the subtitle unless I close the totem then open it again.

I think it's a different bug, isn't it?

Kevin (kevinshlee) wrote :

By the way, I forgot to say thanks for solving this problem.

Thank you all who made an effort to solve it.

Sebastien Bacher (seb128) wrote :

the new comment seems similar to bug #497567

Thanks, Sebastien

I think that is it.

I've just tested and it happens to audio files as well as video files
without the subtitle.

Sebastien Bacher wrote:
> the new comment seems similar to bug #497567
>
>

Guillaume Desmottes (cassidy) wrote :

0.10.25-2ubuntu1.2 solved this issue for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-base0.10 - 0.10.25-2ubuntu1.2

---------------
gst-plugins-base0.10 (0.10.25-2ubuntu1.2) karmic-proposed; urgency=low

  * debian/patches/0008-protect-subtitle-elements.patch:
    - upstream change to fix totem locking when opening videos with subtitle
      thank to Fortunato Ventre and others on the bug (lp: #441396)
 -- Sebastien Bacher <email address hidden> Mon, 14 Dec 2009 18:02:51 +0100

Changed in gst-plugins-base0.10 (Ubuntu Karmic):
status: Fix Committed → Fix Released

i don't fix the bug, but run movie with srt loading automatically in totem ;)
I changed the default output over subtitle edit from opengl and this is ok.
xine works in beauty.

Sergio (sergio-otero) wrote :

Ubuntu's been updated automatically and now Totem+subtiltes works fine

Thanks

Sebastien Bacher (seb128) wrote :

the issue should be fixed in lucid too now, reopen if you still get it there though

Changed in gst-plugins-base0.10 (Ubuntu):
status: Fix Committed → Fix Released
Changed in gstreamer:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.