Ubuntu

gnome-sound-properties freeze

Reported by Piotr Stefanczyk on 2009-03-19
62
This bug affects 5 people
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
High
gst-plugins-base0.10 (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

Description: Ubuntu jaunty (development branch)
Release: 9.04
gnome-control-center 1:2.26.0-0ubuntu1

Few days ago I had installed Ubuntu 9.04 and I have some problem. Sound properties from Gnome menu doesn't work. For a while I see that it tries to run but nothing appears. In System monitor I see process of sound properties.
I attached lspci out.

Piotr Stefanczyk (sashx) wrote :
description: updated
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-control-center (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Piotr Stefanczyk (sashx) wrote :

Added attachment from gdb.

Piotr Stefanczyk (sashx) wrote :
Piotr Stefanczyk (sashx) wrote :
kaij74 (kaij74) wrote :

I can confirm this bug. Gnome-volume-control and old mixer applet doesn't work either. Old mixer applet is often not visible. It also causes gnome panel to freeze sometimes. New gnome-volume-control-applet works fine but it controls pulseaudio.

Same thing with fresh live cd.

kaij74 (kaij74) wrote :
kaij74 (kaij74) wrote :
Changed in gnome-control-center:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

the hang seems to be a gstreamer one the stacktrace has no debug symbols though

kaij74 (kaij74) wrote :

New backtrace with gstreamer debug symbols.

kaij74 (kaij74) wrote :

New strace with gstreamer debug symbols.

kaij74 (kaij74) wrote :

sorry, again, i didn't have all symbols installed.

kaij74 (kaij74) wrote :
Piotr Stefanczyk (sashx) wrote :

That may depends of sound card CA0106. With other sound cards it works fine. I have tried with snd-hda-intel and everything is ok.

kaij74 (kaij74) wrote :

Indeed, tried different sound(Creative) card and it works.

Florian Zeitz (florian-zeitz) wrote :

It also doesn't work on ICE1712.
Possible hint: all those cards don't have a Master volume control (in ALSA) AFAIK.

kaij74 (kaij74) wrote :

Yes CA0106 don't have Master volume control.

Sebastien Bacher (seb128) wrote :

could somebody having access to a such card open the bug on bugzilla.gnome.org?

I have a card using ICE1712 as well as one using Intel HDA in the same machine. Sometimes the window opens, sometimes not, as described in #347793. (I didn't find this bug when searching earlier and submitting that one.)

Can someone who can describe this bug properly submit to Gnome? My own programming skills are really on the wrong layer of abstraction for this. ;)

Pedro Villavicencio (pedro) wrote :

May someone experiencing the issue send this directly to bugzilla.gnome.org where the software authors could read about it? For forwarding instructions please have a look to http://wiki.ubuntu.com/Bugs/Upstream/GNOME ; Thanks in advance.

summary: - gnome-sound-properties freez
+ gnome-sound-properties freeze
Piotr Stefanczyk (sashx) wrote :

Ok. Bug report sent to bugzilla.gnome.org.

Changed in gstreamer:
importance: Undecided → Unknown
status: New → Unknown
Changed in gstreamer0.10 (Ubuntu):
status: Confirmed → Triaged
Changed in gstreamer:
status: Unknown → New
Changed in gstreamer0.10 (Ubuntu):
importance: Low → Medium
milestone: none → ubuntu-9.04
Facundo Batista (facundo) wrote :

I have the same issue. Trying to check which soundcard I have, to report the bug in Gnome as suggested, I found that I can't find it.

Neither lshw or lspic tell me anything about a soundcard (which I have and it's working). Maybe this can help to find the issue?

Sebastien Bacher (seb128) wrote :

there is a possible fix upstream could somebody having the bug try it?

David Potter (ninjaguardsheep) wrote :

How would i go about that?

kaij74 (kaij74) wrote :

That fix work for me atleast.

Peter Rowe (rowe-p-a) wrote :

I have the same problem. Causes gnome-panel to freeze. ICE1712 (Maudio2496) like Florian's.

Sebastien Bacher (seb128) wrote :

thanks for confirming, the change will be in jaunty

affects: gstreamer0.10 (Ubuntu) → gst-plugins-base0.10 (Ubuntu)
Changed in gst-plugins-base0.10 (Ubuntu):
status: Triaged → Fix Committed
Facundo Batista (facundo) wrote :

Sebastien, which fix upstream are you talking about?

I could try it...

Sebastien Bacher (seb128) wrote :

the upstream bug is referenced on this page did you read it? it has the commit listed

I read it. I cant' say that I understand what to do with the "commit". I'm
out of my depth. If it's not too complicated, explain and I'll run with it.

2009/4/3 Sebastien Bacher <email address hidden>

> the upstream bug is referenced on this page did you read it? it has the
> commit listed
>
> --
> gnome-sound-properties freeze
> https://bugs.launchpad.net/bugs/345550
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The GStreamer Multimedia Framework: New
> Status in “gst-plugins-base0.10” source package in Ubuntu: Fix Committed
>
> Bug description:
> Binary package hint: gnome-control-center
>
> Description: Ubuntu jaunty (development branch)
> Release: 9.04
> gnome-control-center 1:2.26.0-0ubuntu1
>
> Few days ago I had installed Ubuntu 9.04 and I have some problem. Sound
> properties from Gnome menu doesn't work. For a while I see that it tries to
> run but nothing appears. In System monitor I see process of sound
> properties.
> I attached lspci out.
>

Sebastien Bacher (seb128) wrote :

there is no need to bother the fix has been confirmed to work just wait to get in jaunty now

Piotr Stefanczyk (sashx) wrote :

When fix will be in repository ?

Sebastien Bacher (seb128) wrote :

tomorrow

Sebastien Bacher (seb128) wrote :

the new revision is in jaunty now

Changed in gst-plugins-base0.10 (Ubuntu):
status: Fix Committed → Fix Released
Peter Rowe (rowe-p-a) wrote :

Sebastien et al.: Thanks so much for sorting this......My panel no longer freezes, and my ICE1712 soundcard (MAudio 2496) just fired up without the need for a custom Pulseaudio config file. Whooppee!!

Confirmation for issue fixed here too. Working with M-Audio Delta 1010 + integrated Intel HDA. :)

Changed in gstreamer:
status: New → Fix Released
Piotr Stefanczyk (sashx) wrote :

It's working fine now.

Changed in gstreamer:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.