Poor DVD playback since Intrepid because of in progress resindvd plugin

Bug #260765 reported by Sebastian Keller on 2008-08-24
54
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gst-plugins-bad
Fix Released
Medium
gst-plugins-bad0.10 (Debian)
Invalid
Undecided
Unassigned
gst-plugins-bad0.10 (Ubuntu)
High
Unassigned
Nominated for Intrepid by Wouter Stomp
Nominated for Jaunty by amano
Nominated for Karmic by amano
gst-plugins-base0.10 (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by Wouter Stomp
Nominated for Jaunty by amano
Nominated for Karmic by amano

Bug Description

In intrepid DVD playback using gstreamer does not work anymore after upgrading gstreamer0.10-plugins-bad_0.10.7-2 to gstreamer0.10-plugins-bad 0.10.8-1.

Totem lists the same entries in the playlist like it did with 0.10.7. It also resizes the window according to the size of the movie, but It only displays a black picture (which might be the first frame of the movie) and it does not play the movie. Totem stays at 0:00/0:14. Also the 14 seconds are clearly wrong. This value is displayed for all videos on the dvd.

Attached is the output of:
GST_DEBUG_NO_COLOR=1 GST_DEBUG="*:3" gst-launch-0.10 playbin uri=dvd:///dev/dvd1 >gst.log 2>&1
(I cut that log file right before pressing ctrl-c after having this run for a few seconds, so the last lines should be where it is frozen)

This displays a black window in the size of the movie, but again nothing is playing.

Since downgrading to 0.10.7 fixes this for me, I tried installing 0.10.8 and removing /usr/lib/gstreamer-0.10/libresindvd.so so the old way of playing dvds would be used again. This made dvd playback work again, so I guess the problem is within resindvd.

Sebastian Keller (skeller) wrote :
Onkar Shinde (onkarshinde) wrote :

Confirmed on latest intrepid installation. I installed intrepid at a friend's place today. I had installed all the getreamer plugins and also libdvdcss2. The problem is that resindvd plugin can not identify or load the dvdspu plugin and complains that adecoder for type 'video/x-dvd-subpicture' is not present. This completely bloks the video playback. I can not play DVD using either totem or with command 'gst-launch-0.10 playbin uri=dvd://'.
But when I rename libresindvd.so to libresindvd.so.bak, totem can at least play the DVD even if it is without menu.

Please mark this bug with at least medium priority as it is a regression.

Changed in gst-plugins-bad0.10:
status: New → Confirmed
Changed in gst-plugins-bad:
status: Unknown → New
nullack (nullack) wrote :

According to upstream we need "gst-plugins-base needs to be CVS to get playbin to autoplug the subpicture overlay correctly" which was stated on 07/08/08. Looking at the package for Intrepid gst-plugins-base0.10 (0.10.20-1) was last changed on Wed, 18 Jun 2008.

Onkar Shinde (onkarshinde) wrote :

I have tried to backport the fix from upstream CVS. Can anyone try installing gstreamer0.10-plugins-base from my PPA (https://edge.launchpad.net/~onkarshinde/+archive)?

When I tried it once on my it didn't take me past first menu. But the machine is down now and I can not do any more testing/debugging.

Sebastian Keller (skeller) wrote :

Thanks for backporting and packaging.
Using your package I am able to start the movie from the dvd-menu, however once the movie is playing I can't seek (which is afaik a limitation of resindvd, which is currently being worked on in CVS) nor can I go back to the menu using the "go to"-menu of totem (might be a related problem). So until the seeking regression gets fixed it might be better to exclude resindvd from the plugins-bad package.

Onkar Shinde (onkarshinde) wrote :

@Sebastian,

Thanks for testing. I think this is improvement over not able to play DVD at all.
The second problem you mentioned about seeking was fixed in resindvd in CVS just two days ago. I will probably backport that fix too.
Regarding totem's problem, It is quite possible that since the DVD playback has landed recently in gstreamer, totem may not have many features implemented in its gstreamer backend for DVD playback.

I will attach a debdiff today to this bug so that it hopefully gets through before beta.

Onkar Shinde (onkarshinde) wrote :

Please find attached debdiff. I have removed the diff for generated debian/control file as on my machine the generated architecture list contains i686 which is not valid arch according to lintian.

nullack (nullack) wrote :

Onkar thankyou for the debiff. That's some great stuff. My view is this, we need to have:

* CVS builds of gstreamer base
* CVS builds of resindvd

As Sebastien noted, not having both results in too many regressions.

Onkar Shinde (onkarshinde) wrote :

@nullack,

I don't think CVS builds of complete plugin package are acceptable at this stage. I will try to backport the resindvd fix also tonight and provide a package in my PPA.

Since the CD images for beta are already built the base plugins change can not be adopted immediately. It will go in only after beta is out.

Onkar Shinde (onkarshinde) wrote :

nullack, Sebastian,

I have tried to backport the seek fix to resindvd from upstream CVS. The package gstreamer0.10-plugins-bad is available in my PPA. Please test and report back.

Brian Murray (brian-murray) wrote :

I'm able to confirm that DVD playback is stuck at a black picture when using the plugins from Intrepid. Additionally, the workaround of moving libresindvd.so works for me. I also tested Onkar's PPA versions of the plugins and I was able to watch the DVD.

I'm not certain what exact functionality resindvd is supposed to provide, but I was not able to navigate past the "ads" at the beginning of the DVD. After watching all of them I ended up at the DVD menu.

Changed in gst-plugins-base0.10:
importance: Undecided → Medium
milestone: none → ubuntu-8.10
Onkar Shinde (onkarshinde) wrote :

@Brian,

resindvd is supposed to provide DVD menu navigation support, title and chapter seek. Can you test if DVD menu works for you?

amano (jyaku) wrote :

This should be worked on with the highest priority. Without getting this fixed, Ubuntu would miss any DVD functionality at a time where GNOME marketing praises the much improved DVD support in GNOME 2.24. We would have to rely to QT programs like VLC to get any playback.

Thanks to Onkar Shinde for providing a fix for this poor situation. Get this into Ubuntu as fast as possible.

nullack (nullack) wrote :

Onkar I'm sorry to report problems with all DVDs I tried using your PPA. With the R4 title "The Core" resindvd fails to see user input regarding which language to display at the DVD menu prompt with a list of languages. Since user input is required to progress in the DVD menu sequence no playback occurs.

On the R4 title "We Were Soldiers" the DVD starts to playback with the copyright notice but then fails with "an error occured failed to connect to stream : OK". Clearly it is bugged with determing dvd menu sequences correctly.

On the R4 title "Ratatouille" the DVD drive seeks, no playback occurs and totem freezes requiring the user to force quit.

Its clear to me that the idea of using the released resindvd in the bad gstreamer plugins will result in a poor user experience. Resindvd was put into the bad plugin set for specific reasons and I think an argument could be fairly made that is was not ready to be considered for release into the bad plugins set at all. If Ubuntu will not consider looking at a CVS compile for where resindvd is up to now, then I recommend what I see as the only real choice available : revert back to not using resindvd with dvdnav / dvdread from the setup that Hardy used.

The setup from Hardy was not always correct, but atleast most of the time it was able to playback main DVD titles without menus. This sometimes caused problems, such as with the R4 title "Star Wars IV A New Hope" where it would select the wrong dvd stream to playback as the main title in the dvd sequence. This however did not occur very often on the DVDs I tried with Hardy's setup.

Onkar Shinde (onkarshinde) wrote :

@nullack,

The error "an error occured failed to connect to stream" is not something related to DVD playing in my opinion. I am seeing similar error on my machine with any media file when the sound output being used is pulseaudio. After I see error totem just hangs on all subsequent media plying attempts. For now I am using ALSA as output plugin. You can set it from System -> Preferences -> Sound.
See if that solved your problem.

Onkar Shinde wrote:
> @nullack,
>
> The error "an error occured failed to connect to stream" is not something related to DVD playing in my opinion. I am seeing similar error on my machine with any media file when the sound output being used is pulseaudio. After I see error totem just hangs on all subsequent media plying attempts. For now I am using ALSA as output plugin. You can set it from System -> Preferences -> Sound.
> See if that solved your problem.
>

or just:

$ pulseaudio -k

https://bugs.launchpad.net/bugs/274124

Changed in gst-plugins-bad0.10:
status: New → Confirmed

Following the updates that came through today by slomo (thanks btw), such as the new gstreamer base revision, I gave another dvd title a test. I tried the R4 title "Reign of Fire" and it failed to playback by presenting an error dialogue about playlist errors not being parsed. I tried again "The Core" and get the same error about parsing playlists.

I'd like to briefly comment on testing dvd menus too. No open source project has been licenced by the copyright holders to provide dvd menu playback. What this means is that the hackers who have reverse engineered dvd menu support in open source projects have done so without being issued the specifications. DVDs have a vast range of different functionality that the specifications cover - some of it is not intuitively obvious or trivial. When it comes to testing its important to try many differently authored DVD menus as they typically use different features out of the spec. If a tester reports "it works for me" we should not rush ahead with this - we need to have caution and a wider test coverage to more widely understand the robustness.

Sebastien Bacher (seb128) wrote :

the new version has been synced on debian today

Changed in gst-plugins-base0.10:
status: Confirmed → Fix Released
nullack (nullack) wrote :

Sebastien this isnt fixed. Since getting the updates my test system provides the following error dialogue when trying to playback the R4 title "The Core" - a dvd subpicture decoder plugin is required to play this stream, but not installed." The strange thing is I have the good, bad, ugly, dirac, ffmpeg etcetc gstreamer plugins.

If I close that error and restart totem fresh, I get a different error that I got before about not being able to parse the playlists.

shockawe5 (shockawe5) wrote :

This is also not fixed for me. I just did the latest updates. Totem is exhibiting the same behavior as it did before the updates.

Sebastien Bacher (seb128) wrote :

how did you install the update before it built? the new gstreamer had build issues and still has on i386 so the new versions are not yet available in intrepid

nullack (nullack) wrote :

Sebastien I can assure you that gstreamer packages were downloaded and installed onto my AMD64 test system following your comments. If you supply the name of the configuration item in question I can look through the package install log to advise you of the date and time it was installed.

Perhaps it would be easier if devs were specific about which configuration items have new revisions with the fixes, so test results can be more accurately related to them. Just as a suggestion mate :)

Anyway since other updates came along Ive since given this another round of testing. Generally there is improvement but there is a bunch of regressions. I have not concluded my testing but to provide initial problems:

1. The user experience has a serious blocker for DVD titles where the DVD menu sequence has a language selection menu item before the main menu. This means the user gets stuck on that screen with no apparent way to go forward. Later on gstreamer provides a UI with focus on clickable fields but this does not seem to occur before the main menu for language selection screens. This is a major issue for my native Region 4 DVD collection as this region typically has these types of menus in many different titles.

2. Trying another test with a dvd title that doesnt have language selection before the main menu, when I select to play the DVD I am not able to seek at all through the footage.

3. In a similar way when playing back the movie there is no response from Totem when a user selects to go back to the main dvd menu.

Have you conducted any unit tests on the SVN version of resindvd? Given resindvd is modular in nature and with what appears to me as a number of regressions in the so called released "bad plugin set" version theres an argument that the SVN version might actually have less harm that the "bad released" version. I dont think this point of view should be dismissed out of hand just because Intrepid is in beta - IMHO this specific situation is a bit unique. I also fully expect my ongoing testing in this area to reveal more problems.

Sebastien Bacher (seb128) wrote :

I no didn't do any testing on this bug and I'm too busy to look at those dvd bugs, I just cleaned the sponsoring request which was open to backport svn change since a new version having this issue has been uploaded to intrepid, I will let you guys try and reopen the bug if that svn change was not enough to fix the issue

Sebastien Bacher (seb128) wrote :

the corresponding version is gstreamer0.10-plugins-base 0.10.21-1

Brian Murray (brian-murray) wrote :

I've briefly tested the new version of gstreamer0.10-plugins-base and noticed the following:

Inserting a DVD and choosing to play it starts playing the main title

Right clicking on the DVD and choosing open with movie player starts playing the main title

Going to Movie -> Play disc in Totem fails with multiple "Playlist error" messages

nullack (nullack) wrote :

Some additional problems to the list:

4. Subtitle functionality is broken - subtitles do not appear when a user selects them in the totem menu and also the list of available subtitles the dvd supports is not correctly identified.

5. Audio functionality is broken - audio tracks are not changed when a user selects them in the totem menu and also the list of available audio tracks the dvd supports is not correctly identified.

6. Multi angle DVDs fail to be dected and totem fails to switch angles when a user attempts too.

I suspect there is a problem when resindvd has to switch between DD 5.1 and a stereo audi stream, where I think it results in stopping playback and giving a stream error dialogue window. Im still testing and diagnosing this issue.

On issue 2 I reported earlier, I can confirm that all methods of seeking via chapters, via dragging the seek bar or via selecting a new section of the seek bar are broken.

Overall, resindvd in the last bad plugins gstreamer release has a very poor dvd user experience.

With all updates installed, I tried 6 random dvd's: with two I directly got stuck at the language selection menu, three gave a 'failed to connect stream error' and one actually played, but didn't allow seeking through the track or going back to the menu.

shockawe5 (shockawe5) wrote :

Just did the latest round of updates. I tried "The Matrix" and "Transformers" and both displayed the main menu, ad I could browse through the menus and turn subtitles on and chapter selection, but once the main title started playing, I could not seek through the movie or use the menu items to return to the main menu.

Onkar Shinde (onkarshinde) wrote :

Hi all,

It looks like the support for DVD menu's using resindvd plugin has landed only two days ago in totem svn. I will try to backport it too and provide packages in my PPA.

Onkar Shinde (onkarshinde) wrote :

I was wrong, totem now only used resindvd instead of dvdreadsrc. There doesn't seem to be any actual seek support from totem's menus.

By the way, all those who are testing menu and seek support please make sure that you get gstreamer-plugins-bad0.10 from my PPA.

Onkar Shinde (onkarshinde) wrote :

Some update. I have updated the gstreamer0.10-plugins-bad package to reflect latest state of resindvd in upstream CVS. I have also backported the change from totem svn to use resindvd. Both packages can be found in my PPA.

Onkar, I tried the same 6 dvd's with your packages, but got the same result as before + a totem crash while trying to seek through the one dvd that actually played.

Onkar Shinde (onkarshinde) wrote :

Wouter,

Can you please try using totem form official repositories and gstreamer0.10-plugins-bad from my PPA? I just want to know if it is the patch I backported form totem SVN that is causing problem.

zombiepig (nyall-zombiepigs) wrote :

Onkar, I installed *only* the gstreamer-plugins-bad from your ppa (wasn't sure if i was supposed to do base or sdl, so I only installed the plugins-bad deb).

Using stock intrepid totem, dvd playback works "ok" for me, on a few titles I've tested it on.

What works:
- Seeking forward, sometimes. Seems to work better on short chapters (< 1 min). Doesn't always seek to the position I set it to, it will often jump back the a point between the current time and the desired time. It also confuses totem a little, if I seek I see the time in the status bar reporting the wrong position (ie, 1:20 / 1:00)
- Menu selection using mouse
- Menu highlighting works correctly most of the time

What doesn't:
- Seeking backwards (seems to skip forward)
- Menu selection using keyboard (tries to seek instead)
- Skip forward/backwards button
- The options in the "go" menu (dvd menu, title menu, etc)

Generally, it's a big improvement -- it feels SO close to proper dvd playback! :D

nullack (nullack) on 2008-10-17
Changed in gst-plugins-bad0.10:
importance: Undecided → High
milestone: none → ubuntu-8.10
status: Confirmed → Triaged
nullack (nullack) wrote :

Onkar, I have used your PPA as per:

nullack@PPP:~$ sudo apt-cache policy gstreamer0.10-plugins-bad
gstreamer0.10-plugins-bad:
  Installed: 0.10.8-1ubuntu1~ppa2
  Candidate: 0.10.8-1ubuntu1~ppa2

With re-testing the previously reported issues:

1. This major issue breaks about half of my DVD collection and still exists in this SVN build of resindvd. Please note, it does not exist with Hardy as resindvd was not used.

2. Seeking is still broken.

3. Trying to go back to menu during title playback is still broken.

4. Subtitle functionality is still broken.

5. Audio functionality is still broken.

6. Multi angle DVDs are still broken.

Onkar, Im thankful for the work youve done with this and Im sure that when upstream is in a better state you will be able to help deliver a great DVD experience on Ubuntu with gstreamer. The problem is the changes with totem using resindvd for a production release version thats very shortly to be released is that the whole experience with gstreamer for DVD playback is much more worse than what it was under Hardy.

I dont see how any responsible decision can be made to go with resindvd playback for Intrepid. To me the only realistic path is to regress back to a Hardy like configuration that did not use resindvd.

Onkar Shinde (onkarshinde) wrote :

A note for all. The packages in my PPA are not relevant anymore as same changes are available in the package in repository. Please do whatever testing you are doing with official packages. If it is observed that the state of DVD playback is still worse than how it was in hardy then we can ask developers to disable resindvd plugin.

I can't get DVD Playback to work at all on 8.10 64-Bit. I tried the trick of renaming "libresindvd.so" to "BACKUP-libresindvd.so" and that did not solve the problem at all. Totem just displays a black screen. If I run from the command line, I get various errors such as:

libdvdread: Invalid IFO for VMGM (VIDEO_TS.IFO).
libdvdread: Invalid IFO for VMGM (VIDEO_TS.BUP).

(totem:9029): GStreamer-CRITICAL **:
Trying to dispose element test_dvdsrc, but it is not in the NULL state.
You need to explicitly set elements to the NULL state before
dropping the final reference, to allow them to clean up.

Sebastien Bacher (seb128) wrote :

the new version is in intrepid no sponsoring is required

amano (jyaku) wrote :

What are the developers' feelings here? Is DVD playback really better than with Hardy now? Is disabling the resindvd plugin a possible solution? Or rather backporting any resindvd fixes if they become available?

Just leaving it in the current state doesn't seem like a good idea to me.

Intrepid Install on Acer aspire 5315 latest gstreamer

** Message: Error: Could not read from resource.
dvdreadsrc.c(935): gst_dvd_read_src_create (): /GstPlayBin:play/GstDvdReadSrc:source

gershee (gershee) wrote :

renamed the libresindvd.so as described above and now am able to play DVD but video flickers with totem using both gstreamer and xine

gershee (gershee) wrote :

Resetting visual effects to none removes flicker from both Totem-gstreamer and Totem-xine. Totem-xine plays DVD with resindvd.so present, but Totem-gstreamer does not. As others have stated Totem worked well with Hardy.

gershee (gershee) wrote :

Disabling ATI driver (Raytheon 1200) does not remove flicker.

Sebastian Keller (skeller) wrote :

It seems like the updated gst-plugins-bad package depends on libcelt >= 0.4.0 while the current libcelt in the repo is 0.3.2, so it did not get built.

Gershee, the flicker-bug is a different bug which has nothing to do with this bug report. Also resindvd does not affect totem-xine because it does not use the gstreamer backend.

Chris Halse Rogers (raof) wrote :

Removing ubuntu-universe-sponsors from this bug; there's nothing to be sponsored here at this point.

Changed in gst-plugins-bad0.10:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Emilio Pozuelo Monfort (pochu) wrote :

I've tried a couple of dvds in hardy, intrepid and jaunty, and both failed in hardy and intrepid (they didn't start to play at all), but they started to play on jaunty (although if I try to seek they fail)

So although this is an important issue, it doesn't seem to be a regression from Hardy, at least not for me with the titles I tried.

Emilio Pozuelo Monfort (pochu) wrote :

I forgot to say that I tried building gst-plugins-bad from Jaunty / Debian experimental and it didn't help.

Steve Beattie (sbeattie) wrote :

This bug was reported in the Intrepid development cycle; removing regression-potential and marking as regression-release.

Changed in gst-plugins-bad:
status: New → Fix Released

I don't know if it is related, but on my friend's PC (8.10 32bit) DVD playback doesn't work not only in Totem, but also in Mplayer and VLC. On my laptop Totem doesn't work too (64-bit, libdvdcss2 and w64codecs installed).

Przemek K. (azrael) wrote :

Here's the output from console when running Totem and playing DVD.

Przemek K. (azrael) wrote :

Similar file for Mplayer

Przemek K. (azrael) wrote :

...and for VLC

Sebastian Keller (skeller) wrote :

No that problem is not related.
Seems like the xv-area that is being allocated is too big for your graphics-card/driver and so it fails. This only happens for DVDs because they have a higher resolution than other videos -> bigger area for xv to allocate. Maybe you can tweak some driver options in your xorg.conf or try different output methods (x11 directly or opengl; you can use gstreamer-properties to change these for totem).

HNT (henry-nicolas) wrote :

I would like to point out that gst-plugins-bad 0.10.9 is available. Release notes available at [0]
As you can see in the notes, DVD playback have been improved and if you look at the notes of 0.10.8, you can see
that resin-dvd was in an experimental state at this release.
There already is a package for gst-plugins-bad 0.10.9 in the ppa of Alessandro Decina [1] with also libcelt0.4.
That version is supposed to fix a lot of thinks and when I tested it, it used to work.
So I think that backporting that 2 packages (gst-plugins-bad & libcelt) is the best solution.

[0] http://gstreamer.freedesktop.org/releases/gst-plugins-bad/0.10.9.html
[1] https://launchpad.net/~alessandro.decina/+archive

Lex Ross (lross) wrote :

When loading DVD I can see DVD menu but menu items do not work. So I cannot play the movie or choose any of the DVD menu options. This is happening only for DVDs with menu designed as static picture. I am running up-to-date Ubuntu 8.10 with totem version 2.24.3-0ubuntu1.

Lex Ross: You may want to try new gstreamer-plugins-bad from the PPA archive quoted in the previous comment, else you can wait for Jaunty. Things are likely to have much changed since Intrepid was released.

HNT (henry-nicolas) wrote :

Hi,

Is it possible to make an update for that package ?
The result is that DVD playback is broken by default (as the codec finder will select gstreamer codecs, dvd playback won't work) and we should just backport 2 simple packages (gstreamer0.10-plugin-bad and libcelt0) to make it work again !

So please, make an SRU.

PS : There are no reverse dependencies for those package, so you won't break any other packages by uploading new versions.

Davias (davias) wrote :

I'm astonished... I've upgrade from 7.10 to 8.10 for not having DVD support.
I've an amd64 and a an HP pavillion in 32 bit version, both fail with DVD on 8.10
My mythbuntu 8.10 box 32 bit works wonder with any DVD...

So, what do we do know?
TIA

Sebastian Keller (skeller) wrote :

Mythbuntu works, because it does not use a gstreamer based player, Ubuntu however uses totem, which by default uses gstreamer.

Davias: with latest updates, DVD playback works quite well with some DVDs. Are you sure you don't suffer from bug 219062? Else you can still use VLC.

HNT: A SRU or a backport would really be a good idea IMHO, you should file a new report against gstreamer-plugins-bad for that - here nothing will be done.

Davias (davias) wrote :

OK, Milan, you are the man. I did:
sudo gedit /usr/share/doc/libdvdread3/install-css.sh for my i386 notebook and mod. the script for my amd64 as suggested: In the line available="i386" replace it with available="ia64" then re-run the script.

it works as it should on both (a bit slow on the notebook, I will investigate) - still the problem remain.

We had a nice info in the packet manager saying that DVD DeCSS was not installed by default becouse blablabla and now, in the latest Ubuntu we just have an error?

This is a serious drawback that will scare many first timer away; I'm not a first timer and, given for granted that DVD support was installed and working on the previous release, I had to research the net for answer and waste several hours.

This MUST be corrected in the reps! Ubuntu team please take note.

Thank you for your precious help

amano (jyaku) wrote :

http://gstreamer.freedesktop.org/releases/gst-plugins-bad/0.10.11.html

A new stable release of the bad plugins is out. Hopefully this will improve the messy Ubuntu DVD situation.

Some things which Ubuntu still lacks are really weird. No (really) working DVD playback out of the box (you have to switch the backend for totem or install other -partly- QT players), no way to display a .ttf file out of the box, no way to view animated gif files with the default image program...

nullack (nullack) wrote :

Resindvd as found in the bad plugins set is missing important features of DVD navigation and is not robust. This is why the project is in the bad plugins set and not the good plugins set.

The intent of the original bug was that DVD's would not play at all but in the progress of the Intrepid development cycle that particular problem was fixed.

I am unsure if it is worth having this bug report open for an upstream project that is known to be incomplete and unstable - in particular given its not installed by default and also that upstream development seems to be occurring at a glacial pace.

amano if you look at the release notes for that release you will see that resindvd changes are not mentioned.

The only question is: would a SRU be worth the pain or not. If nobody intends to do it, then let's close the bug, and wait for Jaunty. But even if ResinDVD is not stable and not installed by default, we must admit it's a central part of the desktop and it should be taken in to account.

Sebastian Keller (skeller) wrote :

This is not about a SRU for gst-plugins-bad since a newer version of this package which was iirc supposed to fix most of the bugs got uploaded in time for intrepid [1], however it did never build correctly because it depended on a newer version of libcelt which was and still is not in the repo. So either there would have to be a SRU for libcelt or the gst-plugins-bad package needs to be changed to not depend on it (if there is a configure option to disable that or by patching the source so the code of the celt-plugin matches the previous version that worked with the older libcelt). As I don't think that many packages depend on celt/libcelt (it is only jackd and gst-plugins-bad on jaunty) I guess backporting the jaunty version of it should be the easiest solution - since disabling celt in gst-plugins-bad might result in other bugs.

[1] https://launchpad.net/ubuntu/+source/gst-plugins-bad0.10/0.10.8.2-1/+build/738567

amano (jyaku) wrote :

http://noraisin.net/~jan/diary/?p=90

Maybe some of Jan Schmitdt's recent fixes to Totem, gst-plugins-base and gst-plugins-bad could be backported. They fix multiangle support and playback in playbin2 and ABOVE all would hook up the DVD menu items in the totem UI.

There is not too much to break and regress in terms of DVD support, thus that could make the dvd experience more acceptable.

Onkar Shinde (onkarshinde) wrote :

@amanio

Have you actually checked if they can be backported to intrepid? If yes, then please file a separate bug.

amano (jyaku) wrote :

No, I am not able to backport patches, thus I cannot judge whether that is feasible. I guess, it should though.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-bad0.10 - 0.10.11-2ubuntu1

---------------
gst-plugins-bad0.10 (0.10.11-2ubuntu1) jaunty; urgency=low

  * Merge from debian unstable(LP: #144254, #260765, #322716)
    remaining change:
    - debian/patches/03_fix_ftbfs_with_latest_libcelt.patch:
      Patch to fix FTBFS with latest libcelt in Ubuntu.

 -- Didier Roche <email address hidden> Wed, 08 Apr 2009 18:21:10 +0200

Changed in gst-plugins-bad0.10 (Ubuntu):
status: Triaged → Fix Released
nullack (nullack) wrote :

Moving back to confirmed as this bug is not fixed. While the bad plugin changes have improved things, users are still without working DVD navigation because totem itself has also not been updated for functionality like going back to the menu, going back to chapters etcetc. Currently the user has to adopt a bad workaround of stopping playback all together, closing totem and re-opening totem to re-access the menu and other dvd navigation items.

Changed in gst-plugins-bad0.10 (Ubuntu):
status: Fix Released → Confirmed
Changed in gst-plugins-base0.10 (Ubuntu):
status: Fix Released → Confirmed
Onkar Shinde (onkarshinde) wrote :

@nullack,

This bug was not about broken DVD navigation with totem-gstreamer. It was about DVD playback being broken completely with resindvd.

For DVD navigation there has been some work done upstream which needs to be ported to gstreamer0.10-plugins-base, gstreamer0.10-plugins-bad and totem.

Upstream has just released further fixes to the DVD playback plugin. See http://gstreamer.freedesktop.org/releases/gst-plugins-bad/0.10.12.html. A more detailed status explanation can be found here:
http://gstreamer.freedesktop.org/wiki/DvdPlayback

All these improvements should be in Karmic, and we may be able to close this bug then... at last.

summary: - DVD playback broken in Intrepid because of resindvd
+ Poor DVD playback since Intrepid because of in progress resindvd plugin
amano (jyaku) wrote :

For Karmic the Xine backend was killed from Totem. Thus people HAVE to rely to the GSTREAMER backend and thus resindvd, which has improved for the last gstreamer-bad releases. Today GStreamer Good 0.10.16 & Bad 0.10.14 stable releases have been released: http://gstreamer.freedesktop.org/news/#2009-08-29T20:00:00Z

Gstreamer-bad 0.10.14 should be shipped in the repos because it fixes further DVD playback bugs:

*588638 : [katedec] add x-dvd-subpicture output
*593063 : resindvd and rawparse do not use correct base LDFLAGS

Didier Roche (didrocks) wrote :

Fixed since 0.10.9

Changed in gst-plugins-bad0.10 (Ubuntu):
status: Confirmed → Fix Released
Changed in gst-plugins-bad:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.