FAAC is missing, libgstfaac.so is not present in any package

Bug #1299376 reported by David Klasinc on 2014-03-29
60
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gst-plugins-bad1.0 (Ubuntu)
Undecided
Unassigned

Bug Description

When gstreamer-plugins-bad is built, libgstfaac.so is omitted from every package. I tried to build the package manually and it didn't help. The library itself is compiled and built, but it is not included in any of the resulting debian packages.

In previous version of GStreamer libgstfaac.so was present in gstreamer0.10-plugins-bad-multiverse.

Every software that will try to use FAAC in gstreamer 1.0 will not work. :(

David Klasinc (bigwhale) wrote :

Some additional info:

After installing all the .deb pakages built there's /usr/lib/x86_64-linux-gnu/gstreamer-1.0/libgstfaad.so, I just copied libgstfaac into the same directory and gst-inspect1.0 faac works as intended.

This clearly seems to be only a packaging problem.

I'm not sure, but it may be excluded on purpose, since gstreaemr-libav has its own aac encoder:

libav: avenc_aac: libav AAC (Advanced Audio Coding) encoder

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gst-plugins-bad1.0 (Ubuntu):
status: New → Confirmed
moma (osmoma) wrote :

Hello,
I noticed this bug when re-compiling audio-recorder for Ubuntu 14.10.
Ref: http://bazaar.launchpad.net/~osmoma/audio-recorder/trunk/view/head:/src/media-profiles.c

I also tried the avenc_aac from the "gstreamer1.0-libav" package but the recorded file content (test.aac) got bad.

gst-launch-1.0 -e pulsesrc ! queue ! audioconvert ! audioresample ! avenc_aac compliance=-2 ! filesink location=test.aac

It records, but file content is bad. Maybe it needs other parameters?

moma (osmoma) wrote :

Adding an avmux_* after encoder might make the pipeline work.
Obrigado.

moma (osmoma) wrote :

Sorry for spamming you with this, but I want to make the pipeline right.

The pipeline works fine with avenc_aac and avmux_mp4 (or ex. avmux_mov) :

$ gst-launch-1.0 -e pulsesrc device="alsa_output.pci-0000_00_1b.0.analog-stereo.monitor" ! queue ! audioconvert ! audioresample ! avenc_aac compliance=-2 ! avmux_mp4 ! filesink location=test.mp4

Also the default input-device was by default set to this laptop's internal microphone (and was impossible to change in sound settings), therefore I use the device="xxx" parameter.
$ pactl list | grep -A2 'Source #' | grep 'Name: ' | cut -d" " -f2

What is the right name;
"gstreaemer-libav" or "gstreaemer-plugins-libav"?

EOL.

Akdor 1154 (akdor1154) wrote :

I think this is still an issue in 17.04...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions