Remove mysql dependency for LPIA

Bug #191952 reported by Steve Magoun on 2008-02-14
4
Affects Status Importance Assigned to Milestone
gst-plugins-bad0.10 (Ubuntu)
Wishlist
Unassigned
totem (Ubuntu)
Undecided
Unassigned

Bug Description

The effort to add MythTV support to Totem (bug 187582) introduced a dependency on mysql-common. This is bad for Ubuntu Mobile, which has to work on resource-constrained devices. Consider disabling the MythTV dependency for the LPIA-architecture builds of gst-plugins-bad0.10.

Tags: ume Edit Tag help
Loïc Minier (lool) wrote :

I think this is a lot for the desktop too; this plugin could be split in a separate package I guess.

Is this something specific to gst-plugins-bad0.10 or to totem?

Emilio Pozuelo Monfort (pochu) wrote :

AFAIK this builds a mythtv plugin in gst-plugins-bad, which is then used by the totem plugin, so this would be gstreamer specific.

slomo? :)

Loïc Minier (lool) wrote :

We should butcher shlibs:Depends to move the libgmyth to Recommends.

Also, the new totem-plugins-extra needs to depend on gstreamer0.10-plugins-bad and libgmyth after this change.

Pedro Villavicencio (pedro) wrote :

ping? any news about this?

Daniel T Chen (crimsun) on 2008-11-29
Changed in gst-plugins-bad0.10:
importance: Undecided → Wishlist
Emmet Hikory (persia) wrote :

I'm marking this wontfix in the interest of reducing architecture-specific changes. Attempting to create a relationship between an architecture and a given use case creates confusion for users who may have multiple architectures available.

Changed in gst-plugins-bad0.10:
status: New → Won't Fix
Changed in totem:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers