package gstreamer sw midi playback plugin

Bug #111555 reported by Roman Polach on 2007-05-01
40
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gst-plugins-bad0.10 (Ubuntu)
Low
Unassigned
gstreamer (Ubuntu)
Undecided
Unassigned
timidity (Ubuntu)
Low
Unassigned

Bug Description

Gstreamer based media players should be able to play midi files by default.

A gstreamer software midi playback plugin exists in the gst-plugins-bad upstream source package. Could you please package it?

Roman Polach (rpolach) wrote :

It displays "Could not determine type of stream" when trying to open *.mid file.

Greg Toombs (greg-toombs) wrote :

Supposedly there already is support for timidity in the gstreamer plugin set, but I don't really know how to make it work.

Roman Polach (rpolach) wrote :

Only a note: This problem still present in Gutsy

Stéphane Loeuillet (leroutier) wrote :

MIDI support has been implemented/released in gstreamer-plugins-base 0.10.5 (source package)
but it hasn't been added to the binary package yet.

http://gstreamer.freedesktop.org/releases/gst-plugins-bad/0.10.5.html

Changed in gstreamer:
status: New → Confirmed
description: updated
Emilio Pozuelo Monfort (pochu) wrote :

This needs to be enabled in -plugins-bad, once libtimidity is packaged (/me looks at persia ;)

Changed in gstreamer:
status: Confirmed → Invalid
Emmet Hikory (persia) on 2007-12-20
Changed in gst-plugins-bad0.10:
importance: Undecided → Low
status: New → Triaged
Emmet Hikory (persia) on 2007-12-20
Changed in timidity:
importance: Undecided → Low
status: New → Confirmed
Mark Van den Borre (markvdb) wrote :

The relevant Debian bug on this one is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=346455 . The most interesting thing here is probably that http://www.whiz.se/temp/libtimidity/ contains a libtimidity .deb.

https://bugs.launchpad.net/ubuntu/+bug/177672 is a related bug.

Emmet Hikory (persia) wrote :

Just as a note, libtimidity (http://freshmeat.net/projects/libtimidity/) is not actually used by the gst-plugins-universe-bad build. It requires timidity itself, which would need a somewhat different library package name in order to not conflict with libtimidity. If possible, using a wildmidi-based solution may be easier to avoid build-depending on a daemon.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gst-plugins-bad0.10 - 0.10.6-1ubuntu1

---------------
gst-plugins-bad0.10 (0.10.6-1ubuntu1) hardy; urgency=low

  * New upstream bug-fix release (LP: #193953).
  * Sync with Debian, remaining changes:
    - Build mythtvsrc plugin:
      + Add libgmyth-dev (>= 0.7.debian1-1~hardy1) to build-deps.in
      + Add mythtvsrc plugin to gstreamer-plugins-bad.install
    - Build midi plugin (LP: #111555):
      + Add libwildmidi-dev to build-deps.in
      + debian/patches/11_build_wildmidi_plugin_if_enabled.patch:
        · Build the wildmidi plugin if it's enabled in configure.
      + debian/patches/90_automake.patch:
        · Regenerate ext/Makefile.in for the above patch changes.
      + debian/gstreamer-plugins-bad.install:
        · Install the wildmidi plugin.
      + debian/gstreamer-plugins-bad.install,
        debian/wildmidi.cfg:
        · Copy the freepats.cfg config file from the freepats
          package to debian/wildmidi.cfg and install it as
          /usr/share/gstreamer0.10/timidity.cfg.
      + TODO: Mimetype detection.
    - Change Maintainer to Ubuntu MOTU Developers.

gst-plugins-bad0.10 (0.10.6-1) unstable; urgency=low

  * New upstream release, "A Big Deep Breath":
    + debian/patches/01_linking-fixes.patch:
      - Dropped, merged upstream.
  * debian/rules,
    debian/build-deps.in,
    debian/gstreamer-plugins-bad.install:
    + Enable the alsaspdif, libcdaudio, dvb, fbdev and vcd plugins
      only on Linux architectures to try to fix FTBFS on kfreebsd.

 -- Emilio Pozuelo Monfort <email address hidden> Sat, 23 Feb 2008 01:37:15 +0100

Changed in gst-plugins-bad0.10:
status: Triaged → Fix Released
Emilio Pozuelo Monfort (pochu) wrote :

Closing timidity tasks. Emmed Hikory packaged wildmidi, and we are now building the wildmidi midi plugin in gst-plugins-bad.

Changed in timidity:
status: Confirmed → Invalid
Conrad Knauer (atheoi) wrote :

very curious... I decided to install Hardy to my HD and begin inspecting various programs; I installed a bunch of the Gstreamer plugins, including gstreamer0.10-plugins-bad and installed timidity and freepats. Suddenly my MIDIs can play in Totem! Ununstalling timidity makes no change; uninstalling freepats makes it not work (a little research later and I'm here). However, when it gets to the end of the song, I get the "search for suitable codec?" message, but the result is "There is no matching application available." (yet... it was just playing! 8-)

Some bug in there somewhere, but its great to listen to MIDIs in Totem!

Simos Xenitellis  (simosx) wrote :

I can verify what Conrad says in the previous post.

By default Totem (Gstreamer) can play midi files with gstreamer-plugins-bad, however it requires the package "freepats".
Sadly, there is no dependency when one installs gstreamer-plugins-bad to install freepats as well. Probably because freepats is ~27MB?

Totem (gstreamer) is able to play midi files, however
1) when you try to seek (use mouse to skip later in the midi file), the playback gets screwed up
2) at the end of the playback you get a message to search for codec which is superfluous as the file was just played.

Greg A (etulfetulf) wrote :

Simon that is bug #208068

Lauri Niskanen (ape3000) wrote :

I have totem 2.24.3 and GStreamer 0.10.21. I also have timidity and freepats. When I try to play a MIDI file on totem it just says: "Could not determine type of stream."

So what do I need to do, if I want to play .mid-files on Totem?

The problem with Midi on Totem is that I can't set (or don't know how to set) my own soundfont (I'm using one called "Ultimate" on TiMidity).

@Lauri Niskanen: Do you also have totem-gstreamer installed?

Toto (dart56) on 2010-04-09
Changed in gst-plugins-bad0.10 (Ubuntu):
status: Fix Released → Fix Committed
Kip Warner (kip) wrote :

I'm running lucid and still can't play with Rhythmbox. Says no decoder available. I've installed all of the timidity packages I see listed in the repository.

Greg A (etulfetulf) wrote :

Make sure you have gstreamer0.10-plugins-bad installed. You don't need the timidity/freepats packages, so I would suggest removing them.

Kip Warner (kip) wrote :

I have the -multiverse variant installed. Is that a problem?

Greg A (etulfetulf) wrote :

You can have both installed, so install gstreamer0.10-plugins-bad as well.

Kip Warner (kip) wrote :

I have it installed too, apparently.

$ dpkg --get-selections | grep -i gstreamer
bluez-gstreamer install
gstreamer0.10-alsa install
gstreamer0.10-esd install
gstreamer0.10-ffmpeg install
gstreamer0.10-fluendo-plugins-mp3-partner install
gstreamer0.10-gnomevfs install
gstreamer0.10-gnonlin install
gstreamer0.10-nice install
gstreamer0.10-packagekit install
gstreamer0.10-plugins-bad install
gstreamer0.10-plugins-bad-multiverse install
gstreamer0.10-plugins-base install
gstreamer0.10-plugins-base-apps install
gstreamer0.10-plugins-base-dbg install
gstreamer0.10-plugins-good install
gstreamer0.10-plugins-good-dbg install
gstreamer0.10-plugins-ugly install
gstreamer0.10-plugins-ugly-multiverse install
gstreamer0.10-pocketsphinx install
gstreamer0.10-pulseaudio install
gstreamer0.10-tools install
gstreamer0.10-x install
libgstreamer-plugins-base0.10-0 install
libgstreamer0.10-0 install
libgstreamer0.10-0-dbg install

Greg A (etulfetulf) wrote :

That seems odd. Just wondering if maybe the midi files we are using to test are somehow different. Could you try with the file I've been using ( http://www.freewebs.com/dwmidi2/March%20of%20the%20Children.mid )

Kip Warner (kip) wrote :

Same deal. I tried using timidity program directly and it worked though.

Greg A (etulfetulf) wrote :

I don't think gstreamer0.10-plugins-bad actually uses timidity though. It uses something called wildmidi instead. Could you try installing the "wildmidi" packages and trying that directly?

Kip Warner (kip) wrote :

Works fine directly, but through Rhythmbox it still can't play.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.