Ubuntu

quicktime videos, on & offline, may be rendered poorly

Reported by Doug McMahon on 2013-02-24
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GStreamer
Fix Released
Medium
gst-libav1.0 (Ubuntu)
Undecided
Unassigned

Bug Description

check upstream bug for info, sample urls & sample file links
No fix as of yet though one simple for current gst-libav1.0 would be to change the element's default "max-threads=0" to 1
Also to note that the internal libav in gst-libav1.1 (git master) does not show this behavior with multi-thread decoding

https://bugzilla.gnome.org/show_bug.cgi?id=694230

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gstreamer1.0-libav 1.0.5-1
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Sun Feb 24 09:15:57 2013
InstallationDate: Installed on 2013-01-27 (27 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130126)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gst-libav1.0
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1132459

tags: added: package-qa-testing
Doug McMahon (mc3man) wrote :

fixed in gst-libav-1.0.6

Changed in gstreamer:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gst-libav1.0 (Ubuntu):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

not sure if suitable (1ubuntu1), but in hopes of some action before it's too late for 13.04
(will be 'self-fixing' when libav-0.9 & gst-1.1 land

The attachment "gst-libav1.0_1.0.5-1ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Marc Deslauriers (mdeslaur) wrote :

Thanks for the debdiff! Looks good, ACK!

Uploaded to Raring.

Changed in gst-libav1.0 (Ubuntu):
status: Confirmed → Fix Committed
Dmitry Shachnev (mitya57) wrote :

Fixed in 1.0.5-1ubuntu1. There was no '#' before the bug number in the changelog, so it was not closed automatically.

Changed in gst-libav1.0 (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.