Ubuntu

gspca does not compile anymore

Reported by gerstrong on 2008-09-23
176
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gspca (Debian)
Fix Released
Unknown
gspca (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by Thomas Markus

Bug Description

Binary package hint: gspca-source

In Ubuntu 8.04, you were able to compile this package for your webcam.

Now in Intrepid, the module is not included anymore. When I install this package and try to build it, there comes a compilation error. Sorry, I must check first on another computer next time, what error-message was. Compilation error.

linux-kernel-2.6.27.4-generic

I think a file of the kernel sources has been moved (couldn't find something like "asm")

Ubuntu 8.10 Alpha 6

gspca-source 1.00.20-1

As far as I understand, gspca is now part of the kernel. See:

https://lists.ubuntu.com/archives/ubuntu-devel/2008-September/026460.html

Tigra (thesuxx) wrote :

Confirm this bug

Maybe this could help to developers: http://linux.derkeiler.com/Mailing-Lists/Kernel/2008-08/msg02939.html

uname -a
Linux dt-home-desktop 2.6.27-4-generic #1 SMP Mon Sep 22 04:40:15 UTC 2008 x86_64 GNU/Linux

make -C /lib/modules/`uname -r`/build SUBDIRS=/usr/src/modules/gspca CC=cc modules
make[1]: Вход в каталог `/usr/src/linux-headers-2.6.27-4-generic'
  CC [M] /usr/src/modules/gspca/gspca_core.o
/usr/src/modules/gspca/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory
/usr/src/modules/gspca/gspca_core.c: In function ‘spca5xx_ioctl’:
/usr/src/modules/gspca/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
/usr/src/modules/gspca/gspca_core.c: At top level:
/usr/src/modules/gspca/gspca_core.c:2604: error: ‘v4l_compat_ioctl32’ undeclared here (not in a function)
/usr/src/modules/gspca/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
/usr/src/modules/gspca/gspca_core.c:2609: warning: initialization from incompatible pointer type
/usr/src/modules/gspca/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
/usr/src/modules/gspca/gspca_core.c: In function ‘spca50x_create_sysfs’:
/usr/src/modules/gspca/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
/usr/src/modules/gspca/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
/usr/src/modules/gspca/gspca_core.c: In function ‘spca5xx_probe’:
/usr/src/modules/gspca/gspca_core.c:4301: error: incompatible types in assignment
make[2]: *** [/usr/src/modules/gspca/gspca_core.o] Ошибка 1
make[1]: *** [_module_/usr/src/modules/gspca] Ошибка 2
make[1]: Выход из каталога `/usr/src/linux-headers-2.6.27-4-generic'
make: *** [default] Ошибка 2

Another thing, (why I need this driver) -- that creative live cam does not work anymore in 8.10 (worked well in 8.04)
(Cannot give now vendor id)

dmesg says:
[18357.772902] compat_ioctl32: VIDIOC_S_PARMioctl32(skype:8154): Unknown cmd fd(51) cmd(c0cc5616){t:'V';sz:204} arg(f620ee00) on /dev/video0

I saw that before, but It isn't included. I think it happens to be missing
because, when the kernel is build, that error isn't noticed. So when you
install intrepid with kernel 2.6.27.4-generic the module is missing and when
you try to compile it yourself, than the error message mentioned above,
appears.

2008/9/24 Wouter Stomp <email address hidden>

> As far as I understand, gspca is now part of the kernel. See:
>
> https://lists.ubuntu.com/archives/ubuntu-
> devel/2008-September/026460.html<https://lists.ubuntu.com/archives/ubuntu-devel/2008-September/026460.html>
>
> --
> gspca does not compile anymore
> https://bugs.launchpad.net/bugs/273727
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "gspca" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: gspca-source
>
> In Ubuntu 8.04, you were able to compile this package for your webcam.
>
> Now in Intrepid, the module is not included anymore. When I install this
> package and try to build it, there comes a compilation error. Sorry, I must
> check first on another computer next time, what error-message was.
> Compilation error.
>
> linux-kernel-2.6.27.4-generic
>
> I think a file of the kernel sources has been moved (couldn't find
> something like "asm")
>
> Ubuntu 8.10 Alpha 6
>
> gspca-source 1.00.20-1
>

Tigra (thesuxx) wrote :

The module is not missing in the kernel... But it does not work correctly for my webcam...

# lsmod | grep gspca
gspca_zc3xx 59520 0
gspca_main 33536 1 gspca_zc3xx
compat_ioctl32 18176 1 gspca_main
videodev 46720 2 gspca_main,compat_ioctl32
usbcore 175248 8 gspca_zc3xx,gspca_main,usbhid,usb_storage,libusual,ohci_hcd,ehci_hcd

Nick McGill (nick-mcgill) wrote :

I have the same problem - webcam is detected, but no picture.
I cannot compile the module as asm/semaphore.h is missing (previous posting)

Nick

gerstrong (gerstrong) wrote :

Yes, that is the same error output I get, when I try to compile it. Tigra
used x64 in that case, but in i386 it happens too.

2008/9/24 Nick McGill <email address hidden>

> I have the same problem - webcam is detected, but no picture.
> I cannot compile the module as asm/semaphore.h is missing (previous
> posting)
>
> Nick
>
> --
> gspca does not compile anymore
> https://bugs.launchpad.net/bugs/273727
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in "gspca" source package in Ubuntu: New
>
> Bug description:
> Binary package hint: gspca-source
>
> In Ubuntu 8.04, you were able to compile this package for your webcam.
>
> Now in Intrepid, the module is not included anymore. When I install this
> package and try to build it, there comes a compilation error. Sorry, I must
> check first on another computer next time, what error-message was.
> Compilation error.
>
> linux-kernel-2.6.27.4-generic
>
> I think a file of the kernel sources has been moved (couldn't find
> something like "asm")
>
> Ubuntu 8.10 Alpha 6
>
> gspca-source 1.00.20-1
>

gerstrong (gerstrong) wrote :

Hello everyone,

I have been checking for the missing semaphore.h that was in the kernel sources. in 2.6.24-19 I find that h-file for many versions.

In the new kernel it is missing. Maybe the file isn't needed anymore, but I think the source of gspca must modified to get it working. By the way, the original source is of 12-24-2007!

Tigra (thesuxx) wrote :

I think semaphore.h is not a real problem... You can remove it from gspca_core.c
But there are v4l related errors: error: ‘v4l_compat_ioctl32’ undeclared here (not in a function)
struct video_device does not have expected here .owner field ...

So, let's hope developers will correct this kernel

gerstrong (gerstrong) wrote :

tested Ubuntu 8.10 beta. Same Kernel, same Problem.

Olivier Guéry (nemolivier) wrote :

New kernel this morning. Same problem.

Tigra (thesuxx) wrote :

gerstrong wrote:
> Which Kernel did you use? Did you use the daily-snapshot of Intrepid or
> did you compile one of kernel.org pages?
>
>
2.6.27-5 (before, -4 and -3 )

Webcam does not work with 2.6.27 kernel, but works with 2.6.24

gerstrong (gerstrong) wrote :

Which Kernel did you use? Did you use the daily-snapshot of Intrepid or
did you compile one of kernel.org pages?

gerstrong wrote:
> Than temporary solution would be to roll back to the older kernel.
>
>
Exactly what I did. But anyway, this is a bug to be solved...

2008/10/6 Tigra <email address hidden>:
> gerstrong wrote:
>> Which Kernel did you use? Did you use the daily-snapshot of Intrepid or
>> did you compile one of kernel.org pages?
>>
>>
> 2.6.27-5 (before, -4 and -3 )
>
> Webcam does not work with 2.6.27 kernel, but works with 2.6.24

2.6.27-5 here too. Didn't know about this daily-snapshot thing.

O.

--
[Message tapé sur un clavier Bépo : http://www.clavier-dvorak.org ]
http://nemolivier.blogspot.com

gerstrong (gerstrong) wrote :

Than temporary solution would be to roll back to the older kernel.

gerstrong (gerstrong) wrote :

Look here:

http://cdimage.ubuntu.com/daily-live/current/

I would suggest to download and test it on the live-cd. It has most of
the updates included.

There is even a more updated version of hardy (8.04.1 LTS)

gerstrong (gerstrong) wrote :

has anyone tried to compile gspca-source on kernel 2.6.27-5 ?

Olivier Guéry (nemolivier) wrote :

2008/10/6 gerstrong <email address hidden>:
> has anyone tried to compile gspca-source on kernel 2.6.27-5 ?

It's the meaning of my morning message : i compiled it on 2.6.27-5
and compilation failed the same way.

Olivier.
--
[Message tapé sur un clavier Bépo : http://www.clavier-dvorak.org ]
http://nemolivier.blogspot.com

gerstrong (gerstrong) wrote :

I tried to compile it on kernel 2.6.26 patched with 2.6.27.rc9 from kernel.org and the error message changes, but it still doesn't work. I will upload the log-file next time. It was something about CC_EXTRAS.

Maybe this hint helps

gerstrong (gerstrong) wrote :

Here is the log-file

gerstrong (gerstrong) wrote :

Good News!

I don't know, if compilation is possible, but my webcam works now in Ubuntu 8.10 Daily-live CD of October 11th!

I going to check this further.

Please try it!

Kernel is 2.6.27-7!

There is a release of the new kernel! Have fun!

Good work!

Olivier Guéry (nemolivier) wrote :

2008/10/11 gerstrong <email address hidden>:
> Good News!
>
> I don't know, if compilation is possible, but my webcam works now in
> Ubuntu 8.10 Daily-live CD of October 11th!
>
> I going to check this further.
>
> Please try it!
>
> Kernel is 2.6.27-7!
>
> There is a release of the new kernel! Have fun!
>
> Good work!
>
> --
> gspca does not compile anymore
> https://bugs.launchpad.net/bugs/273727
> You received this bug notification because you are a direct subscriber
> of the bug.
>

I read this yesterday : gspca is included in linux 2.6.27 !
Thank's the kernel team !

Olivier.

--
[Message tapé sur un clavier Bépo : http://www.clavier-dvorak.org ]
http://nemolivier.blogspot.com

Olivier Guéry (nemolivier) wrote :

Ok, I confirm.
After the update this morning my webcam work out of the box in cheese.
No compilation needed !

I suppose we can close this bug.

Testing in skype, (configuration > video > test) kill skype…

gerstrong (gerstrong) on 2008-10-11
Changed in gspca:
status: New → Fix Released
gerstrong (gerstrong) wrote :

Skype works, but like in other Webcam only green bars are seen.

Only Cheese is working with my webcam.

Camorama, ekiga and skype won't budge!

Changed in gspca:
status: Fix Released → In Progress
gerstrong (gerstrong) wrote :

Skype works using the newest version of libv4l and the LD_PRELOAD parameter.

Just try it!

gerstrong (gerstrong) wrote :

I think this bug can be closed when, Skype is patched or scripted for the new linux kernel.

Changed in gspca:
status: In Progress → Fix Committed
Mario Sitz (mario-sitz) wrote :

I have still green bars with the x64-version and kernel 2.6.27-7.
I tested with camera and it can't get the available resolutions.

With the 32-bit version I get an image with the same webcam.

gerstrong (gerstrong) wrote :

Am Montag, den 20.10.2008, 06:51 +0000 schrieb Mario Sitz:
> I have still green bars with the x64-version and kernel 2.6.27-7.
> I tested with camera and it can't get the available resolutions.
>
> With the 32-bit version I get an image with the same webcam.
>

@Mario Sitz: Did you only Skype, or also apps like cheese, ekiga, etc. ?

Mario Sitz (mario-sitz) wrote :

gerstrong schrieb:
> @Mario Sitz: Did you only Skype, or also apps like cheese, ekiga, etc. ?
>
>
@gerstrong

I tested now again on my 64-bit system (after a bunch of updates),

my webcam is working again.
cheese works instantly,
skype,kopete works with LD_PRELOAD.

fdmarco (fdmarco3) wrote :

Can you please explain what kind of upgrades? I still have the green screen in skype in intrepid ibex 64bit version both launching skype normally and with the LD_PRELOAD option. The other programs run fine.

Mario Sitz (mario-sitz) wrote :

fdmarco schrieb:
> Can you please explain what kind of upgrades? I still have the green
> screen in skype in intrepid ibex 64bit version both launching skype
> normally and with the LD_PRELOAD option. The other programs run fine.
>
>
I don't know which updates all were made.

I used skype from medibuntu (http://www.medibuntu.org)
But these packages are currently broken for amd64:
(https://bugs.launchpad.net/medibuntu/+bug/286215)

And I used the following command:
LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype
(with installed lib32v4l-0 )

sojourner (itsmealso2) wrote :

The builtin driver working does not address this bug which is about gspca-source installed from synaptic does not compile and gives the errors noted above . the semaphore.h include has been moved from /usr/src/linux-headers....../asm/ to /usr/src/linux-headers....../linux/ . hacking gspca_core.c to point it at the right place gets rid of the semaphore.h error but not the other errors . it still won't build on my 64bit sys uptodate as of oct21 AM .

ElTimo (homicidal-tofu) wrote :

I can confirm this, as my webcam doesn't work with the normal gspca. It requires "gspca_core.c" to be hacked a little, but after that, it was working with 2.6.24 . Now, I can't get it to compile. According to avb from ubuntuforums, the api for v4l has changed. Could we possibly get a version of gspca-source that is updated to reflect this?

PS: My webcam is a logitech quickcam e2500. It isn't supported by default by gspca, but gspca DOES work with it.

gerstrong (gerstrong) wrote :

I believe, that gspca-source is too old now. There must come something
similiar, but official didn't update this.

I only can recommend updating the complete Linux-Kernel, because the
driver have been integrated. Compile your own version downloading of
www.kernels.org

Maybe the most recent Kernel works for you. I cannot guarantee that. I'm
sorry. But maybe you have luck. Anyway the developers are still working
hard on it!

Am Dienstag, den 21.10.2008, 16:13 +0000 schrieb ElTimo:
> I can confirm this, as my webcam doesn't work with the normal gspca. It
> requires "gspca_core.c" to be hacked a little, but after that, it was
> working with 2.6.24 . Now, I can't get it to compile. According to avb
> from ubuntuforums, the api for v4l has changed. Could we possibly get a
> version of gspca-source that is updated to reflect this?
>
> PS: My webcam is a logitech quickcam e2500. It isn't supported by
> default by gspca, but gspca DOES work with it.
>

Jae Stutzman (jaebird) wrote :

My Logitech QuickCam E2500 also does not work with Intrepid kernel 2.6.27-7-generic x64. Since gspca is now a part of the kernel and support for the E2500 requires a patch to gspca, can we expect an updated kernel with support for this camera? So far I have not seen any solutions to this problem, or any indication that a kernel.org kernel actually works with this camera.

yasou (yasou) wrote :

For the people who need to patch the gspca source to use a special camera like the E2500 they should get a more recent source available here:
http://linuxtv.org/hg/v4l-dvb (download gz or bz2)

Use these instructions: http://moinejf.free.fr/gspca_README.txt

in my case it didn't help, my camera still doesn't work since Ubuntu 8.10, although it worked with 8.04. And as I have recompiled the driver I don't think that the gspca driver that comes with ubuntu is causing the problem.

I believe it is something with the kernel itself, but as I don't know how the linux kernel and driver function I don't know what could be wrong.

My camera: Z-Star Microelectronics Corp. ZC0303 WebCam
GSPCA-driver: gspca_zc3xx

it works with zc0301 but only with v4l2 and thus only with ekiga. (no v4l support here) In Hardy 8.04 I just blacklisted zc0301 and gspca took over the cam automatically.

in 8.10 (kernel 2.6.27) , dmesg only gives me:
[29143.996060] usb 2-1: new full speed USB device using uhci_hcd and address 6
[29144.197121] usb 2-1: configuration #1 chosen from 1 choice

I strongly believe that the problem has to do with the kernel, not the gspca driver iself.

Andres Mujica (andres.mujica) wrote :

Hi, i've marked some dupes from this bug. Please take into account that gspca modules are being introduced to the kernel, so the chances are that you don't need to compile it anymore. Please check the bugs: bug #292086, bug #144745 and bug #260918

Regards,

dmoyne (daniel-moyne) wrote :

I just want to add a comment here in relation with module "ov5x-jpeg" necessary to get a webcam Hercules Classic to work :
- it is necessary to delete module "gspca_ov519" that otherwise is automatically loaded,
- then the Hercules Classic works fine even with Skype.

I do not know wether module "gspca_ov519" belongs to the package herewith mentioned.

Regards.

frenchn00b (yellow-protoss) wrote :

Hi,
I downloaded this version:
http://mxhaard.free.fr/spca50x/Download/gspcav1-20071224.tar.gz

not working with the last kernel properly compiled debian way:
Linux 2.6.27.8 #1 SMP Wed Dec 24 17:03:01 CET 2008 i686 GNU/Linux
So??

/usr/src/modules/gspcav1-20071224# make
make -C /lib/modules/`uname -r`/build SUBDIRS=/usr/src/modules/gspcav1-20071224 CC=cc modules
make[1]: Entering directory `/usr/src/linux-2.6.27.8'
  CC [M] /usr/src/modules/gspcav1-20071224/gspca_core.o
/usr/src/modules/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory
/usr/src/modules/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
/usr/src/modules/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
/usr/src/modules/gspcav1-20071224/gspca_core.c: At top level:
/usr/src/modules/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
/usr/src/modules/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
/usr/src/modules/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
/usr/src/modules/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
/usr/src/modules/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
/usr/src/modules/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
/usr/src/modules/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
/usr/src/modules/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
make[2]: *** [/usr/src/modules/gspcav1-20071224/gspca_core.o] Error 1
make[1]: *** [_module_/usr/src/modules/gspcav1-20071224] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.27.8'
make: *** [default] Error 2

Bruce Crowther (bandjc) wrote :

Yep, that's about my problem too. I cannot compile gspca with kernel 2.6.27-11 generic in 64 bit Intrepid. Synaptic tells me I have the latest version, but it doesn't load at boot.
Something does not compute, pardon the pun.
There are issues abroad with Logitech Quickcam E2500 which require patching the source: done that, but no help as the source won't compile.
Every time I find a fix for a problem that still requires me to keep my WinDoze partition, another one rears it's ugly head. Now have OCR working, Palm syncing, and suddenly Linux kills my webcam. Buggah! Apart from that hiccup, Ubuntu blows XP into the weeds for user friendliness.

Bruce Crowther (bandjc) wrote :

Hmm, silly me: added gspca_zc3xx to /etc/modules and it loads, but still no webcam. I have the source, and I have added a line to it to include my camera, but how to compile it and replace the old driver is quite beyond me.

Martijn van Maurik (combro2k) wrote :

I can't also compile this source with the same as frenchn00b.
I've a logitech Notebook Deluxe, can't use it out-of-the-box, or did I do something wrong?

Even dmesg doesn't show any information except the usual information:
[ 1302.896569] usb 2-1: USB disconnect, address 3
[ 1304.900609] usb 2-1: new full speed USB device using ohci_hcd and address 4
[ 1305.071745] usb 2-1: configuration #1 chosen from 1 choice

(lsusb: Bus 002 Device 004: ID 046d:08d8 Logitech, Inc. QuickCam for Notebook Deluxe )

Working on a 64 bits system aswell:
Linux c2k-multimedia 2.6.27-9-generic #1 SMP Thu Nov 20 22:15:32 UTC 2008 x86_64 GNU/Linux

Regards

Lucio (lumatemp-nospam) wrote :

Same problem on my Dell Latitude D620 with a TRUST HiRes Webcam Live WB-3420N (ID 145f:013c when lsusb is issued), Ubuntu 8.10 all patches appied on BOTH 32 and 64 bit OS (kernel 2.6.27-11).

When compiling gspca provided in Intrepid repos this errors appears:

/usr/src/modules/gspca/gspca_core.c:54:27: error: asm/semaphore.h: Nessun file o directory

(sorry I'm unable to paste the entire log... how to copy from the module-assistant window?)

The webcam does not work with cheese nor with any other software.

Bruce Crowther (bandjc) wrote :

Bought a cheap camera (NZ$9.00) on an auction site, and it works straight out of the box in 64 bit 8.10 with 2.6.27-ll from the repos (proposed).
Anyone want a Logitech E2500? Not seriously, I am sure a fix will come for it, and I will hand the el cheapo on.

Martijn van Maurik (combro2k) wrote :

Bruce,

Can you please tell me which camera it is?

Kind Regards,
Martijn

Bruce Crowther (bandjc) wrote :

"Bruce,

Can you please tell me which camera it is?

Kind Regards,
Martijn"

Martjin,
It calls itself an Auriga Smartlook, I think it is a cheap thing knocked out for the Australia/New Zealand market. Perhaps more to the point is what lsusb finds, which points those with the knowledge at the sensor type, I believe: Bus 001 Device 005: ID 0461:4d15 Primax Electronics, Ltd
Cheers,
Bruce.

Petr Kopač (petrkopac) wrote :

I bought E2500, too. There's an instruction for installing with a link to a patch, which is okay with ubuntu 8.10:
http://www.actionshrimp.com/2008/08/logitech-quickcam-e2500-on-ubuntu-skype/
But I'm not able to compile the gstfakevideo, so it takes me insane amount of cpu power (circa 50 %). Also the image output doesn't look well (I'm going to check it on windows soon, too). Is there any possibility that this will be functional "out of the box" in some future updates? What's the problem btw?

Andres Mujica (andres.mujica) wrote :

Hi, with latest Jaunty Alpha4 would it be possible for some of you to test if this is still an issue?

thanks in advance!

On Jaunty i have done this:

sudo apt-get install gspca
sudo -i
tar jxvf gspca.tar.bz2

cd /usr/src/modules/gspca/
./gspca_build

I get....

 ./gspca_build

 REMOVE the old module if present
ERROR: Module gspca does not exist in /proc/modules

 CLEAN gspca source tree
rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \
 .gspca.o.cmd *.o *.ko *.mod.* .[a-z]* core *.i \
 *.symvers *.err

 COMPILE gspca Please Wait ....!!

 INSTALL gspca in the kernel binary tree
mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
install: cannot stat `gspca.ko': No such file or directory
make: *** [install] Error 1

 LOAD gspca in memory
FATAL: Module gspca not found.

 PRINT COMPILATION MESSAGES if ERRORS look kgspca.err
make -C /lib/modules/`uname -r`/build SUBDIRS=/usr/src/modules/gspca CC=cc modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.28-8-generic'
  CC [M] /usr/src/modules/gspca/gspca_core.o
/usr/src/modules/gspca/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory
/usr/src/modules/gspca/gspca_core.c: In function ‘spca5xx_ioctl’:
/usr/src/modules/gspca/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
/usr/src/modules/gspca/gspca_core.c: At top level:
/usr/src/modules/gspca/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
/usr/src/modules/gspca/gspca_core.c:2609: warning: initialization from incompatible pointer type
/usr/src/modules/gspca/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
/usr/src/modules/gspca/gspca_core.c: In function ‘spca50x_create_sysfs’:
/usr/src/modules/gspca/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
/usr/src/modules/gspca/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
/usr/src/modules/gspca/gspca_core.c: In function ‘spca5xx_probe’:
/usr/src/modules/gspca/gspca_core.c:4301: error: incompatible types in assignment
make[2]: *** [/usr/src/modules/gspca/gspca_core.o] Error 1
make[1]: *** [_module_/usr/src/modules/gspca] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.28-8-generic'
make: *** [default] Error 2

Andres Mujica (andres.mujica) wrote :

This is still a problem according to reporters and some dupes i've found

Changed in gspca:
status: Fix Committed → Confirmed
Didier Eymet (didiereymet) wrote :

I have exactly the same log as marcobra, today 2009, April 18 with Jaunty RC.

permafrost91 (permafrost91) wrote :

Running up-to-date Jaunty 32bit (April 18 2009). Logitech QuickCam Connect E2500. Same problem everyone else is having, cannot patch and compile gspca source.

Ryan Daly (daly-ctcnet) wrote :

I'm running up-to-date Intrepid and am in the same boat, unfortunately.

Is there a kernel patch coming or should I return this camera?

Tarek Loubani (tareko) wrote :

I agree that there are enough problems with gspcav2 that v1 is desirable. I feel a bit closer when adding the patches from http://www.actionshrimp.com/2008/08/logitech-quickcam-e2500-on-ubuntu-skype/ , since it at least compiles. However, I continue to have the error:

gspca: disconnect complete
gspca: disagrees about version of symbol video_devdata
gspca: Unknown symbol video_devdata
gspca: disagrees about version of symbol video_unregister_device
gspca: Unknown symbol video_unregister_device
gspca: disagrees about version of symbol video_device_alloc
gspca: Unknown symbol video_device_alloc
gspca: disagrees about version of symbol video_register_device
gspca: Unknown symbol video_register_device
gspca: disagrees about version of symbol video_usercopy
gspca: Unknown symbol video_usercopy
gspca: disagrees about version of symbol video_device_release
gspca: Unknown symbol video_device_release

which is discussed in Bug #160814

tarek : )

gerstrong (gerstrong) on 2009-11-11
Changed in gspca (Ubuntu):
status: Confirmed → Fix Released
Changed in gspca (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.