init script is broken

Bug #30228 reported by Mitja Pagon
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gsmlib (Ubuntu)
Medium
Abhishek kumar singh

Bug Description

gsm-utils init script in /etc/init.d doesn't work as expected

custom settings from /etc/default/gsm-utils aren't read and taken into account.

Revision history for this message
Mitja Pagon (sect2k) wrote : fixed init script

This is a somewhat fixed version of the gsm-utils init script. Setting in /etc/default/gsm-utils are taken into account.

I belive there are some other minor issues with the script like reload not stoping the daemon before starting it again, but i haven't looked into that issue yet.

Cheers,
Mitja

Revision history for this message
Barry deFreese (bddebian) wrote :

Uploaded with attached patch. Thank you for the report and the fix. I also looked at the reload portion and it was doing --start twice so I changed the first instance to --stop to stop the daemon.

Changed in gsmlib:
status: Unconfirmed → Fix Committed
Revision history for this message
Barry deFreese (bddebian) wrote :

Built successfuly. Thank you.

Changed in gsmlib:
status: Fix Committed → Fix Released
Roman Yepishev (rye)
Changed in gsmlib (Ubuntu):
status: Fix Released → New
Revision history for this message
Roman Yepishev (rye) wrote :

I have to reopen this bug report since current version in Karmic has pretty much the same issue.
See the attached patch.

Revision history for this message
Roman Yepishev (rye) wrote :

This version of the patch does not read the options twice.

Revision history for this message
Roman Yepishev (rye) wrote :

And it looks like I will need to rewrite the patch once more, seems like the init script was not given much love :)

If I get my cellphone to work with gsmsmsd then I will rewrite the init script (or maybe it is better to convert it to upstart?)

tags: added: patch
tags: added: karmic
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Roman,

Are you still going to work on updating your patch? I'd like to give you a chance to adjust it to whatever you expect to happen precisely, then we can present it to Debian or consider applying changes directly in Ubuntu. Note that upstream does not seem very active, there hasn't been a new release in almost two years.

tags: added: patch-needswork
removed: patch
Changed in gsmlib (Ubuntu):
assignee: nobody → Abhishek kumar singh (abhishekkumarsingh-cse)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gsmlib - 1.10+20120414.gita5e5ae9a-0.1

---------------
gsmlib (1.10+20120414.gita5e5ae9a-0.1) unstable; urgency=low

  * Non-maintainer upload.
  * Update to the latest Git version by Vianney Bouchaud.
  * Use 3.0 (quilt) source package format.
  * Own the run subdirectory (Closes: #689891).
  * Don't remove the system user on package remove.
  * Fix init script (LP: #30228).

 -- Andrew Shadura <email address hidden> Tue, 15 Oct 2013 13:29:27 +0200

Changed in gsmlib (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers