Ubuntu

Gshutdown closes gnome session but does not shutdown down

Reported by Christoph Langner on 2007-06-27
168
This bug affects 34 people
Affects Status Importance Assigned to Milestone
gshutdown (Baltix)
Undecided
Unassigned
gshutdown (Ubuntu)
Undecided
zsolt320i
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher
Gutsy
Undecided
Unassigned

Bug Description

Binary package hint: gshutdown

I installed gshutdown 0.1 via the package management of Ubuntu Feisty Fawn. When i try to shut the computer down via gshutdown the gnome session is closed down but i end up inside gdm again and the computer doesn't turn off.

When i run

# tail -f -n 0 /var/log/messages

while "shutting down" via gshutdown i get this messages

--
Jun 27 19:40:02 ubuntu gconfd (ubuntu-20442): Beenden
Jun 27 19:40:02 ubuntu kernel: [18009.415703] mtrr: your processor doesn't support write-combining
--

I can reproduce this error on multiple computers.

Christoph Langner (chrissss) wrote :

This bug is solved in Upstream. GShutdown 0.2 has been released tody. It solves this bug.

---
* GDM bug fixed.
---

http://gnomefiles.org/app.php/gshutdown

Maxime Chéramy (maxime81) wrote :

I agree :

GDM has changed with the last release of ubuntu (feisty) then gshutdown couln't "speak" with GDM but still could close the session.

We decided to stop using the gdm functions and use a system command instead of the old method...

The bug is normally fixed now. If not, please contact us.

http://gshutdown.tuxfamily.org

Christoph Langner (chrissss) wrote :

Please close this bug. The new upstream version fixes this issue!

Changed in gshutdown:
status: New → Fix Released
Skippy (skippyfr) wrote :

Don't close the bug yet.
In Gutsy the version is still the 0.1 and it doesn't work. It closes the gnome session, but doesn't shutdown the computer.

Please publish the last version in the repositories, test the shutdown, and after close the bug report.

Maxime Chéramy (maxime81) wrote :

The bug is fixed with the 0.2 release. Gutsy must use the 0.2 release instand.

I hope there are some packagers working on it.

gerard (zzking) wrote :

I fullt agree with Skippy, the bug is still there on Gutsy.

Gshutdown is, after today's update dec 21th 2007, in release GShutdown 0.1.

What can we do to get the 0.2 if it is not in the repositories???? could you stream it up in order to get rid of this long lasting bug please.

Because even if the bug is solved, if we cannot get the "patch" I consider the problem is still alive!!

Thx a lot for your help

Emmet Hikory (persia) wrote :

This will not be fixed in gutsy (or feisty), as it does not meet the criteria for a Stable Release Update. Specifically, it is not a security vulnerability, not a regression (feisty didn't work), will not cause loss of user data, the package doesn't fail to build from source, the package can be installed, and the program doesn't segfault on startup. If you disagree with this conclusion, please review https://wiki.ubuntu.com/StableReleaseUpdates and follow the process described therein to apply for inclusion in prior releases.

gshutdown 0.2 was added to the Ubuntu repository in preparation for Ubuntu 8.04 on 12th November, 2007, and will be included in future releases of Ubuntu, closing this bug.

Note that it is inappropriate to mark a bug "Fix Released" prior to the upload of a fixed version to the Ubuntu repositories. It is likely that the solution to this bug could have been included in Ubuntu 7.10 if this bug had not been mistakenly marked as solved.

Changed in gshutdown:
status: New → Won't Fix
aloctavodia (aloctavodia) wrote :

I have been using gshutdown with jaunty and intrepid.
After upgrading to karmic alpha3 gshutdown stop working properly now it close the session instead of shutting down the system. Now I´m using Karmic alpha 6 and the problem is still there.

Thanks in advance.

aloctavodia (aloctavodia) wrote :

same problem using Karmic beta :-(

Christoph Langner (chrissss) wrote :

The new GDM doesn't work gnome-session anymore. I reopen this issue

Changed in gshutdown (Ubuntu):
status: Fix Released → Confirmed
Marcus Sundman (sundman) wrote :

As a workaround for the shutdown method you can use the custom command "gnome-session-save --shutdown-dialog" (without the ") in gshutdown's preferences.

zsolt320i (zsolt320i) on 2010-05-26
Changed in gshutdown (Ubuntu):
assignee: nobody → zsolt320i (zsolt320i)
wpshooter (joverstreet1) wrote :

My experience is that gshutdown works perfectly on my Jaunty computer but does not work correctly on my Lucid computer.

On the Lucid computer it only closes the current users' session and goes back to the user/password login prompt, instead of shutting down the computer as expected.

Thanks.

igi (igor-cali) on 2010-10-30
tags: added: maverick
ValentinV (valentinverde) wrote :

Please fix this problem

goldencut (goldencut) wrote :

same problem on maverick (10.10) - instead of shutdown we get login screen.

koukourikos (ekoukourikos) wrote :

Quick fix: (tested under Ubuntu 10.04)

run
sudo chmod +s /sbin/shutdown

and then open gshutdown properties,choose own command for shutdown:

shutdown -h now

source: " http://ubuntuforums.org/showthread.php?t=807186&page=2 "

Me too I have this problem on maverick. When I try to launch gshutdown in a terminal, it launch, but write it:

** (gshutdown:8860): WARNING **: Failed to establish a connection with GDM: Aucun fichier ou dossier de ce type

I only selected the last line, cause I really think it's the problem.

@koukourikos : with your solution, does it mean that everyone can use the command shutdown ? What about the security in this case ? Isn't it more secure to launch gshutdown in sudo : I mean use the command gskudo gshutdown or sudo gshutdown ?

To add some information to the comment of Marcus (#11). A workaround to use the logout action is to set the following command in the preferences of gshutdown :
gnome-session-save --logout

Specially for the Frenchies : look at this page : http://doc.ubuntu-fr.org/gshutdown

weeix (weeaix) wrote :

Almost 4 years passed but this bug still exists in Lucid/gshutdown 0.2

Mantas Kriaučiūnas (mantas) wrote :

Lots of improvements made in GShutdown since May 2008 (GShutdown 0.2 release), see
http://svn.tuxfamily.org/viewvc.cgi/gshutdown_gshutdown/ChangeLog?view=markup
But Ubuntu 12.04 and older includes old and buggy GShutdown 0.2 :(

Btw, last active GShutdown developer told me "gshutdown is no longer developed nor maintained", see text at the end.
So, I've chosen to improve Gpoweroff, which is an alternative to GShutdown written in Python/Gtk, see
https://launchpad.net/gpoweroff

I've improved Gpoweroff - added Hibernate and Suspend actions, changed dbus commands to modern universal org.freedesktop.ConsoleKit instead of outdated (and GNOME-depending) org.gnome.SessionManager
Patched Gpoweroff works fine with latest Ubuntu/Kubuntu 11.04 and 11.10 releases (should work in 10.04 too)
Main GShutdown developer Philip Peitsch promised me to add my improvements to official Gpoweroff sources and release new Ubuntu packages in ppa:gpoweroff/stable repository, see bug #973577

Please include Gpoweroff instead of unmaintained and not working Gshutdown in Ubuntu repositories.

Newest Gpoweroff can also be installed from official Baltix GNU/Linux repository (ppa:baltix-members/ppa ), see
https://launchpad.net/~baltix-members/+archive

On Tue, Apr 3, 2012, Maxime Chéramy <email address hidden> wrote:
> Unfortunately, gshutdown is no longer developed nor maintained for a long
> time now. There are several reasons for that:
> - The developers had other projects and not enough time to do everything.
> - It was very discouraging to adapt the source code after each major
> release : the protocols changed, the commands changed, etc. That explains
> the "it stopped to work". At the time, there was a lack of a real standard
> common to any distribution and desktop manager. The solution was to try 3
> different ways of doing the same action! I don't know the current situation.
> - The source code was in C/Gtk2+ which is not very sexy to develop a
> graphical application. I would definitely use Python/Gtk now.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions