gsfonts-x11 depends on uninstallable transitional package xutils

Bug #56008 reported by Martin Kretzschmar on 2006-08-11
4
Affects Status Importance Assigned to Milestone
gsfonts-x11 (Debian)
Fix Released
Unknown
gsfonts-x11 (Ubuntu)
Medium
Unassigned

Bug Description

xutils is not installable because imake was dropped from edgy.

(xutils has:Depends: imake (>= 1:1.0.0) | xmkmf, xcursorgen, sessreg, xfonts-utils
and there are no files in xutils itself)

xmkmf, xcursorgen and sessreg aren't necessary for gsfonts-x11, are they? And there's already an xfonts-utils dependency in gsfonts-x11. Shouldn't that be enough?

Related branches

Paul Dufresne (paulduf) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
xutils does not depends on imake anymore in 7.10.
So we are closing this bug.

Changed in gsfonts-x11:
assignee: nobody → dufresnep
status: New → Invalid
Martin Kretzschmar (martink) wrote :

This was not just about xutils being uninstallable (though that's what I said in the first line of the bug report), if it was, I'd have filed it against xutils, of course.

It was also about having a useless dependency. That problem still exists.

Changed in gsfonts-x11:
status: Invalid → New
Paul Dufresne (paulduf) wrote :

In 7.10, we have the following dependencies:
gsfonts-x11: gsfonts, xfonts-utils, xutils
gsfonts: defoma
xfonts-utils: libc6, libfontenc1, libfreetype6, libxfont1, x11-common, xfonts-encodings, zlib1g
xutils: sessreg, x11-common, xcursorgen, xfonts-util, xutils-dev

Note also that xutils description say: "This package smooths upgrades from Ubuntu 5.04 ('Hoary') by ensuring that most miscellaneous utilities traditionally shipped with the sample implementation of X are installed."
Which suggest it may want to install some utilities may want to be installed even if not strictly necessary for the package.

So xmkmf and xcursorgen are not a problem anymore.
This leave only sessreg, that you pretend is not necessary (I have no idea, I am just a bug triager making sure things are clear).

Indeed, xutils just have the directory: usr/share/doc/xutils

So your bug is about xutils as a dependency of gsfonts-x11.
Let's ask maintainer, what he think of this. Confirming.

Changed in gsfonts-x11:
status: New → Confirmed
assignee: dufresnep → nobody
Matthias Klose (doko) wrote :

package should depend on the dependencies of xutils directly, not on the transitional package itself.

Changed in gsfonts-x11:
importance: Undecided → Medium
milestone: none → hardy-alpha-1
Daniel T Chen (crimsun) wrote :

IMHO not a blocker for Alpha 1, as xutils is installable. I'm attaching a debdiff, however, since I'm away from a stable 'net connection until the weekend.

Changed in gsfonts-x11:
status: Confirmed → Fix Committed
Daniel T Chen (crimsun) wrote :

gsfonts-x11 (0.20ubuntu1) hardy; urgency=low

  * Ubuntu-specific changes:
    - debian/control:
      + Handle dist-upgrades to 8.04 LTS by replacing the dependency
        on xutils with one on xfonts-utils and xutils-dev
        (LP: #56008);
      + Adhere to DebianMaintainerField.

 -- Daniel T Chen <email address hidden> Wed, 28 Nov 2007 22:46:57 -0500

Changed in gsfonts-x11:
status: Fix Committed → Fix Released
Changed in gsfonts-x11:
status: Unknown → New
Changed in gsfonts-x11:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.