Manage auto brightness synchronisation

Bug #1273174 reported by Iain Lane
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity System Compositor
Undecided
Unassigned
gsettings-ubuntu-touch-schemas (Ubuntu)
Undecided
Unassigned
unity-system-compositor (Ubuntu)
Undecided
Alberto Aguirre
unity8 (Ubuntu)
Medium
Michael Terry

Bug Description

powerd doesn't handle the saving or restoring of the automatic brightness boolean itself. Something else (likely unity8) should do this.

I'm adding a GSettings boolean which should be monitored and synchronised to powerd using userAutoBrightnessEnable on its D-Bus API.

Related branches

Michał Sawicz (saviq)
Changed in unity8:
status: New → Triaged
importance: Undecided → Medium
Iain Lane (laney)
Changed in gsettings-ubuntu-touch-schemas (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gsettings-ubuntu-touch-schemas - 0.0.1+14.04.20140130.1-0ubuntu1

---------------
gsettings-ubuntu-touch-schemas (0.0.1+14.04.20140130.1-0ubuntu1) trusty; urgency=low

  [ Iain Lane ]
  * Move AccountsService vendor extension schema from ubuntu-system-
    settings.
  * Add the Sound schema (LP: #1265528). (LP: #1265528)
  * Add a key for the automatic brightness state (LP: #1273174)
  * Use current ubuntu-system-settings version to Break/Replace on as
    this is the version that will lose the AS schemas
 -- Ubuntu daily release <email address hidden> Thu, 30 Jan 2014 16:44:57 +0000

Changed in gsettings-ubuntu-touch-schemas (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

At powerd, you need to call the userAutobrightnessEnable method from com.canonical.powerd. You can play with powerd-cli as well if needed.

Michael Terry (mterry)
Changed in unity8:
assignee: nobody → Michael Terry (mterry)
Revision history for this message
Michael Terry (mterry) wrote :

So I gathered from an IRC conversation that the goal here is just to have unity8 proxy that setting to powerd to avoid regressions. And not worry about the multiple-unity8-process problem until a later merge that moves that logic into USC.

Is that right?

Revision history for this message
Iain Lane (laney) wrote : Re: [Bug 1273174] Re: Manage auto brightness synchronisation

On Wed, Mar 26, 2014 at 03:48:11PM -0000, Michael Terry wrote:
> So I gathered from an IRC conversation that the goal here is just to
> have unity8 proxy that setting to powerd to avoid regressions. And not
> worry about the multiple-unity8-process problem until a later merge that
> moves that logic into USC.

It's mainly because the setting needs to be applied at login, when
system-settings can't do it.

> Is that right?

AFAIK yes

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

kevin gunn (kgunn72)
Changed in unity-system-compositor (Ubuntu):
assignee: nobody → Alberto Aguirre (albaguirre)
status: New → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 7.84+14.04.20140327.1-0ubuntu1

---------------
unity8 (7.84+14.04.20140327.1-0ubuntu1) trusty; urgency=low

  [ Michał Sawicz ]
  * Increase kill timeout so that crashes are not truncated.

  [ Ying-Chun Liu ]
  * Fix a small typo in LazyImage: scale -> scaleTo

  [ Albert Astals ]
  * Make geometry calls for autopilot work again -geometry is a internal
    Qt argument that only works for QWidget based apps Before it was
    being returned to us in -args but now it's eaten so we need to use a
    different one, -windowgeometry
  * Make "Recent" translatable and update pot file

  [ Mirco Müller ]
  * Make visual queue of (up to five) snap-decisions contract and expand
    according to visual design-spec.

  [ Michael Terry ]
  * Pass user's preference for auto-brightness on to powerd. (LP:
    #1273174)

  [ Michael Zanetti ]
  * allow executing a single test function example: make testShell
    FUNCTION="Shell::test_background"
 -- Ubuntu daily release <email address hidden> Thu, 27 Mar 2014 12:38:21 +0000

Changed in unity8 (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq)
Changed in unity8:
status: Triaged → Fix Released
Changed in unity-system-compositor:
status: New → Fix Released
Changed in unity-system-compositor (Ubuntu):
status: Triaged → Fix Released
Michał Sawicz (saviq)
Changed in unity8 (Ubuntu):
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Medium
no longer affects: unity8
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers