gsettings-qt 0.2-1 source package in Ubuntu

Changelog

gsettings-qt (0.2-1) unstable; urgency=medium

  * New upstream version.
  * debian/watch:
    + Add file. Pointing to UBports's version of gsettings-qt.
  * debian/{control,compat}:
    + Switch to debhelper-compat notation. Bump DH compat level to version 12.
  * debian/{control,copyright}:
    + Update upstream location according to d/watch file.
  * debian/control:
    + Move maintenance over to UBports team (with Deepin Package Team as
      co-maintainers). (Closes: #951019).
    + Add B:/R: (qml-module-gsettings1.0): qtdeclarative5-gsettings1.0
      (<< 0.2~).
    + Bump Standards-Version: to 4.5.0. No changes needed.
    + Add Rules-Requires-Root: field and set it to 'no'.
  * debian/rules:
    + Add get-orig-source target.
  * debian/patches:
    + 0005-bugfix-about-test-cases.patch: Trivial rebase.
    + Adapt patch file names to our patch file naming scheme.
    + Add README file, explaining our patch naming scheme.
    + Add 2001_keep-com.canonical-DBus-namespace.patch. Switch back to
      com.canonical.gsettings DBus namespace to not break co-funtionality
      with other non-Unity Qt5 based environments and components (e.g. Deepin
      Desktop Environment).
  * debian/upstream/metadata:
    + Add file. Comply with DEP-12.
  * debian/libgsettings-qt1.symbols:
    + Add Build-Depends-Package: meta data field.
    + Update symbols file (for amd64 only for now).

 -- Mike Gabriel <email address hidden>  Tue, 18 Feb 2020 15:26:18 +0100

Upload details

Uploaded by:
Debian UBports Team on 2020-02-18
Uploaded to:
Sid
Original maintainer:
Debian UBports Team
Architectures:
any
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Focal release on 2020-02-19 universe libs

Downloads

File Size SHA-256 Checksum
gsettings-qt_0.2-1.dsc 2.4 KiB c7cbb5172fd470338d9c095027b35eb8f66e9036895d92be8616ffbea0a08c93
gsettings-qt_0.2.orig.tar.gz 18.5 KiB 1ee20cc73f0c3c6afc6910e6b60fd1236e6bcc42920f7b2442aca208914cd7f8
gsettings-qt_0.2-1.debian.tar.xz 9.0 KiB 5db5d176111fe8194a3fadaa1b8b7ed97a55f168db3037570da2f71449c083c1

No changes file available.

Binary packages built by this source

libgsettings-qt-dev: library to access GSettings from Qt (development files)

 Libgsettings-qt provides Qt binding to GSettings, a high-level API
 for application settings. This library can be used to access GSettings from Qt
 applications.
 .
 This package contains the development files needed to build applications using
 the GSettings Qt library.

libgsettings-qt1: library to access GSettings from Qt (shared libraries)

 Libgsettings-qt provides Qt binding to GSettings, a high-level API
 for application settings. This library can be used to access GSettings from Qt
 applications.
 .
 This package contains shared library files for libgsettings-qt.

libgsettings-qt1-dbgsym: debug symbols for libgsettings-qt1
qml-module-gsettings1.0: QML Bindings for GSettings

 Libgsettings-qt provides Qt binding to GSettings, a high-level API
 for application settings. This library can be used to access GSettings from Qt
 applications.
 .
 This package provides QML bindings for GSettings. QML applications
 may use this library to manipulate data stored in GSettings database.

qml-module-gsettings1.0-dbgsym: debug symbols for qml-module-gsettings1.0