Firefox 11.04.1 does not use the gnome-proxy-settings

Bug #956961 reported by Ralph Holzer on 2012-03-16
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gsettings-desktop-schemas (Ubuntu)
Undecided
Unassigned
Natty
Medium
Unassigned

Bug Description

Since the automatic upgrade from 10.0.2,to 10.04.1 Firefox ignores the gnome-proxy-settings and so could not find the way to the Internet.
When I set the proxy-settings manual it works. It also works with the Chrome-Browser. Websites inside our network work.

You could reproduce it by:
Set the system wide proxy-settings in gnome.
Change your proxy-settings in firefox: Edit > Preferences > Network > Settings > "Use system proxy settings"
Only internal websites works with this configuration...
To get them working you have to set the settings manual in: Edit > Preferences > Network > Settings > "Manual proxy configuration"

Description: Ubuntu 11.04 Release: 11.04

I upgraded this package :
Upgrade: firefox-globalmenu:i386 (10.0.2+build1-0ubuntu0.11.04.1, 11.0+build1-0ubuntu0.11.04.1), firefox:i386 (10.0.2+build1-0ubuntu0.11.04.1, 11.0+build1-0ubuntu0.11.04.1), firefox-gnome-support:i386 (10.0.2+build1-0ubuntu0.11.04.1, 11.0+build1-0ubuntu0.11.04.1), xul-ext-ubufox:i386 (0.9.3-0ubuntu0.11.04.1, 0.9.4-0ubuntu1), firefox-locale-de:i386 (10.0.2+build1-0ubuntu0.11.04.1, 11.0+build1-0ubuntu0.11.04.1), firefox-locale-en:i386 (10.0.2+build1-0ubuntu0.11.04.1, 11.0+build1-0ubuntu0.11.04.1)
End-Date: 2012-03-16 14:06:17

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in firefox (Ubuntu):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

Do you have the gsettings-desktop-schemas package installed by any chance?

Changed in firefox (Ubuntu):
status: Confirmed → Incomplete
Ralph Holzer (ralph-holzer) wrote :

gsettings-desktop-schemas is installed, Version: 3.0.0-0ubuntu1

Chris Coulson (chrisccoulson) wrote :

Please remove it. I bet it will work again

affects: firefox (Ubuntu) → gsettings-desktop-schemas (Ubuntu)
Changed in gsettings-desktop-schemas (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
affects: gsettings-desktop-schemas (Ubuntu) → ubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gsettings-desktop-schemas (Ubuntu Natty):
status: New → Confirmed
affects: ubuntu → gsettings-desktop-schemas (Ubuntu)
Changed in gsettings-desktop-schemas (Ubuntu):
status: Triaged → Invalid
Changed in gsettings-desktop-schemas (Ubuntu Natty):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in gsettings-desktop-schemas (Ubuntu):
importance: Medium → Undecided
Chris Coulson (chrisccoulson) wrote :

Could you please make sure that proxy settings work correctly with the gsettings-desktop-schemas package in https://launchpad.net/~ubuntu-mozilla-security/+archive/ppa?

Ralph Holzer (ralph-holzer) wrote :

I removed gsettings-desktop-schemas, and no Firefox finds the system-wide-proxy settings again !

Thanks, that solved the problem for me.

Chris Coulson (chrisccoulson) wrote :

You can install it again from the link in comment 6 if you like. We'll push that out as an update in any case

Ralph Holzer (ralph-holzer) wrote :

Installinf the new gsettings-desktop-schemas_3.0.0-0ubuntu1.1_all.deb worked also :-)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gsettings-desktop-schemas - 3.0.0-0ubuntu1.1

---------------
gsettings-desktop-schemas (3.0.0-0ubuntu1.1) natty-security; urgency=low

  * Fix LP: #956961 - Firefox 11 doesn't use system proxy settings anymore
    in Ubuntu 11.04. By default in Ubuntu 11.04, we install the proxy settings
    schema even though it isn't consumed by anything. Now that Firefox uses
    gsettings for the proxy settings (if the schema exists), having the schema
    installed breaks things in 11.04. Note that the same is also true for the
    background settings, so we drop both the proxy and background schemas
    from this package
    - update debian/rules
 -- Chris Coulson <email address hidden> Fri, 23 Mar 2012 09:52:28 +0000

Changed in gsettings-desktop-schemas (Ubuntu Natty):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers