Two-finger right click does not work in gnome-shell

Bug #1699033 reported by Daniel van Vugt on 2017-06-20
This bug affects 11 people
Affects Status Importance Assigned to Milestone
GSettings Desktop Schemas
Fix Released
gsettings-desktop-schemas (Ubuntu)

Bug Description

Using two fingers on the clickpad to right click does not work in gnome-shell.

It seems to be defaulting to the old-style single finger click in the bottom right corner to do a right click.

gnome-tweak-tool > Keyboard & Mouse > Touchpad > Click Method = Fingers

Gsettings diff:
< org.gnome.desktop.peripherals.touchpad click-method 'default'
> org.gnome.desktop.peripherals.touchpad click-method 'fingers'

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-shell 3.24.2-0ubuntu6
ProcVersionSignature: Ubuntu 4.11.0-7.12-generic 4.11.6
Uname: Linux 4.11.0-7-generic x86_64
ApportVersion: 2.20.5-0ubuntu4
Architecture: amd64
Date: Tue Jun 20 14:50:10 2017
DisplayManager: lightdm
GsettingsChanges: b'org.gnome.desktop.interface' b'gtk-im-module' b"'gtk-im-context-simple'"
InstallationDate: Installed on 2017-06-20 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170613)
SourcePackage: gnome-shell
UpgradeStatus: No upgrade log present (probably fresh install)

Daniel van Vugt (vanvugt) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
Tomjleo (tomjleo) wrote :

Thanks Daniel van Vugt! Ubuntu Tweaks "gnome-tweak-tool" workaround fixed this issue for me.

summary: - Two-finger right click does not work in 17.10 gnome-shell
+ Two-finger right click does not work in gnome-shell
Daniel van Vugt (vanvugt) wrote :

Good news:

"In GNOME 3.27.90, the GNOME default mouse click emulation on touchpads will change from 'default' to 'fingers'."


Jeremy Bicha (jbicha) on 2018-01-31
affects: gnome-shell (Ubuntu) → gsettings-desktop-schemas (Ubuntu)
Changed in gsettings-desktop-schemas (Ubuntu):
status: Confirmed → Fix Committed
Changed in gsettings-desktop-schemas:
importance: Unknown → Medium
status: Unknown → Fix Released
Jeremy Bicha (jbicha) wrote :

I forgot to close this bug in my gsettings-desktop-schemas upload yesterday.

I included a bit of background about this change at

Changed in gsettings-desktop-schemas (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :


Although to refer to clickpads as a "Mac" feature that's new to Windows laptops is probably a bit outdated. Most laptops, for many years of late, fall into this category.

Eugene Savelov (savelov) wrote :

strangely I think that defaulting to two-fingers click as a right mouse button is not apparent to me - and I was not able to find switch between two-finger click and right in standard settings in 18.04, instead it exists only in gnome-tweak-tool. if this is really new behaviour, it makes sense to include this setting in basic ubuntu mouse settings

Daniel van Vugt (vanvugt) wrote :

I completely agree. It is annoying that basic settings are missing in the Settings app.

If it bothers you enough then please log a bug directly with the upstream developers in their new bug tracker:

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.