Reenable G4 compression in gscan2pdf

Bug #1784120 reported by Thomas Mayer on 2018-07-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gscan2pdf (Ubuntu)
Undecided
Unassigned

Bug Description

A while ago, I reported a regression because G4 compression did not work any more in recent versions of ubuntu: https://bugs.launchpad.net/ubuntu/+source/gscan2pdf/+bug/482673 .

My bug report led to the disablement of G4 compression. This somehow restores user satisfaction, but if I remember right, G4 compression had much better results in Black/white (2 colors) color mode than all the other compression algorithms. I also think that the bug not originates in gscan2pdf itself but either in a library which is used by gscan2pdf or in wrong usage of the interface of such a library.

Now that G4 compression worked perfectly fine in earlier versions of ubuntu and gscan2pdf, my question would be if G4 compression could please be enabled again.

It might even happen that just by reverting the older patch (for 482673) already does the trick in case the library has been fixed in the meantime (which is many years in that case).

Currently, I'm using ubuntu 16.04 and gscan2pdf 1.3.9, but I'm planning to upgrade to ubuntu 18.04 soon.

The reason G4 worked in the past was that it used tiff2pdf in the background. I switched to using PDF::API2 for the PDF engine in order to allow the use of the OCR layer behind the image.

Unfortunately, up to now, PDF::API2 has buggy G4 TIFF support, and so I disabled the G4 compression option in gscan2pdf.

I have provided patches to the author of PDF::API2 to allow much better TIFF support, but these have not yet been accepted by the maintainer of PDF::API2.

In the mean time, which later version of gscan2pdf still do not support G4, you would find lost of new features and bug fixes if you upgraded via the PPA.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers