[GPL GS WORKS] Printer cuts off larger letters (W,Ü,Ö) at the top or the right side.

Bug #82813 reported by Andreas Ermler on 2007-02-02
2
Affects Status Importance Assigned to Milestone
gs-esp (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gs-esp

I am using Ubuntu Edgy Eft and have a Samsung ML-1610 printer and I'm using the Samsung ML-1610 Foomatic/gdi driver. When printing text from OpenOffice.org or printing pdfs with KPDF or Acrobat Reader, when using certain fonts (like Bitstream Vera), it cuts off letters like W at the right side (the last mm) and letters like the German Umlauts Ü at the top, so you can't see the dots on top.
They seem to have the same problem: http://ubuntuforums.org/showthread.php?t=300250 and in this thread there is a picture with an example of what I mean: http://forum.ubuntu-fr.org/viewtopic.php?id=80770
I downloaded an older Version of this package (7.07.1) from an older Ubuntu-Version and installed it. It broke some of my dependencies, but now printing works fine. So it seems to me that the problem is somehow connected to version 8.15.2 of this package.

Andreas Ermler (aermler) on 2007-02-02
description: updated
Till Kamppeter (till-kamppeter) wrote :

Do

sudo apt-get install gs-gpl
sudo update-alternatives gs

The second command presents a menu, choose gs-gpl there. Can you still reproduce the bug? Or can you print correctly now? Please post the file(s) which caused the problem, so that it/they can be added to the regression testing at ghostscript.com.

To return to use of ESP GhostScript do

sudo update-alternatives gs

and choosing gs-esp.

Changed in gs-esp:
status: Unconfirmed → Needs Info
Andreas Ermler (aermler) wrote :

When I do that it says:
update-alternatives: unknown argument `gs'

The file I attached is an odt-file I just created. When I print it, the right side of the W is cut off a little and the dots of the Ä and Ö are cut off almost completely. The same happens when I export it as a pdf-file and print it again.

Btw: I tested the livecd of Ubuntu 7.04 and there the problem doesn't exist anymore.

Till Kamppeter (till-kamppeter) wrote :

Sorry, must mean (forgot the "--config")

sudo apt-get install gs-gpl
sudo update-alternatives --config gs

and then choose gs-gpl.

Till Kamppeter (till-kamppeter) wrote :

If you cannot print at all with gs-gpl, try the following GPL GhostScript, as it has merged in all printer drivers:

http://www.openprinting.org/download/printing/esp-gpl-ghostscript-merge/README

The page contains all instructions to install it.

Andreas Ermler (aermler) wrote :

Ok, I switched to gs-gpl, but then I couldn't print anymore. There was no error message and Cups said that it printed, but my printer didn't do anything.
I then installed GPL GhostScript, followed all of the instructions, but it didn't print either. Also no error messages and Cups said that everything went ok.

Till Kamppeter (till-kamppeter) wrote :

Can you try with the new gs-gpl packages?

Download all packages from

http://www.linux-foundation.org/~till/tmp/ubuntu/gutsy/gs-gpl/binary/

and do

sudo dpkg -i *gs-esp*.deb *gs-gpl*.deb

to replace your ESP Ghostscript by the new GPL Ghostscript.

Andreas Ermler (aermler) wrote :

Ok, I tried it. But when I installed it there were some dependency problems and it doesn't print:

dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gs-gpl:
 gs-gpl hängt ab von libc6 (>= 2.5-5); aber:
  Version of libc6 on system is 2.4-1ubuntu12.3.
dpkg: Fehler beim Bearbeiten von gs-gpl (--install):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gs-gpl-x:
 gs-gpl-x hängt ab von libc6 (>= 2.5-5); aber:
  Version of libc6 on system is 2.4-1ubuntu12.3.
 gs-gpl-x hängt ab von gs-gpl (>= 8.60); aber:
  Package gs-gpl is not configured yet.
dpkg: Fehler beim Bearbeiten von gs-gpl-x (--install):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgs-gpl8:
 libgs-gpl8 hängt ab von libc6 (>= 2.5-5); aber:
  Version of libc6 on system is 2.4-1ubuntu12.3.
 libgs-gpl8 hängt ab von libcupsimage2 (>= 1.2.5); aber:
  Version of libcupsimage2 on system is 1.2.4-2ubuntu3.
 libgs-gpl8 hängt ab von libcupsys2 (>= 1.2.7); aber:
  Version of libcupsys2 on system is 1.2.4-2ubuntu3.
 libgs-gpl8 hängt ab von libgnutls13 (>= 1.5.3-0); aber:
  Version of libgnutls13 on system is 1.4.0-3ubuntu1.
 libgs-gpl8 hängt ab von libpng12-0 (>= 1.2.13-4); aber:
  Version of libpng12-0 on system is 1.2.8rel-5.1ubuntu0.1.
 libgs-gpl8 hängt ab von libstdc++6 (>= 4.2-20070208); aber:
  Version of libstdc++6 on system is 4.1.1-13ubuntu5.
dpkg: Fehler beim Bearbeiten von libgs-gpl8 (--install):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgs-gpl-dev
:
 libgs-gpl-dev hängt ab von libgs-gpl8; aber:
  Package libgs-gpl8 is not configured yet.
dpkg: Fehler beim Bearbeiten von libgs-gpl-dev (--install):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gs-esp:
 gs-esp hängt ab von gs-gpl; aber:
  Package gs-gpl is not configured yet.
dpkg: Fehler beim Bearbeiten von gs-esp (--install):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gs-esp-x:
 gs-esp-x hängt ab von gs-gpl-x; aber:
  Package gs-gpl-x is not configured yet.
dpkg: Fehler beim Bearbeiten von gs-esp-x (--install):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libgs-esp-dev
:
 libgs-esp-dev hängt ab von libgs-gpl-dev; aber:
  Package libgs-gpl-dev is not configured yet.
dpkg: Fehler beim Bearbeiten von libgs-esp-dev (--install):
 Abhängigkeitsprobleme - lasse es unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 gs-gpl
 gs-gpl-x
 libgs-gpl8
 libgs-gpl-dev
 gs-esp
 gs-esp-x
 libgs-esp-dev

Till Kamppeter (till-kamppeter) wrote :

These packages are for gutsy. If you are on Feisty or earlier, you can either try to use distribution-independent packages or compile from upstream source (both described on http://www.openprinting.org/download/printing/esp-gpl-ghostscript-merge/README) or rebuild the Ubuntu packages.

To rebuild the Ubuntu packages download the files from

http://www.openprinting.org/download/printing/esp-gpl-ghostscript-merge/

into the same directory. Then do

sudo apt-get install build-essential
sudo apt-get build-dep gs-esp gs-gpl
dpkg-source -x gs-gpl_8.60.dfsg.1-0ubuntu1.dsc
cd gs-gpl-8.60.dfsg.1
dpkg-buildpackage -rfakeroot
cd ..
sudo dpkg -i *gs-esp*.deb *gs-gpl*.deb

Answer every question which appears with "y", so that all needed packages get installed.

Till Kamppeter (till-kamppeter) wrote :

I have tested with GPL Ghostscript 8.60 and it works correctly for me.

Changed in gs-esp:
status: Needs Info → Fix Committed
Changed in gs-esp:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments