gs with KRGB patch segfaults on certain PS files

Bug #69905 reported by Brian J. Murrell on 2006-11-02
16
Affects Status Importance Assigned to Milestone
GS-GPL
Fix Released
Medium
HPLIP
Undecided
Unassigned
ghostscript (Ubuntu)
Medium
Unassigned
gs-esp (Ubuntu)
Medium
Unassigned

Bug Description

While debugging a printing problem I discovered that gs segfaults on feisty:

$ gs -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="DESKJET 930" -dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792 -dDuplex=false -r300 -sIjsParams=Quality:Quality=0,Quality:ColorMode=0,Quality:MediaType=0,Quality:PenSet=2 -dIjsUseOutputFD -sOutputFile=- ~/fea19b.ps
Segmentation fault (core dumped)

I will attach the core file after I create this ticket.

Related branches

No movement on this bug? Not even a triage?

This is a showstopper for printing in fiesty! Edgy perhaps even if gs has not been updated for fiesty.

Till Kamppeter (till-kamppeter) wrote :

I cannot reproduce it, can you attach the PostScript which you tried to print?

Changed in gs-esp:
importance: Undecided → Medium
status: Unconfirmed → Needs Info

Sure. It's worth noting that evince on edgy renders this file but evince on feisty does not. Probably because it's rendering engine segfaults on it too.

Till Kamppeter (till-kamppeter) wrote :

The gs-esp version which I am actually using is this one:

http://www.linux-foundation.org/~till/tmp/ubuntu/feisty/gs-esp/binary/

Can you test whether this works for you?

Till Kamppeter (till-kamppeter) wrote :

With your PostScript file I can reproduce the segfault also with my new packages.

Till Kamppeter (till-kamppeter) wrote :

Your file seems somewhat broken, as when sending it to an HP LaserJet 3390 it does not print correctly, but GhostScript should not segfault on a bad file.

Screen display with gs-esp works.

On Wed, 2007-01-24 at 23:53 +0000, Till Kamppeter wrote:
> With your PostScript file I can reproduce the segfault also with my new
> packages.

Ahhh. Good. An important and good first step towards a solution.

Till, can I ask, are you still working for Mandriva or are you working
for Ubuntu now?

b.

--
My other computer is your Microsoft Windows server.

Brian J. Murrell

For the record, this segfaults in Mandriva 2007.0 too, so this looks like it's upstream.

Can you try also whether the problem occurs with gs-gpl, so that I know on which upstream level this needs to be reported.

For me it crashes also with gs-gpl:

---------------------------------------------------------------------------------------------------------
till@till-laptop:~/ubuntu/gutenprint/gutenprint-5.0.0+cvs20070127$ gs-gpl -q -dBATCH -dPARANOIDSAFER -dQUIET -dNOPAUSE -sDEVICE=ijs -sIjsServer=hpijs -sDeviceManufacturer="HEWLETT-PACKARD" -sDeviceModel="DESKJET 930" -dDEVICEWIDTHPOINTS=612 -dDEVICEHEIGHTPOINTS=792 -dDuplex=false -r300 -sIjsParams=Quality:Quality=0,Quality:ColorMode=0,Quality:MediaType=0,Quality:PenSet=2 -dIjsUseOutputFD -sOutputFile=- ~/printing/fea19b.ps
Segmentation fault (core dumped)
till@till-laptop:~/ubuntu/gutenprint/gutenprint-5.0.0+cvs20070127$ unable to read client data err=-2
---------------------------------------------------------------------------------------------------------

So it I will report it on www.ghostscipt.com

Changed in gs-gpl:
status: Unconfirmed → Confirmed
Changed in gs-esp:
status: Needs Info → Confirmed
Changed in gs-gpl:
importance: Undecided → Medium
Changed in gs-gpl:
status: Unknown → Unconfirmed

This one works with the current Subversion snapshot of GPL GhostScript.

This breaks when applying the KRGB patch to the current Subversion snapshot of GPL GhostScript.

KRGB patch for GhostScript 8.5x:

http://www.linuxprinting.org/download/printing/esp-gpl-ghostscript-merge/ghostscript-8.57-ijs-krgb.patch

As this patch is developed and maintained by the HPLIP team from HP I forward the bug report to the HP folks.

ESP Ghostscript is not developed upstream any more and replaced by GPL Ghostscript -> removing gs-esp task

Changed in gs-esp:
status: Confirmed → Rejected
Changed in gs-gpl:
status: New → Confirmed

Confirmed this isn't a problem with HPLIP and that it's upstream. Setting to invalid.

A

Changed in hplip:
status: New → Invalid

I got a patch from HP which fixes this bug. I will apply the patch to the next ghostscript package.

Changed in ghostscript:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ghostscript - 8.61.dfsg.1-0ubuntu4

---------------
ghostscript (8.61.dfsg.1-0ubuntu4) hardy; urgency=low

  * debian/patches/09_ijs_krgb_support.dpatch: Updated the KRGB patch from
    HP to the newest upstream version with added checks for null forward
    device in the graphic procedures to fix segfault bug LP: #69905 and
    corrected "force banding" code in gsijs_open for small images (IE:
    hagaki in landscape).

 -- Till Kamppeter <email address hidden> Wed, 23 Jan 2008 13:17:43 +0000

Changed in ghostscript:
status: In Progress → Fix Released
Changed in gs-gpl:
status: Confirmed → Fix Released
Changed in gs-gpl:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.