distribution upgrade from 9.10 over 11.10 to 12.04 - grub failed to install

Bug #986632 reported by Marcelo Abadie on 2012-04-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Low
Unassigned

Bug Description

Upgraded 9.10 to 11.04 and then to 12.04

package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: grub-pc-bin
ProcVersionSignature: Ubuntu 2.6.32-40.87-generic 2.6.32.57+drm33.23
Uname: Linux 2.6.32-40-generic i686
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
Date: Sat Apr 21 08:51:26 2012
DeviceMap:
 (hd0) /dev/disk/by-id/ata-MAXTOR_STM3320820AS_9QF8CS5W
 (hd1) /dev/disk/by-id/ata-SAMSUNG_SP0842N_S0DWJ40L347763
 (hd2) /dev/disk/by-id/usb-Kingston_DT_101_II_001372982F25F9B046400D08-0:0
ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-40-generic root=UUID=e01361e5-1559-4b08-8a19-81840a86e040 ro quiet splash
SourcePackage: grub2
Title: package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured
UpgradeStatus: Upgraded to precise on 2012-04-21 (0 days ago)

Marcelo Abadie (marceabadie) wrote :
Sasa Paporovic (melchiaros) wrote :

Please attach

/var/log/dist-upgrade

as compressed folder here.

Thank you in advance.

tags: added: dist-upgrade
description: updated
Changed in grub2 (Ubuntu):
status: New → Incomplete
summary: - package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade:
- ErrorMessage: dependency problems - leaving unconfigured
+ distribution upgrade from 9.10 over 11.10 to 12.04 - grub failed to
+ install
Download full text (3.5 KiB)

Thanks!

Enviado desde mi iPhone

El 22/04/2012, a las 11:55, melchiaros <email address hidden> escribió:

> Please attach
>
> /var/log/dist-upgrade
>
> as compressed folder here.
>
> Thank you in advance.
>
> ** Tags added: dist-upgrade
>
> ** Description changed:
>
> Upgraded 9.10 to 11.04 and then to 12.04
> +
> + package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade:
> + ErrorMessage: dependency problems - leaving unconfigured
> +
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: grub-pc-bin
> ProcVersionSignature: Ubuntu 2.6.32-40.87-generic 2.6.32.57+drm33.23
> Uname: Linux 2.6.32-40-generic i686
> ApportVersion: 2.0.1-0ubuntu5
> Architecture: i386
> Date: Sat Apr 21 08:51:26 2012
> DeviceMap:
> - (hd0) /dev/disk/by-id/ata-MAXTOR_STM3320820AS_9QF8CS5W
> - (hd1) /dev/disk/by-id/ata-SAMSUNG_SP0842N_S0DWJ40L347763
> - (hd2) /dev/disk/by-id/usb-Kingston_DT_101_II_001372982F25F9B046400D08-0:0
> + (hd0) /dev/disk/by-id/ata-MAXTOR_STM3320820AS_9QF8CS5W
> + (hd1) /dev/disk/by-id/ata-SAMSUNG_SP0842N_S0DWJ40L347763
> + (hd2) /dev/disk/by-id/usb-Kingston_DT_101_II_001372982F25F9B046400D08-0:0
> ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-40-generic root=UUID=e01361e5-1559-4b08-8a19-81840a86e040 ro quiet splash
> SourcePackage: grub2
> Title: package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured
> UpgradeStatus: Upgraded to precise on 2012-04-21 (0 days ago)
>
> ** Changed in: grub2 (Ubuntu)
> Status: New => Incomplete
>
> ** Summary changed:
>
> - package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade: ErrorMessage: dependency problems - leaving unconfigured
> + distribution upgrade from 9.10 over 11.10 to 12.04 - grub failed to install
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/986632
>
> Title:
> distribution upgrade from 9.10 over 11.10 to 12.04 - grub failed to
> install
>
> Status in “grub2” package in Ubuntu:
> Incomplete
>
> Bug description:
> Upgraded 9.10 to 11.04 and then to 12.04
>
> package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade:
> ErrorMessage: dependency problems - leaving unconfigured
>
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: grub-pc-bin
> ProcVersionSignature: Ubuntu 2.6.32-40.87-generic 2.6.32.57+drm33.23
> Uname: Linux 2.6.32-40-generic i686
> ApportVersion: 2.0.1-0ubuntu5
> Architecture: i386
> Date: Sat Apr 21 08:51:26 2012
> DeviceMap:
> (hd0) /dev/disk/by-id/ata-MAXTOR_STM3320820AS_9QF8CS5W
> (hd1) /dev/disk/by-id/ata-SAMSUNG_SP0842N_S0DWJ40L347763
> (hd2) /dev/disk/by-id/usb-Kingston_DT_101_II_001372982F25F9B046400D08-0:0
> ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-40-generic root=UUID=e01361e5-1559-4b08-8a19-81840a86e040 r...

Read more...

Marcelo Abadie (marceabadie) wrote :
Download full text (3.5 KiB)

Here it goes. Thanks again

2012/4/22 melchiaros <email address hidden>

> Please attach
>
> /var/log/dist-upgrade
>
> as compressed folder here.
>
> Thank you in advance.
>
> ** Tags added: dist-upgrade
>
> ** Description changed:
>
> Upgraded 9.10 to 11.04 and then to 12.04
> +
> + package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade:
> + ErrorMessage: dependency problems - leaving unconfigured
> +
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: grub-pc-bin
> ProcVersionSignature: Ubuntu 2.6.32-40.87-generic 2.6.32.57+drm33.23
> Uname: Linux 2.6.32-40-generic i686
> ApportVersion: 2.0.1-0ubuntu5
> Architecture: i386
> Date: Sat Apr 21 08:51:26 2012
> DeviceMap:
> - (hd0) /dev/disk/by-id/ata-MAXTOR_STM3320820AS_9QF8CS5W
> - (hd1) /dev/disk/by-id/ata-SAMSUNG_SP0842N_S0DWJ40L347763
> - (hd2)
> /dev/disk/by-id/usb-Kingston_DT_101_II_001372982F25F9B046400D08-0:0
> + (hd0) /dev/disk/by-id/ata-MAXTOR_STM3320820AS_9QF8CS5W
> + (hd1) /dev/disk/by-id/ata-SAMSUNG_SP0842N_S0DWJ40L347763
> + (hd2)
> /dev/disk/by-id/usb-Kingston_DT_101_II_001372982F25F9B046400D08-0:0
> ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-40-generic
> root=UUID=e01361e5-1559-4b08-8a19-81840a86e040 ro quiet splash
> SourcePackage: grub2
> Title: package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade:
> ErrorMessage: dependency problems - leaving unconfigured
> UpgradeStatus: Upgraded to precise on 2012-04-21 (0 days ago)
>
> ** Changed in: grub2 (Ubuntu)
> Status: New => Incomplete
>
> ** Summary changed:
>
> - package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade:
> ErrorMessage: dependency problems - leaving unconfigured
> + distribution upgrade from 9.10 over 11.10 to 12.04 - grub failed to
> install
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/986632
>
> Title:
> distribution upgrade from 9.10 over 11.10 to 12.04 - grub failed to
> install
>
> Status in “grub2” package in Ubuntu:
> Incomplete
>
> Bug description:
> Upgraded 9.10 to 11.04 and then to 12.04
>
> package grub-pc-bin 1.99-21ubuntu3 failed to install/upgrade:
> ErrorMessage: dependency problems - leaving unconfigured
>
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.04
> Package: grub-pc-bin
> ProcVersionSignature: Ubuntu 2.6.32-40.87-generic 2.6.32.57+drm33.23
> Uname: Linux 2.6.32-40-generic i686
> ApportVersion: 2.0.1-0ubuntu5
> Architecture: i386
> Date: Sat Apr 21 08:51:26 2012
> DeviceMap:
> (hd0) /dev/disk/by-id/ata-MAXTOR_STM3320820AS_9QF8CS5W
> (hd1) /dev/disk/by-id/ata-SAMSUNG_SP0842N_S0DWJ40L347763
> (hd2)
> /dev/disk/by-id/usb-Kingston_DT_101_II_001372982F25F9B046400D08-0:0
> ErrorMessage: ErrorMessage: dependency problems - leaving unconfigured
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> ProcCmdLine: BOOT_IMAGE=/vmlinuz-2.6.32-40-generic
> root=UUID=e01361e5-1559-4b08-8a19-81840a86e040 ro quiet splash
> So...

Read more...

Changed in grub2 (Ubuntu):
status: Incomplete → Confirmed
Brian Murray (brian-murray) wrote :

From VarLogDistupgradeApttermlog.gz:
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.2.0-23-generic /boot/vmlinuz-3.2.0-23-generic
update-initramfs: Generating /boot/initrd.img-3.2.0-23-generic

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-3.2.0-23-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.2.0-23-generic.postinst line 1010.
dpkg: error processing linux-image-3.2.0-23-generic (--configure):
 subprocess installed post-installation script returned error exit status 2

Changed in grub2 (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → Low
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that there was an error on your system when trying to update the kernel on your system due to a lack of free space in your boot partition. Please resolve this situation manually and try the update again.

tags: added: no-boot-space
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers