package grub-pc 1.99-21ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Bug #984530 reported by Cariboo1938
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
grub2 (Ubuntu)
Expired
Low
Unassigned

Bug Description

I can not exactly say when the error occurred --- I was about to run Update Manager!
1)
jg@HP-Pavilion-g6-1b67ca:~$ lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04
2)
jg@HP-Pavilion-g6-1b67ca:~$ apt-cache policy update-manager
update-manager:
  Installed: 1:0.156.11
  Candidate: 1:0.156.13
  Version table:
     1:0.156.13 0
        500 http://ca.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
 *** 1:0.156.11 0
        100 /var/lib/dpkg/status

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: grub-pc 1.99-21ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
ApportVersion: 2.0.1-0ubuntu4
AptOrdering:
 hardinfo: Install
 lm-sensors: Install
 grub-pc: Configure
 hardinfo: Configure
 lm-sensors: Configure
Architecture: amd64
Date: Tue Apr 17 20:01:42 2012
ErrorMessage: subprocess installed post-installation script returned error exit status 2
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120328)
InvalidGrubScript: /etc/grub.d/30_os-prober
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=0ccd3df4-ef2b-4c41-ae46-fc008cc5a1bb ro quiet splash vt.handoff=7
SourcePackage: grub2
Title: package grub-pc 1.99-21ubuntu3 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Cariboo1938 (jgrauca) wrote :
affects: ubuntu → grub2 (Ubuntu)
tags: removed: need-duplicate-check
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in grub2 (Ubuntu):
status: New → Confirmed
Revision history for this message
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Reviewing your log files attached to this bug report it seems that there is a problem in the configuration of your '/etc/default/grub' file. Keep in mind than any kernel parameters should have double quotes around them like so: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Please review your changes to '/etc/default/grub' and try running 'sudo update-grub' again. In the event they you are able to resolve your issue please set this bug's status to Invalid. If you are not able to resolve the issue please attach the file '/etc/default/grub' to the bug report. Thanks and good luck!

Changed in grub2 (Ubuntu):
status: Confirmed → Incomplete
importance: Undecided → Low
tags: added: syntax-error
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for grub2 (Ubuntu) because there has been no activity for 60 days.]

Changed in grub2 (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers